Bug? The 1vs1 'trade'. Does Lemondogs deserve to lose ESWC?

Discuss everything related to Shootmania.

Moderator: English Moderator

TheM
Posts: 1445
Joined: 15 Jun 2010, 14:30
Location: Uden, Noord-Brabant, Netherlands
Contact:

Re: Bug? The 1vs1 'trade'. Does Lemondogs deserve to lose ES

Post by TheM » 28 Feb 2014, 21:18

I've removed both your messages and I hope that you're not going to behave like this again.
You don't need to list all what you do here, it doesn't make you better than others.
Do not swear on the forum, it doesn't belong here!

Now please continue about the topic instead of yourself.
Global moderator | Dutch moderator | Laddermoderator | ManiaWiki moderator
Server Manager/webmaster of Smurfen.net, join us on Canyon, Valley and Royal!
ESL (Game) Staff Head for TrackMania (Stadium, Canyon and Valley).

gAHNZBY
Posts: 2
Joined: 07 Aug 2013, 20:50

Re: Bug? The 1vs1 'trade'. Does Lemondogs deserve to lose ES

Post by gAHNZBY » 04 Mar 2014, 16:08

Nice analysis and well written sens :thumbsup: . It kinda sucks knowing that this particular moment could have changed everything afterwards. I've always thought these kinda stuff only happens when its like less than 1 millisecond that differs from the laser and rocket hit. But seeing this now and it differs 2-4 milliseconds it makes me wonder why this hasn't been fixed yet.

Anyways, I havn't read everything that the Nadeo guys have said in this thread so I'm going to stop here. I'm also glad that someone took the initiative to bring this up because it is a problem right now since I get to see this "bug" quite frequently. *LOOKING FORWARD TO THE UPDATE*

pksens
Posts: 107
Joined: 11 Sep 2012, 13:12

Re: Bug? The 1vs1 'trade'. Does Lemondogs deserve to lose ES

Post by pksens » 12 Mar 2014, 03:33

This Update which will fix things? who knows. All we know are indefinite delays to the patches.
Every single match there is something kind of wrong happens with the game which is out of your control and the more you play, the more you look out for it, the more visible it is. It's always there I think, this discrepancy of what you see and what happens. Everyone knows the shots (lasers going through, rockets going through, bounces not working, capping when he was visibly off pole, or not capping whilst on pole, etc.) All of these things tell you one thing in common: The enemy you see is not where he is in 'server reality' - ie the player might be 2-3 meters in different direction at ANY GIVEN TIME and what you shoot at is at the mercy of pure randomness.


Heres me shooting a rocket through someone
http://i.imgur.com/DAPxwwG.jpg
What happened? Well, I saw the wrong information on my screen. In reality he was
http://i.imgur.com/nWLIu1e.jpg
Combined & synced vid http://youtu.be/dVj020Vpai8 . Looks fun right? The guy on the right is server replay, the guy on left is what I saw ingame and shot my rocket at. This moment is something truly to behold ...

Well what about how random the rockets you shoot? It's been obvious since we switched from Beta 2 that rockets you fire feel delayed on times and you can't be accurate all the time.
In any given replay you can produce these results:
Take screenshot of moment you hear the sound when you fire:
http://i.imgur.com/RGU0A0X.jpg and compare time delay to the rocket being fired:
http://i.imgur.com/6mxviNw.jpg . 40 ms !! incredible! I remember playing with 56k modem in UT and my shots having less delay! Most of the time it is 10-20ms as shown as:
http://i.imgur.com/WhSDNy4.jpg v http://i.imgur.com/z9rOteW.jpg - 10ms. That's how it should be all the time.

This NadeoTime is disheartening. . . So much randomness is bad for everyone.. even if people don't see it. Subconsciously I am sure people feel it and feel frustrated... loathe the game at times and can't put their finger on it so they sound like a moaning / whining loser.
Last edited by pksens on 12 Mar 2014, 23:55, edited 3 times in total.
Win7x64Ulti, i7 870, 8gb Geil, ASRock P55 Extreme4, AMD 7950

caspa
Posts: 72
Joined: 02 Jul 2013, 19:03

Re: Bug? The 1vs1 'trade'. Does Lemondogs deserve to lose ES

Post by caspa » 12 Mar 2014, 04:30

It amazes me that something as critical to the gameplay as the weapons themselves don't even function correctly/consistently. At the core, this game is simply random.

pksens
Posts: 107
Joined: 11 Sep 2012, 13:12

Re: Bug? The 1vs1 'trade'. Does Lemondogs deserve to lose ES

Post by pksens » 12 Mar 2014, 16:09

http://i.imgur.com/GKsYgZo.jpg - that moment when rockets don't hit people. This one confuses me, if the hitbox is too far forward than it'll be hit by the first one, if it's not than the 2nd one is a hit. If neither, then it's very far behind? Or are the rockets out of sync here? I wish I had the replay. I'll get more evidence later, happens every single game so won't be hard.
Win7x64Ulti, i7 870, 8gb Geil, ASRock P55 Extreme4, AMD 7950

pksens
Posts: 107
Joined: 11 Sep 2012, 13:12

Re: Bug? The 1vs1 'trade'. Does Lemondogs deserve to lose ES

Post by pksens » 13 Mar 2014, 02:56

Here's a fun couple:
http://i.imgur.com/SiB65B7.jpg - server replay that one
http://youtu.be/-veUCbAFF1k - here, the pole is about 95% capped and about 0.03 seconds left. You can hear my rocket being fired point blank at the dude but it's one of those 'delayed' rockets I mentioned before, it does not even dare show it self even after the capture. If the rocket came out like normal, 0.01s, it could have hit him in time and awarded us the round but instead it was going to be one of the 0.04s+ rockets. Cost us a cup final last week that one ^^
Win7x64Ulti, i7 870, 8gb Geil, ASRock P55 Extreme4, AMD 7950

User avatar
Omnixor
Translator
Translator
Posts: 2959
Joined: 03 Jul 2010, 17:07
Location: Vilnius, Lithuania

Re: Bug? The 1vs1 'trade'. Does Lemondogs deserve to lose ES

Post by Omnixor » 13 Mar 2014, 20:22

is this normal? http://cl.ly/UPtV/ScreenShot02.jpg (exact shot moment, no hit registered); http://cl.ly/UQ31/ScreenShot03.jpg (a hit). might be just pings, but still...
- staff head of ESL TM²Stadium -

pksens
Posts: 107
Joined: 11 Sep 2012, 13:12

Re: Bug? The 1vs1 'trade'. Does Lemondogs deserve to lose ES

Post by pksens » 13 Mar 2014, 22:12

You would have to see the server side replay to be sure of what is going on. But even then, on the server replay, there are moments where the rail can clip through some parts of the outer torso for example. These are issues that hopefully might be different in the next patch.
Win7x64Ulti, i7 870, 8gb Geil, ASRock P55 Extreme4, AMD 7950

pksens
Posts: 107
Joined: 11 Sep 2012, 13:12

Am I bloggin' 'ere?

Post by pksens » 15 Mar 2014, 03:47

Yop. Was playin cup earlier this night, got to finals and last rounds on last map... I cap the pole to 100%! But the round is not mine. http://i.imgur.com/ZPWCi93.jpg (frustrating but personal feelings aside.. I wanna know why).

http://i.imgur.com/cIelKLZ.jpg <--- I'm alive, pole is alight. Noticed a few tricky things on server replay though:

Server replay: http://www.sendspace.com/file/iifd2t

Took 20ms to turn blue from 100% http://i.imgur.com/8FxaMUt.jpg -> http://i.imgur.com/VyjT5iy.jpg (I die in the time between).
Also, after 98% pole capture the capture speed reduces to a very slow rate for the final 2%. Very strange for a capture rate to change when you are 100% on it. I can understand it slows a little when you step on & off, 50ms of a fraction capture time I suspect. Those milliseconds were crucial in delaying the final pole light up. Also the rocket still has yet to hit me in any of these situations.
Win7x64Ulti, i7 870, 8gb Geil, ASRock P55 Extreme4, AMD 7950

haV
Posts: 39
Joined: 14 Oct 2012, 23:44
Location: Scotland
Contact:

Re: Am I bloggin' 'ere?

Post by haV » 15 Mar 2014, 13:51

pksens wrote:Yop. Was playin cup earlier this night, got to finals and last rounds on last map... I cap the pole to 100%! But the round is not mine. http://i.imgur.com/ZPWCi93.jpg (frustrating but personal feelings aside.. I wanna know why).

http://i.imgur.com/cIelKLZ.jpg <--- I'm alive, pole is alight. Noticed a few tricky things on server replay though:

Server replay: http://www.sendspace.com/file/iifd2t

Took 20ms to turn blue from 100% http://i.imgur.com/8FxaMUt.jpg -> http://i.imgur.com/VyjT5iy.jpg (I die in the time between).
Also, after 98% pole capture the capture speed reduces to a very slow rate for the final 2%. Very strange for a capture rate to change when you are 100% on it. I can understand it slows a little when you step on & off, 50ms of a fraction capture time I suspect. Those milliseconds were crucial in delaying the final pole light up. Also the rocket still has yet to hit me in any of these situations.
I seen this last night, I feel this is something that needs to be fix and sort in the next update. I am sure nadeo are doing there best to fit it, yet we do need it patched asap.

Post Reply

Return to “Shootmania”

Who is online

Users browsing this forum: No registered users and 2 guests