TMUF doesn't recognize graphics card

Discuss everything and more.

Moderator: English Moderator

User avatar
riolu
Posts: 1349
Joined: 15 Jun 2010, 18:39
Location: Germany

Re: TMUF doesn't recognize graphics card

Post by riolu » 19 Nov 2014, 01:38

My laptop has integrated graphics AND a graphic card (Geforce 840M). I can switch between both. The problem is that TMUF apparently does not recognize the graphic card's dedicated memory (which is 2GB).

@Omnixor, I updated the Intel HD drivers, no success either. I'm really out of ideas myself^^
I ran a couple of benchmarks and the game runs quite okay with average FPS of ~50 on high settings, the problem is that all textures are extremely blurry due to the lack of memory.
Maniaplanet runs fine on medium settings with at least 50 FPS as well, even on bigger maps.

User avatar
Omnixor
Translator
Translator
Posts: 2959
Joined: 03 Jul 2010, 17:07
Location: Vilnius, Lithuania

Re: TMUF doesn't recognize graphics card

Post by Omnixor » 19 Nov 2014, 01:43

50 fps with 840M? I get 150+ with 650M... make sure that in configure-advanced-compatibility cpu/gpu sync is 1 frame and light from map is none (applies for both maniaplanet and TMUF), can give huge fps boost.
- staff head of ESL TM²Stadium -

User avatar
riolu
Posts: 1349
Joined: 15 Jun 2010, 18:39
Location: Germany

Re: TMUF doesn't recognize graphics card

Post by riolu » 19 Nov 2014, 10:05

GPU/CPU sync was already set to 1 frame. Tried your tip with "light from map", sadly with no noticable difference :/

Edit: I've installed a more recent chipset driver, that one didn't fix the issue either....
Edit2: Tried playing around with NVidia Inspector, no changes either.

User avatar
trew
Posts: 20
Joined: 03 May 2018, 21:38
Location: Canada // Québec

Re: TMUF doesn't recognize graphics card

Post by trew » 02 Feb 2020, 02:16

In case someone hits this issue again. In Windows 10 (tested in version 1909),
- go to Settings
- Search for "Graphics settings" ("Paramètres des graphiques" in french)
- Add both TmForeverLauncher.exe and TmForever.exe to the list
- Set both to "high performance" instead of "power savings"
This will make sure that both exes use the dedicated GPU.
You can confirm that is it using the correct GPU by looking in task manager in the "GPU engine" column

After that I still had blurry texture issues. Fixed by disabling anti-aliasing. Many people reported other ways to fix that, but I guess it's worth a try.
Also, the amount of VRAM reported in TMUF config is wrong, but the game runs fine at max settings regardless.
Hope that helps!

martin-m-97
Posts: 1
Joined: 06 Apr 2011, 08:12

Re: TMUF doesn't recognize graphics card

Post by martin-m-97 » 16 Oct 2020, 19:27

trew wrote:
02 Feb 2020, 02:16
In case someone hits this issue again. In Windows 10 (tested in version 1909),
- go to Settings
- Search for "Graphics settings" ("Paramètres des graphiques" in french)
- Add both TmForeverLauncher.exe and TmForever.exe to the list
- Set both to "high performance" instead of "power savings"
This will make sure that both exes use the dedicated GPU.
You can confirm that is it using the correct GPU by looking in task manager in the "GPU engine" column

After that I still had blurry texture issues. Fixed by disabling anti-aliasing. Many people reported other ways to fix that, but I guess it's worth a try.
Also, the amount of VRAM reported in TMUF config is wrong, but the game runs fine at max settings regardless.
Hope that helps!
Everything you wrote definitely helped me, thanks!

Post Reply

Return to “Off-Topics”

Who is online

Users browsing this forum: No registered users and 2 guests