Raid Valley beta : terminé :) (sortie en cours)

Parlez de tout ce qui est lié à Trackmania 2.

Moderator: French Moderator

User avatar
fleo
Posts: 304
Joined: 02 Sep 2011, 12:56

Re: Raid Valley beta : dernier test avant lancement

Post by fleo » 22 Jul 2014, 20:15

meuh21 wrote:- la playlist n'indique ni <script_name> ni <title>, mais là aussi ça fonctionnait bien lors des tests précédents. Est-ce important ? Si oui je peux prévoir d'ajouter ça mais chaque c'est 600 Mo d'upload...
Je ne sais pas trop si c'est important, moi j'ai créé la playlist via Maniaplanet, tu sais juste avant de lancer un serveur, tu peux enregistrer le matchsettings. Du coup ça m'a généré ce fichier que j'utilise dans mon mode :

https://www.dropbox.com/s/kdz7scwnavr4k ... aining.txt

J'ai testé cette dernière version et j'ai toujours la même erreur :/ qu'est ce qu'il y a au fait à cette fameuse ligne 528 ?
Follow me on my maniaflash. Try the new elitealternative! Feedbacks on this post. :thumbsup:

I need αεяø. I'm holding out for αεяø 'til the end of the night.

User avatar
meuh21
Posts: 1269
Joined: 15 Jun 2010, 17:00
Location: Dans mon champ...
Contact:

Re: Raid Valley beta : dernier test avant lancement

Post by meuh21 » 22 Jul 2014, 20:25

Arf, merci pour ton test. Tu as un compte démo pour Valley ou un compte "normal" ?

La ligne 528 :

Code: Select all

G_Raids[NumRaid]["NbMaps"] = TextLib::ToText(NombreDeMaps);

User avatar
fleo
Posts: 304
Joined: 02 Sep 2011, 12:56

Re: Raid Valley beta : dernier test avant lancement

Post by fleo » 22 Jul 2014, 20:27

Oui j'ai valley complet. Ok donc ça vient bien des maps, mais juste avec cette ligne je peux pas faire grand chose hélas... :/
Follow me on my maniaflash. Try the new elitealternative! Feedbacks on this post. :thumbsup:

I need αεяø. I'm holding out for αεяø 'til the end of the night.

User avatar
TMarc
Posts: 15358
Joined: 05 Apr 2011, 19:10
Location: Europe
Contact:

Re: Raid Valley beta : dernier test avant lancement

Post by TMarc » 22 Jul 2014, 22:29

meuh21 wrote:Une nouvelle version à essayer : https://meocloud.pt/link/863068b2-4f2a- ... .Pack.Gbx/
Pas sur de ce qu'on doit absolument essayer, alors je me lance dans le solo.
Installation facile, mais j'upload pas dans la cloud ;)

Premier screen: la carte du monde.
Image
En fait tu as mis des petits cubes par étape, mais les traits rouges suggèrent les trajets à première vue.
Je mettrais plutot soit des pointillés, et des peut-être flêches circulaires pour chaque étape (au zoom réel si possible).
Par contre c'est une surprise agréable qu'on retrouve 5 maps par zone. :thumbsup:

Génial avec les loupes, sauf qu'elle sn'agrandissent rien, et que celle sur le dernière zone ne marche pas du tout... ou trop bien, elle se trouve tellement agrandie qu'elle couvre toute la terre :? le monde s'assombrit...
Image
mais on peut lancer cette zone heureusement.

Les parcours "entre" les eaux, difficile avec ValleyCar... dans Raiditude tu avais montré une moto, il manque alors la possibilité de forcer un modèle/skin au moins en solo, non?
Les brumes dans les forêts, sympa, sauf que ça n'influence pas du tout l'eau (elle apparait très foncée à l'horizon en sortant des brumes). Et dans les petites forêts, on dirait plutot de la fumée.

Un seul petit hic, une des premières flêches à l'entrée du temple(?) est trop haute, on ne voit pas ou il faut aller ;)
Image

Au moment de choisir les mods pour créer une nouvelle map, pourquoi deux mods ont des étoiles? SkiValley* et DesertValley*
maniaplanet forum global moderator

Link list with FAQ, Support, Wiki, Tutorials, Community activities, and much more.

System specs: Intel i7-970 12GB RAM, nVidia RTX 2060 6GB, Creative SB X-Fi, 2xSSD 1xHDD
Discord: TMarc#3002

User avatar
meuh21
Posts: 1269
Joined: 15 Jun 2010, 17:00
Location: Dans mon champ...
Contact:

Re: Raid Valley beta : dernier test avant lancement

Post by meuh21 » 23 Jul 2014, 09:00

Un grand merci :thx: pour ton retour qui m'offre beaucoup d'espoir :yes: mais aussi pas mal de perplexité... :?

Le test portait juste sur savoir ou non si la campagne solo fonctionne ou plante dès le début. Elle plante chez Fleo et fadden. Elle fonctionne chez toi et la version précédente marchait chez MrLag... Je pensais que cela venait du fait qu'il avait joué les maps lors de l'opération replay. Il ne me semble pas que tu es enregistré des temps mais je ne suis pas sû de tous les login ayant participé. Peux-tu confirmer que tu n'as pas joué en ligne sur le serveur testmania ?
TMarc wrote:Installation facile, mais j'upload pas dans la cloud ;)
Moi non plus je n'ai pas uploadé dans le cloud. Si Fleo, Fadden et Mr Lag pouvait nous dire ce qu'ils ont fait cela nous aiderait à y voir plus clair. Enfin, peut-être, car là on pédale dans la choucroute :mrgreen:

Concernant tes remarques :
TMarc wrote:En fait tu as mis des petits cubes par étape, mais les traits rouges suggèrent les trajets à première vue.
Je mettrais plutot soit des pointillés, et des peut-être flêches circulaires pour chaque étape (au zoom réel si possible).
Par contre c'est une surprise agréable qu'on retrouve 5 maps par zone. :thumbsup:

Génial avec les loupes, sauf qu'elles n'agrandissent rien, et que celle sur le dernière zone ne marche pas du tout... ou trop bien, elle se trouve tellement agrandie qu'elle couvre toute la terre :? le monde s'assombrit...
Image
mais on peut lancer cette zone heureusement.

Les parcours "entre" les eaux, difficile avec ValleyCar... dans Raiditude tu avais montré une moto, il manque alors la possibilité de forcer un modèle/skin au moins en solo, non?
Les brumes dans les forêts, sympa, sauf que ça n'influence pas du tout l'eau (elle apparait très foncée à l'horizon en sortant des brumes). Et dans les petites forêts, on dirait plutot de la fumée.

Un seul petit hic, une des premières flêches à l'entrée du temple(?) est trop haute, on ne voit pas ou il faut aller ;)
Image

Au moment de choisir les mods pour créer une nouvelle map, pourquoi deux mods ont des étoiles? SkiValley* et DesertValley*
Réponse de bas en haut :
Les mods avec étoiles sont des .pack, les autres des .zip. Les mods les plus complets sont plutôt en .pack et les autres en .zip. Mais je ne sais pas comment trop gérer ça. Difficile d'appréhender toutes les conséquences présentes et futures de cette décision. En pack c'est mieux pour éventuellement diffuser le mod séparement (ce que je ne prévois pas de faire) mais ça demande plus de temps pour faire la manip.

Pour les maps, il y a encore des défauts mais je ne pense plus les retoucher sinon ça ne s'arrête jamais... Et puis je ne crois pas avoir perdu le moindre joueur dans le temple ;)

Le brouillard n'est pas parfait (effectivement effet bizarre sur l'eau) et mon réglage sur WinterValley est un peu sombre. Mais je l'ai conservé comme ça pour apporter de la diversité et aussi car on peut imaginer que c'est un mélange de fumée (l'hiver est la période des coupes de bois où l'on brule les petites branches) et de brume. Et puis la brume est un apport récent (grâce aux moods settings) que je trouve vraiment génial :thumbsup: Merci Nadeo :thx:

J'aurais pu pour la campagne solo avoir des véhicules custom (ou un véhicule custom) mais cela impliquait de mettre dans le titre un modèle 3D spécial Raid (mais attention au copyright) et des skins mais qui auraient alourdi un peu plus encore le poids du fichier .pack. Pour cela, je me suis donc contenter de la valleycar et de skins Nadeo. Dans l'avenir, si la possibilité de définir un modèle pour un titre arrive alors je pourrai me replonger dans mes modèles 3d en cours ou alors lancer un concours pour définir un 3d original. Mais cela prendra du temps. Au moins 6 mois après l'éventuelle annonce de cette possibilité.

Les traits plein sont plus simples à faire que les pointillés :mrgreen: Les zooms sont volontairement légers. Bon tout cela pourrait être améliorer mais là aussi il faut que j'avance. Je note tes remarques pour Raid² ;)

Encore merci à toi et à ceux qui ont testé ça permet d'avancer même si je ne sais pas trop où on va :pil

User avatar
meuh21
Posts: 1269
Joined: 15 Jun 2010, 17:00
Location: Dans mon champ...
Contact:

Re: Raid Valley beta : dernier test avant lancement

Post by meuh21 » 23 Jul 2014, 12:24

Suite aux quelques retours sur la dernière version de test, nous avons des comportements assez variés pour la campagne solo  :? :

Le jeu renvoie une erreur et ne démarre pas la campagne solo pour certains (Fleo, Fadden) et pas pour d'autres (TMMarc, Buzard et moi).

Les replays sont joués pour certains (Buzard mais sur toutes les maps?) mais pas pour d'autres (moi)

La touche « Echap » permet de recommencer la map (Buzard) mais pas pour moi (ce qui est le comportement normal car les maps doivent impérativement s’enchaîner)

Résolu : Le Raid Denpasar-Kunming ne s'affichait pas correctement car ce fichier était absent du xml (mais présent dans mon dossier et je n'avais donc pas de bug)

Nous voilà donc avec un comportement erratique... J'ai ajouté l'image du raid manquant dans le xml et parce que je ne sais plus quoi faire, j'ai renommé « Not Raid » en « NotRaid » dans le script et dans la playslist (correspond à la map d'attente qui se charge derrière la carte des raids).

Avant d'uploader cette nouvelle version qui ne change que des détails, je suis preneur d'idées. Peut-être que que quelqu'un du coté de chez Nadeo a une piste à nous soumettre ?

Si d'autres personnes peuvent tester, le plus long c'est d'uploader le titre. Après c'est rapide il suffit de :
- voir si la campagne solo se lance
- choisir un raid
- rouler 10 secondes et attendre de voir si les replays doublent
- faire Echap et voir si l'on peut rejouer la map (redémarrer la map) ou, ce qui est le comportement souhaité, si cela nous sort du Raid pour revenir à la carte solo ou au menu général si on fait "quitter"

Merci d'avance pour votre aide :thx:

The_Big_Boo
Posts: 1041
Joined: 15 Jun 2010, 15:46

Re: Raid Valley beta : dernier test avant lancement

Post by The_Big_Boo » 23 Jul 2014, 13:38

J'ai testé et je suis dans le cas de la campagne solo qui ne se lance pas.
OS: Win 7 Pro x64
RAM: 2x4GB Corsair @ 1600MHz
CPU: Intel i5 760 @ 3.6GHz
Mobo: Asus P7P55D-E
GPU: NVidia GTX 760 2GB
HDD: WD Black 1TB
Sound: VIA VT1828S (onboard)
Peripherals: Razer DeathAdder - Razer DeathStalker - Logitech F310

User avatar
magnetik
Nadeo
Nadeo
Posts: 1677
Joined: 01 Feb 2012, 19:13
Location: Bordeaux
Contact:

Re: Raid Valley beta : dernier test avant lancement

Post by magnetik » 23 Jul 2014, 13:53

Au lancement du solo erreur suivante :

start main...
NotRaid Testmania\Not Raid\
[528, 17] Out of bounds access at [0]
ManiaPlanet technical documentation portal (Dedicated, ManiaLink, ManiaScript, Titles...) -- contribute!

User avatar
meuh21
Posts: 1269
Joined: 15 Jun 2010, 17:00
Location: Dans mon champ...
Contact:

Re: Raid Valley beta : dernier test avant lancement

Post by meuh21 » 23 Jul 2014, 14:02

Merci pour vos retours. Même si j'aurai préféré d'autres réponses :(

User avatar
Eole
Nadeo
Nadeo
Posts: 1265
Joined: 26 Apr 2011, 21:08

Re: Raid Valley beta : dernier test avant lancement

Post by Eole » 23 Jul 2014, 14:38

Voir si la campagne solo se lance
-> Oui

Choisir un raid
-> OK

Rouler 10 secondes et attendre de voir si les replays doublent
-> Je n'ai pas vu de replay

Faire Echap et voir si l'on peut rejouer la map (redémarrer la map) ou, ce qui est le comportement souhaité, si cela nous sort du Raid pour revenir à la carte solo ou au menu général si on fait "quitter"
->Je suis renvoyé sur la carte
Contribute to the ManiaPlanet documentation on GitHub
A question about ManiaScript? Ask it here!

Post Reply

Return to “Trackmania 2”

Who is online

Users browsing this forum: No registered users and 2 guests