Page 2 of 2

Re: No respawn on 'purple' stuff?

Posted: 23 Oct 2013, 20:26
by wijszman
That's correct, I can just walk over it no problem.

This does not happen on all maps i've downloaded, but on more than one.

Surely I'm not the only one with this issue?

Re: No respawn on 'purple' stuff?

Posted: 28 Oct 2013, 22:48
by wijszman
I've just created an own map, with some offzone in it. Same thing, I can walk straight thru the offzone.

Maybe this is a debug flag or something?

Re: No respawn on 'purple' stuff?

Posted: 29 Oct 2013, 11:37
by TMarc
:shock: I was able to reproduce it: it apparently depends where the player stops when reaching the top of the grate (I used block 6-8-4) with offzone in it.
If he stops somehow at the edge between normal part and offzone, then he can continue to walk on the grate then.
It is not easy to reproduce.
If the player stops clearly before the grate and then stops on it, he respawns.

Image

Test maps:
OffzoneGratesTest.Map.Gbx
OffzoneGratesTest2.Map.Gbx

Replay: OffzoneGratesTest.Replay.Gbx
Movie of the replay: OffzoneGratesTest.Replay.mp4

Strange btw., if you reach a vertical grate that has the offzone, you never respawn. It is as if you never could touch a vertical grate (e.g. with blocks 6-6-1, 6-6-2, 6-6-4 and 6-6-5)

Re: No respawn on 'purple' stuff?

Posted: 29 Oct 2013, 12:54
by steeffeen
wijszman wrote:I've just created an own map, with some offzone in it. Same thing, I can walk straight thru the offzone.
so you mean that you walk trough offzone with the complete body?
wijszman wrote:Maybe this is a debug flag or something?
well which version of obstacle are you using?

did you modify the script? ^.^
i guess not so i'm kind of puzzled because the script usually doesn't even consider letting you walk trough offzone...

Re: No respawn on 'purple' stuff?

Posted: 16 Nov 2013, 15:46
by wijszman
no i did not modify the script, and yes i can just walk through it full body.
The weirdest thing is that if I run a local server (in game) with the same script the offzone does work (i.e. you respawn).

Somehow the linux binaries for servers seem to have a bug, or at least it seems like that.

Anyone have a different obstacle script? should i post mine on here?

Re: No respawn on 'purple' stuff?

Posted: 16 Nov 2013, 15:52
by steeffeen
well I don't think that you have a modified version of the script if you didn't change it yourself
but you could still try to redownload it >url

you could also try to create a new dedicated server (redownload the software and create clean configs)

i don't really know what else to say, sorry

Re: No respawn on 'purple' stuff?

Posted: 24 Nov 2013, 21:54
by wijszman
A fresh server install seems to have fixed the issue :)
dunno what the issue was though.

thx for the help!