Warm-Up duration problem in "CUP" mode...

Moderator: NADEO

Post Reply
PhantOM51
Posts: 64
Joined: 15 Jul 2012, 11:11

Warm-Up duration problem in "CUP" mode...

Post by PhantOM51 » 23 Aug 2017, 22:13

Hi
I have some problem with warm up duration on my server.
Duration is always set to 8 seconds (a little bit short i think :roflol: )
I have modified modescript_settings.xml --> no effect
I have modified warmup duration value in the script --> no effect
I have modified the value in the matchsetting file --> no effect

Someone can help the little padawan ?

Thanks

User avatar
Eole
Nadeo
Nadeo
Posts: 1206
Joined: 26 Apr 2011, 21:08

Re: Warm-Up duration problem in "CUP" mode...

Post by Eole » 25 Aug 2017, 08:49

Hi

Are you using the scripted version of the Cup game mode?
If yes you should have access to two settings:
  • S_WarmUpNb -> the number of warm up rounds at the beginning of each map
  • S_WarmUpDuration -> the duration of one round of warm up in seconds
Because the duration is in seconds, you need to set S_WarmUpDuration to 120 for a 2 minutes warm-up round for example. S_WarmUpNb must be set to 1 or higher to enable the warm-up.

In your matchsettings file you should see the two settings:

Code: Select all

<script_settings>
    <!-- <setting name="S_WarmUpNb" type="integer" value="0"/> -->
    <!-- <setting name="S_WarmUpDuration" type="integer" value="0"/> -->
  </script_settings>
By default they are commented, you need to remove the <!-- and --> around the settings and set the correct value.
Contribute to the ManiaPlanet documentation on GitHub
A question about ManiaScript? Ask it here!

PhantOM51
Posts: 64
Joined: 15 Jul 2012, 11:11

Re: Warm-Up duration problem in "CUP" mode...

Post by PhantOM51 » 25 Aug 2017, 19:22

Ok, thanks for answer.
But the problem is not fix.

I have this in "Cup.Script.txt" :

Code: Select all

#Setting S_WarmUpNb			1	as _("Number of warm up :")
#Setting S_WarmUpDuration	180	as _("Duration of one warm up :")
I have this in the matchsettings.txt file :

Code: Select all

<setting name="S_WarmUpNb" type="integer" value="1"/>
<setting name="S_WarmUpDuration" type="integer" value="180"/>
My server CUP is set to 3 round on a map before skipping and 1 warmup of 180s before each new map.
It seems that the warmup duration is good when i launch the server but after skipping the first map, the warmup duration is 8s !

Another thing ! You can also set these values in the "modescript_settings.xml" of uaseco !
Values are (for me) :

Code: Select all

<warm_up_number>1</warm_up_number>
<warm_up_duration>180</warm_up_duration>
Which file is the most important ?

Any idea ?

User avatar
Eole
Nadeo
Nadeo
Posts: 1206
Joined: 26 Apr 2011, 21:08

Re: Warm-Up duration problem in "CUP" mode...

Post by Eole » 30 Aug 2017, 13:22

I don't know which one takes priority. Did you try to run the server without Uaseco to see if the bug persists? This way you will know if the problem comes from the controller or the game mode.
Contribute to the ManiaPlanet documentation on GitHub
A question about ManiaScript? Ask it here!

Post Reply

Return to “Dedicated Server”

Who is online

Users browsing this forum: No registered users and 1 guest