Dedicated Servers... what a disaster

Moderator: NADEO

Post Reply
paketep
Posts: 6
Joined: 31 Aug 2011, 12:54

Dedicated Servers... what a disaster

Post by paketep » 18 Nov 2017, 03:50

OMG, I thought MP3 was hard. MP4 is even worse:

- LAN not working. Error doesn't give any clue. You have to launch the server as an internet server. The way I read it, this has been happening for months.
- Packs have to be downloaded separately
- Now if you don't give the ident node of the map in the matchsettings file, it is as if it's not in the folder. Why?.
- No ident database anywhere. Do I really have to start opening gbx files to write them down?.
- I can get A, B, C's from TMValleyA.txt, B, C, but no D or E. Yeah, the E maps where not there either on MP3, but I could at least put the map tag in there and the D's would work.
- No clear documention ANYWHERE. Not here, not in the website. Incomplete everywhere, or not easy to find at all. Is it so hard to put up a step by step wiki page, a guide in steam, some screenshots, a complete .zip, whatever?. The config generator doesn't include a single map.
- And this is all for the "easy" one, Trackmania. Don't even get me started on Shootmania.

I have a LAN Party tomorrow. It's almost 4AM. And I'm really tired of this. Every version of MP/the dedi server this is even worse. Tomorrow I'll just launch a listen server, and then it's bye bye TM.

My god, things were not a hundredth as hard before Ubi bought you guys. Why make everything so forking difficult for your fans?. Starforce, ManiaPlanet, unnecesary connections for LAN games... The only thing missing is Uplay.

Perhaps I'm just incompetent, but hey, I never had a problem with old TM / Sunrise / United Forever.

Oh, well. I'm going to bed.

hackie
Posts: 1087
Joined: 19 Jul 2012, 22:43

Re: Dedicated Servers... what a disaster

Post by hackie » 18 Nov 2017, 08:50

System Specs:
OS: Windows 7 Professionnal x64
CPU: Intel Core i7-6700K / 4 GHz - 8 MB cache
GPU: MSI GTX 980TI GAMING 6G - OC Edition
Motherboard: ASUS MAXIMUS VIII RANGER
RAM : 32Gb Kingston HyperX Savage - DDR4
DirectX 11

oliverde8
Posts: 1322
Joined: 16 Jun 2010, 07:33
Location: in a Blue Box

Re: Dedicated Servers... what a disaster

Post by oliverde8 » 18 Nov 2017, 09:22

I quite agree with the assessment.

Maps are in the title back hidden somewhere. so if you use the match settings generator from their player page it works but there is no easy way to get a match settings file.

There should be commands to the dedicated server to install title pack, like ./maniaplanet install titlepack Canyon@Nadeo which fetches all the MatchSeting files and maps and place them in the UserData folder.

Right now it's magic happening in a gbx file...
Image
Developper for The next generation, Clean and Powerfull controller eXpansion for your SM & TM server . Working on eXpansion² with full MP4 support and many other awesome features...

hackie
Posts: 1087
Joined: 19 Jul 2012, 22:43

Re: Dedicated Servers... what a disaster

Post by hackie » 18 Nov 2017, 10:44

Did Reaby not made a tool for writing a matchsetting file ?

viewtopic.php?f=465&t=17341&p=149398#p149398
System Specs:
OS: Windows 7 Professionnal x64
CPU: Intel Core i7-6700K / 4 GHz - 8 MB cache
GPU: MSI GTX 980TI GAMING 6G - OC Edition
Motherboard: ASUS MAXIMUS VIII RANGER
RAM : 32Gb Kingston HyperX Savage - DDR4
DirectX 11

paketep
Posts: 6
Joined: 31 Aug 2011, 12:54

Re: Dedicated Servers... what a disaster

Post by paketep » 03 Feb 2018, 02:35

Thanks, hackie and oliverde8 for trying to help.

I'm afraid three months after, the situation is still the same.

I can't understand how Nadeo doesn't have a clear, step by step, install guide for a dedi server. I've been doing LAN parties for 20 years, but I still can't make a LAN server work for either TM2 or Shootmania. And I managed to get CS:GO working (way to move to a way worse system there, Valve).

Why did they have to make it so complicated?. Completely fundamental things like where to put to gbx, how to add the maps, etc, are NOWHERE to be seen. Instead of getting easier, they make it more difficult with each upgrade. Would it really be SO hard to put standard configs in the maniaplanet server package?. "Here, this is the command line for running a LAN Royal server with the standard maps, just download the gbx from here AND PUT IT IN THIS FOLDER". "Here, this is the command line for a internet TM2 Stadium, register at this URL and put your user and password in this file".

Does LAN still not work?. I have downloaded the latest mp server, the log message doesn't even make it clear if the problem is mine or the server's.

Those Lagoons aren't going to sell themselves with this kind of support. What a waste, guys.

User avatar
Miss
Posts: 1194
Joined: 05 Jan 2016, 11:34
Location: The Netherlands
Contact:

Re: Dedicated Servers... what a disaster

Post by Miss » 03 Feb 2018, 14:33

Besides this step-by-step getting started guide, it's missing information on where to place the packs. I might do a pull request today to fix this page.

Also, it says for a LAN server, a login is not required. What error do you get when you try to start a server without a login?

Edit: Was messing around a bit and got this error when using the "/lan" option:

Code: Select all

[2018/02/03 16:13:15] ...ERROR: Load failed. Could not get access to 'Trackmania² Stadium'.
[2018/02/03 16:13:15] Could not install or update the title's files...
I guess that's broken right now.

Edit 2: I made a pull request to improve the getting started guide here.
Forum moderator, opinions are my own. :thx:
Check out Image openplanet, the alternative Maniaplanet scripting platform! (Openplanet subforum)
I also stream on Twitch and tweet on Twitter.

User avatar
wlhlm
Posts: 10
Joined: 08 Oct 2017, 17:33

Re: Dedicated Servers... what a disaster

Post by wlhlm » 11 Feb 2018, 15:53

Miss wrote:
03 Feb 2018, 14:33
Besides this step-by-step getting started guide, it's missing information on where to place the packs. I might do a pull request today to fix this page.

Also, it says for a LAN server, a login is not required. What error do you get when you try to start a server without a login?

Edit: Was messing around a bit and got this error when using the "/lan" option:

Code: Select all

[2018/02/03 16:13:15] ...ERROR: Load failed. Could not get access to 'Trackmania² Stadium'.
[2018/02/03 16:13:15] Could not install or update the title's files...
I guess that's broken right now.
Yes it's broken. I've documented some workarounds here: viewtopic.php?t=42677
Miss wrote:
03 Feb 2018, 14:33
Edit 2: I made a pull request to improve the getting started guide here.
Thanks for that!

Post Reply

Return to “Dedicated Server”

Who is online

Users browsing this forum: No registered users and 2 guests