...ERROR: The playlist file not found.

Moderator: NADEO

Post Reply
striker890
Posts: 2
Joined: 01 Jan 2018, 18:28

...ERROR: The playlist file not found.

Post by striker890 » 01 Jan 2018, 18:35

Hello,
setting up a Trackmania 2 Stadium server atm and cam across this error.
Starting with: maniaplanet-server /nodaemon /dedicated_cfg=config /game_settings=config
Getting this error:

Code: Select all

Starting ManiaPlanet Date=2017-11-17_18_00 Svn=78597 GameVersion=3.3.0...
Configuration file : config
Loading system configuration...
...system configuration loaded
Loading cache...
...OK
Loading dedicated server configuration...
...Dedicated server configuration loaded
Connecting to master server...
...OK
Identifying on master server...
...OK
Listening for xml-rpc commands on port 5000.
Match settings file : config
Loading match settings...
...ERROR: The playlist file not found.
...Could not load the match settings
Server not started: no Maps available. Check your matchsettings!
URL: maniaplanet://#join=bliblablubbbla@TMStadium@nadeo
Server not running, exiting.
Exiting...
MatchSettings:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<playlist>
  <gameinfos>
    <game_mode>0</game_mode>
    <chat_time>10000</chat_time>
    <finishtimeout>1</finishtimeout>
    <allwarmupduration>0</allwarmupduration>
    <disablerespawn>0</disablerespawn>
    <forceshowallopponents>0</forceshowallopponents>
    <script_name><![CDATA[TimeAttack.Script.txt]]></script_name>
  </gameinfos>
  <filter>
    <is_lan>1</is_lan>
    <is_internet>1</is_internet>
    <is_solo>0</is_solo>
    <is_hotseat>0</is_hotseat>
    <sort_index>1000</sort_index>
    <random_map_order>0</random_map_order>
  </filter>
  <script_settings>
    <setting name="S_ChatTime" type="integer" value="10"/>
    <setting name="S_UseClublinks" type="boolean" value="0"/>
    <setting name="S_UseClublinksSponsors" type="boolean" value="0"/>
    <setting name="S_NeutralEmblemUrl" type="text" value=""/>
    <setting name="S_ScriptEnvironment" type="text" value="production"/>
    <setting name="S_AllowRespawn" type="boolean" value="1"/>
    <setting name="S_UseLegacyXmlRpcCallbacks" type="boolean" value="1"/>
    <setting name="S_WarmUpNb" type="integer" value="0"/>
    <setting name="S_WarmUpDuration" type="integer" value="0"/>
    <setting name="S_TimeLimit" type="integer" value="300"/>
  </script_settings>
  <startindex>0</startindex>
  <map><file>TrackMania\Stadium\Solar.Map.Gbx</file></map>
</playlist>
Hope somebody can help. Not so easy to find reliable information on howto setup a trackmania server... (Why isn't there a full working sample? :? )
Greetings

hackie
Posts: 1060
Joined: 19 Jul 2012, 22:43

Re: ...ERROR: The playlist file not found.

Post by hackie » 01 Jan 2018, 19:14

https://doc.maniaplanet.com/dedicated-server

Something missing in youre command line I think.
I start my server under windows like this :

ManiaPlanetServer.exe /game_settings=MatchSettings/TMStadiumA.txt /dedicated_cfg=dedicated_cfg.txt /title=TMStadium@nadeo
System Specs:
OS: Windows 7 Professionnal x64
CPU: Intel Core i7-6700K / 4 GHz - 8 MB cache
GPU: MSI GTX 980TI GAMING 6G - OC Edition
Motherboard: ASUS MAXIMUS VIII RANGER
RAM : 32Gb Kingston HyperX Savage - DDR4
DirectX 11

striker890
Posts: 2
Joined: 01 Jan 2018, 18:28

Re: ...ERROR: The playlist file not found.

Post by striker890 » 02 Jan 2018, 19:52

hackie wrote:
01 Jan 2018, 19:14
https://doc.maniaplanet.com/dedicated-server

Something missing in youre command line I think.
I start my server under windows like this :

ManiaPlanetServer.exe /game_settings=MatchSettings/TMStadiumA.txt /dedicated_cfg=dedicated_cfg.txt /title=TMStadium@nadeo
I set the title in the dedicated_cfg, which is loading perfectly. When I hadn't set the title it showed up before this error even came up.

Post Reply

Return to “Dedicated Server”

Who is online

Users browsing this forum: No registered users and 1 guest