Uaseco MasterAdmin

Forum d'entraide au sujet de Maniaplanet et ses jeux

Moderator: French Moderator

Post Reply
izunlek
Posts: 18
Joined: 01 May 2018, 11:07

Uaseco MasterAdmin

Post by izunlek » 19 May 2018, 14:39

Bonjour/bonsoir,
Je travaille à un serveur dédié hébergé de chez moi qui marche très bien(les gens peuvent rejoindre peut-importe le pays, les voitures s'affichent etc), cependant aucun plugin n'y est installé alors je commence à installer uaseco ne trouvant aucun ou très peu de tuto pour ManiaControl. Bref, j'ai fait ma base de données, j'ai configuré les dossiers " config " tout ça tout ça...
Tout marche bien sauf que j'ai plusieurs problèmes :

-MasterAdmin non reconnu: j'ai essayé de mettre mon login tm, mon pseudo tm, mon login steam ou encore mon pseudo steam mais aucun d'eux ne marche... voilà le message :

[UASECO Fatal Error] No MasterAdmin(s) configured in [config/UASECO.xml]! on line 762 in file C:\Users\Documents\Maniaplanet\Serveur\UASECO-0.9.5_2017-06-08\uaseco.php

et j'ai aussi un message dont je ne vois pas du tout la provenance : [PHP Notice] Array to string conversion on line 133 in file C:\Users\Documents\Maniaplanet\Serveur\UASECO-0.9.5_2017-06-08\includes\core\xmlparser.class.php

J'ai vérifé PARTOUT dans TOUT les fichiers même ceux qui n'avaient pas grand chose en rapport à la recherche d'une balise " masteradmin " au cas où j'en aurais loupé.. Mais même avec mon ip et en me connectant en local comme le spécifie le dossier de configuration ça ne marche pas !

" <!-- /ip:port in tmlogin only useful when joining server over LAN -->"
( fichier config dans lequel je suis censé mettre mon login )

Mon fichier configuré ressemble à ça ( pour la partie qui pose problème ):

<masteradmins>
<!-- /ip:port in tmlogin only useful when joining server over LAN -->
<!-- ipaddress can be specified to guard each login against -->
<!-- unauthorized use of admin commands from other IP addresses -->

<tmlogin>izunlek</tmlogin> <ipaddress> ~~Mon ip~~ </ipaddress>
//-->izunlek
</masteradmins>



Mon autre problème est qu'aucune interface de plugin style LocalRecords ne s'affiche dans mon serveur :/, j'ai pourtant vérifié et tout m'a l'air plutot bien configuré dans les fichiers des plugins

Merci d'avance pour toutes les aides apportées !

hackie
Posts: 1075
Joined: 19 Jul 2012, 22:43

Re: Uaseco MasterAdmin

Post by hackie » 19 May 2018, 18:24

Mine looks like this :

Code: Select all

	<masteradmins>
		<!-- /ip:port in tmlogin only useful when joining server over LAN -->
		<!-- ipaddress can be specified to guard each login against       -->
		<!-- unauthorized use of admin commands from other IP addresses   -->
		<!-- format:
		<tmlogin>YOUR_MASTERADMIN_LOGIN</tmlogin> <ipaddress>YOUR_MASTERADMIN_IP</ipaddress>
		//-->
		<tmlogin>account1</tmlogin>
		<tmlogin>account2</tmlogin>
		<tmlogin>account3</tmlogin>
	</masteradmins>
So in your case , remove account1 and put your login there.
Delete the rest.


Like this :

Code: Select all

	<masteradmins>
		<!-- /ip:port in tmlogin only useful when joining server over LAN -->
		<!-- ipaddress can be specified to guard each login against       -->
		<!-- unauthorized use of admin commands from other IP addresses   -->
		<!-- format:
		<tmlogin>YOUR_MASTERADMIN_LOGIN</tmlogin> <ipaddress>YOUR_MASTERADMIN_IP</ipaddress>
		//-->
		<tmlogin>izunlek</tmlogin>
	</masteradmins>
System Specs:
OS: Windows 7 Professionnal x64
CPU: Intel Core i7-6700K / 4 GHz - 8 MB cache
GPU: MSI GTX 980TI GAMING 6G - OC Edition
Motherboard: ASUS MAXIMUS VIII RANGER
RAM : 32Gb Kingston HyperX Savage - DDR4
DirectX 11

izunlek
Posts: 18
Joined: 01 May 2018, 11:07

Re: Uaseco MasterAdmin

Post by izunlek » 19 May 2018, 19:41

Thank you very much ! I do not have this problem, the only problems I have left now are how to display the records(local and world) and this message :

[UASECO Warning] [Dedicated] [1] connect - Cannot open socket
[UASECO Fatal Error] [Dedicated] ...connection could not be established! on line 395 in file C:\Users\Documents\Maniaplanet\Serveur\UASECO-0.9.5_2017-06-08\uaseco.php


I do not understand what that means, what is wrong ? At the line 395 on this folder I have : trigger_error('[Dedicated] ...connection could not be established!', E_USER_ERROR);
What I need to do ?

I want to say it again : Thank you a lot !

hackie
Posts: 1075
Joined: 19 Jul 2012, 22:43

Re: Uaseco MasterAdmin

Post by hackie » 20 May 2018, 09:34

I think that uaseco can not connect to youre dedicated server.

some ifo about the installation :

http://www.uaseco.org/documentation/installation.php
System Specs:
OS: Windows 7 Professionnal x64
CPU: Intel Core i7-6700K / 4 GHz - 8 MB cache
GPU: MSI GTX 980TI GAMING 6G - OC Edition
Motherboard: ASUS MAXIMUS VIII RANGER
RAM : 32Gb Kingston HyperX Savage - DDR4
DirectX 11

izunlek
Posts: 18
Joined: 01 May 2018, 11:07

Re: Uaseco MasterAdmin

Post by izunlek » 21 May 2018, 10:35

Hello !
I have succesfully solve this problem, the problem I have now is " permissions denied " from the plugins *-*, they don't give more informations and I don't how to solve it..
The logs are here : (green:it's working and red not working)

[2018-05-21 09:23:29] [Plugin] » initialize [plugins/plugin.records_eyepiece.php]
[2018-05-21 09:23:29] [Plugin] » initialize [plugins/plugin.vote_manager.php]
[2018-05-21 09:23:29] [Plugin] Checking dependencies of Plugins...
[2018-05-21 09:23:29] [Plugin] ...successfully done!
[2018-05-21 09:23:30] [Plugin] Registering events and chat commands...
[2018-05-21 09:23:30] [Plugin] ...successfully done!

[UASECO Exception] Error returned: "Permission denied." [-1000] at GbxRemote::query() for method "GetServerPlanets" with arguments:
array(0) {
}

[UASECO Exception] Error returned: "Permission denied." [-1000] at GbxRemote::query() for method "GameDataDirectory" with arguments:
array(0) {
}

[UASECO Exception] Error returned: "Permission denied." [-1000] at GbxRemote::query() for method "GetMapsDirectory" with arguments:
array(0) {
}

[UASECO Exception] Error returned: "Not a server." [-1000] at GbxRemote::query() for method "IsRelayServer" with arguments:
array(0) {
}

[UASECO Fatal Error] [Gameinfo] Unsupported Modescript "" loaded, please report this at https://www.UASECO.org on line 129 in file C:\Users\gstep\Documents\Maniaplanet\Serveur\UASECO-0.9.5_2017-06-08\includes\core\gameinfo.class.php
[UASECO Exception] Error returned: "Permission denied." [-1000] at GbxRemote::query() for method "ManualFlowControlEnable" with arguments:
array(1) {
[0]=>
bool(false)
}

[UASECO Exception] Error returned: "Permission denied." [-1000] at GbxRemote::query() for method "ManualFlowControlProceed" with arguments:
array(0) {
}

[UASECO Exception] Error returned: "Permission denied." [-1000] at GbxRemote::query() for method "SendHideManialinkPage" with arguments:
array(0) {
}


Thanks for help !

izunlek
Posts: 18
Joined: 01 May 2018, 11:07

Re: Uaseco MasterAdmin

Post by izunlek » 21 May 2018, 10:37

I wanna precise : my data base is working ! The data tabbles are okay

User avatar
undef.de
Posts: 1786
Joined: 06 Apr 2011, 21:57
Location: Germany
Contact:

Re: Uaseco MasterAdmin

Post by undef.de » 22 May 2018, 21:07

izunlek wrote:
21 May 2018, 10:35
Hello !
I have succesfully solve this problem, the problem I have now is " permissions denied " from the plugins *-*, they don't give more informations and I don't how to solve it..
The logs are here : (green:it's working and red not working)

Code: Select all

[2018-05-21 09:23:29] [Plugin] » initialize [plugins/plugin.records_eyepiece.php]
[2018-05-21 09:23:29] [Plugin] » initialize [plugins/plugin.vote_manager.php]
[2018-05-21 09:23:29] [Plugin] Checking dependencies of Plugins...
[2018-05-21 09:23:29] [Plugin] ...successfully done!
[2018-05-21 09:23:30] [Plugin] Registering events and chat commands...
[2018-05-21 09:23:30] [Plugin] ...successfully done!
[UASECO Exception] Error returned: "Permission denied." [-1000] at GbxRemote::query() for method "GetServerPlanets" with arguments:
array(0) {
}

[UASECO Exception] Error returned: "Permission denied." [-1000] at GbxRemote::query() for method "GameDataDirectory" with arguments:
array(0) {
}

[UASECO Exception] Error returned: "Permission denied." [-1000] at GbxRemote::query() for method "GetMapsDirectory" with arguments:
array(0) {
}

[UASECO Exception] Error returned: "Not a server." [-1000] at GbxRemote::query() for method "IsRelayServer" with arguments:
array(0) {
}

[UASECO Fatal Error] [Gameinfo] Unsupported Modescript "" loaded, please report this at https://www.UASECO.org on line 129 in file C:\Users\gstep\Documents\Maniaplanet\Serveur\UASECO-0.9.5_2017-06-08\includes\core\gameinfo.class.php
[UASECO Exception] Error returned: "Permission denied." [-1000] at GbxRemote::query() for method "ManualFlowControlEnable" with arguments:
array(1) {
  [0]=>
  bool(false)
}

[UASECO Exception] Error returned: "Permission denied." [-1000] at GbxRemote::query() for method "ManualFlowControlProceed" with arguments:
array(0) {
}

[UASECO Exception] Error returned: "Permission denied." [-1000] at GbxRemote::query() for method "SendHideManialinkPage" with arguments:
array(0) {
}
Thanks for help !
Answered here.
Developer of UASECO, a controller with support of the Modescript Gamemodes for TM².
Visit the official website for more: UASECO.org


Developer of various plugins for XAseco/XAseco2 and MPAseco, visit my lab: www.undef.name

You like what I do? Then award a ManiaStar.

izunlek
Posts: 18
Joined: 01 May 2018, 11:07

Re: Uaseco MasterAdmin

Post by izunlek » 23 May 2018, 14:36

Thank you a lot but I always have this message :

[2018-05-21 09:23:28] [Dedicated] Try to authenticate with login [SuperAdmin] and password [*********] (masked password)
[UASECO Exception] Error returned: "Password incorrect." [-1000] at GbxRemote::query() for method "Authenticate" with arguments:
array(2) {
[0]=>
string(10) "SuperAdmin"
[1]=>
string(9) "******" (masked password)
}

I have try all the passwords : The password in dedicated.cfg ( SuperAdmin ), my maniaplanet password, the password from dedicated server on site and nothing is working ! Did I have do something wrong ? The two passwords in the two folders are sames !

Post Reply

Return to “Support”

Who is online

Users browsing this forum: No registered users and 1 guest