[STADIUM] The server does not recognize the map

Talk about the online play and eSport / team

Moderator: English Moderator

clementlapizza
Posts: 23
Joined: 14 Nov 2018, 04:28
Location: Gaspé, Quebec, Canada
Contact:

Re: [STADIUM] The server does not recognize the map

Post by clementlapizza » 28 Mar 2019, 18:07

The titlepack I use is not TMStadium@nadeo, it's esl_comp@lt_forever and even following your boot system it always makes the same mistake, so I do not know

Code: Select all

./ManiaPlanetServer /nodaemon /title=esl_comp@lt_forever /game_settings=MatchSettings/MatchSetting_djclement50_2019_03_26_18_18.txt /dedicated_cfg=dedicated_cfg.txt
Je sais pas conduire sur TM

User avatar
undef.de
Posts: 2037
Joined: 06 Apr 2011, 21:57
Location: Germany, North Sea Coast
Contact:

Re: [STADIUM] The server does not recognize the map

Post by undef.de » 28 Mar 2019, 18:37

I have a working esl_comp@lt_forever server running, does your dedicated_cfg.txt contain this?:

Code: Select all

<dedicated>
	<system_config>
		<title>esl_comp@lt_forever</title>
	</system_config>
</dedicated>
And your MatchSettings/MatchSetting_djclement50_2019_03_26_18_18.txt should have this (forgot to add esl_comp@lt_forever the last time):

Code: Select all

	<gameinfos>
		<game_mode>0</game_mode>
		<script_name>TimeAttack.Script.txt</script_name>
		<title>esl_comp@lt_forever</title>
	</gameinfos>
And this is a map that's running on that server: https://tm.mania-exchange.com/tracks/115197
Developer of UASECO, a controller with support of the Modescript Gamemodes for TM².
Visit the official website for more: UASECO.org


Developer of various plugins for XAseco/XAseco2 and MPAseco, visit my lab: www.undef.name

You like what I do? Then award a ManiaStar.

clementlapizza
Posts: 23
Joined: 14 Nov 2018, 04:28
Location: Gaspé, Quebec, Canada
Contact:

Re: [STADIUM] The server does not recognize the map

Post by clementlapizza » 28 Mar 2019, 19:07

undef.de wrote:
28 Mar 2019, 18:37
I have a working esl_comp@lt_forever server running, does your dedicated_cfg.txt contain this?:

Code: Select all

<dedicated>
	<system_config>
		<title>esl_comp@lt_forever</title>
	</system_config>
</dedicated>
And your MatchSettings/MatchSetting_djclement50_2019_03_26_18_18.txt should have this (forgot to add esl_comp@lt_forever the last time):

Code: Select all

	<gameinfos>
		<game_mode>0</game_mode>
		<script_name>TimeAttack.Script.txt</script_name>
		<title>esl_comp@lt_forever</title>
	</gameinfos>
And this is a map that's running on that server: https://tm.mania-exchange.com/tracks/115197
Yes it contains the esl_comp@lt_forever in the dedicated_cfg.txt

And I did update the matchsettings file by adding the <title>

And even loading the card you give me, the server does not detect it.
Je sais pas conduire sur TM

User avatar
undef.de
Posts: 2037
Joined: 06 Apr 2011, 21:57
Location: Germany, North Sea Coast
Contact:

Re: [STADIUM] The server does not recognize the map

Post by undef.de » 28 Mar 2019, 19:13

That's strange, still the same error? Hmmm.... :?
Developer of UASECO, a controller with support of the Modescript Gamemodes for TM².
Visit the official website for more: UASECO.org


Developer of various plugins for XAseco/XAseco2 and MPAseco, visit my lab: www.undef.name

You like what I do? Then award a ManiaStar.

clementlapizza
Posts: 23
Joined: 14 Nov 2018, 04:28
Location: Gaspé, Quebec, Canada
Contact:

Re: [STADIUM] The server does not recognize the map

Post by clementlapizza » 28 Mar 2019, 19:14

Maybe it's my titlepack bug ?! But it's still weird because I even reinstall it via the site of ManiaPlanet, so weird…

And the logs do not help me too much about the problem
Je sais pas conduire sur TM

User avatar
undef.de
Posts: 2037
Joined: 06 Apr 2011, 21:57
Location: Germany, North Sea Coast
Contact:

Re: [STADIUM] The server does not recognize the map

Post by undef.de » 28 Mar 2019, 19:20

If you PM me a e-mail address I would send you my TitlePack by wetransfer.com so you could test if it cause the problem.
Developer of UASECO, a controller with support of the Modescript Gamemodes for TM².
Visit the official website for more: UASECO.org


Developer of various plugins for XAseco/XAseco2 and MPAseco, visit my lab: www.undef.name

You like what I do? Then award a ManiaStar.

clementlapizza
Posts: 23
Joined: 14 Nov 2018, 04:28
Location: Gaspé, Quebec, Canada
Contact:

Re: [STADIUM] The server does not recognize the map

Post by clementlapizza » 28 Mar 2019, 19:22

undef.de wrote:
28 Mar 2019, 19:20
If you PM me a e-mail address I would send you my TitlePack by wetransfer.com so you could test if it cause the problem.
Even with your titlepack it does not work, too bad I'll give up for the moment, I'll think about a solution later
Je sais pas conduire sur TM

ranig
Posts: 49
Joined: 27 May 2017, 01:07

Re: [STADIUM] The server does not recognize the map

Post by ranig » 29 Mar 2019, 11:28

I took a quick look at the first MatchSetting file you've shown here, and in the map section, I noticed that you used a backslash "\" for the folder separation. Have you tried using a normal slash instead "/" ? Linux uses normal slash instead of backlashes XD
Your Trackmania resource for Nascar racing http://www.tm-nascar.com

clementlapizza
Posts: 23
Joined: 14 Nov 2018, 04:28
Location: Gaspé, Quebec, Canada
Contact:

Re: [STADIUM] The server does not recognize the map

Post by clementlapizza » 29 Mar 2019, 17:31

ranig wrote:
29 Mar 2019, 11:28
I took a quick look at the first MatchSetting file you've shown here, and in the map section, I noticed that you used a backslash "\" for the folder separation. Have you tried using a normal slash instead "/" ? Linux uses normal slash instead of backlashes XD
I already have another server that is active in titlepack TMStadium@nadeo and it works fine with \ and I also test / but it's the same error so I do not know.




I managed to launch my server, the problem came from the maps I created under the titlepack ESL.
So it's pretty annoying because I wanted to create my maps and upload them on this server.

I even completely reinstall the titlepack so I do not where does the problem come from ?!
Je sais pas conduire sur TM

clementlapizza
Posts: 23
Joined: 14 Nov 2018, 04:28
Location: Gaspé, Quebec, Canada
Contact:

Re: [STADIUM] The server does not recognize the map

Post by clementlapizza » 30 Mar 2019, 01:36

Sorry for the double post but I'm just correcting my bug.

My bug came because maps and matchsettings of the titlepack ESL that find in the folder :

Code: Select all

/GameData/Maps
and it was necessary to put them inthe folder :

Code: Select all

/UserData/Maps
And now the server is working properly.

I thank you for your help on the forum :)
Je sais pas conduire sur TM

Post Reply

Return to “Multiplayer”

Who is online

Users browsing this forum: No registered users and 1 guest