TUTORIEL COMPLET : Créer un serveur Maniaplanet avec Uaseco

Parlez de tout ce qui concerne le jeu en ligne ainsi que de l'eSport et des teams

Moderator: French Moderator

mathys76
Posts: 58
Joined: 30 Nov 2018, 17:32

Re: TUTORIEL COMPLET : Créer un serveur Maniaplanet avec Uaseco

Post by mathys76 » 01 Dec 2018, 14:26

j'ai réglé ce pb mais j'en ai un autre :
dans : C:\wamp64 je n'ai pas de php je l'ai juste dans bin c'est étrange

mathys76
Posts: 58
Joined: 30 Nov 2018, 17:32

Re: TUTORIEL COMPLET : Créer un serveur Maniaplanet avec Uaseco

Post by mathys76 » 03 Dec 2018, 19:26

ça me met ça maintenant : ning: Declaration of Database::query($sql) should be compatible with mysqli::query($query, $resultmode = NULL) in C:\Users\user\Desktop\Serveur\UASECO-0.9.5_2017-06-08\includes\core\database.class.php on line 431
[2018-12-03 18:22:36] ###############################################################################
[2018-12-03 18:22:36] [UASECO] Initializing...
[2018-12-03 18:22:36] [PHP] Checking for required and wanted PHP extensions...
[2018-12-03 18:22:36] [PHP] > Checking "Exchangeable Image Information" (exif): OK!
[2018-12-03 18:22:36] [PHP] > Checking "File Transfer Protocol" (ftp): extension not loaded, it is REQUIRED to enable this extension.. See "http://php.net/manual/en/book.ftp.php" for installation details.
[2018-12-03 18:22:36] [PHP] > Checking "ICONV character set conversion facility" (iconv): OK!
[2018-12-03 18:22:36] [PHP] > Checking "Image Processing and GD" (gd): OK!
[2018-12-03 18:22:36] [PHP] > Checking "JavaScript Object Notation" (json): OK!
[2018-12-03 18:22:36] [PHP] > Checking "LibXML" (libxml): OK!
[2018-12-03 18:22:36] [PHP] > Checking "Multibyte String" (mbstring): OK!
[2018-12-03 18:22:36] [PHP] > Checking "MySQL Improved" (mysqli): OK!
[2018-12-03 18:22:36] [PHP] > Checking "SimpleXML" (SimpleXML): OK!
[2018-12-03 18:22:36] [PHP] > Please enable the required PHP extensions and try again!
Appuyez sur une touche pour continuer...


je n'ai pas de doissier php dans c:/wamp64

mathys76
Posts: 58
Joined: 30 Nov 2018, 17:32

Re: TUTORIEL COMPLET : Créer un serveur Maniaplanet avec Uaseco

Post by mathys76 » 03 Dec 2018, 19:41

maintenant c'est ca le pb : Page de codes active : 65001

Warning: Declaration of Database::query($sql) should be compatible with mysqli::query($query, $resultmode = NULL) in C:\Users\user\Desktop\Serveur\UASECO-0.9.5_2017-06-08\includes\core\database.class.php on line 431
[2018-12-03 18:41:23] ###############################################################################
[2018-12-03 18:41:23] [UASECO] Initializing...
[2018-12-03 18:41:23] [PHP] Checking for required and wanted PHP extensions...
[2018-12-03 18:41:23] [PHP] > Checking "Exchangeable Image Information" (exif): OK!
[2018-12-03 18:41:23] [PHP] > Checking "File Transfer Protocol" (ftp): OK!
[2018-12-03 18:41:23] [PHP] > Checking "ICONV character set conversion facility" (iconv): OK!
[2018-12-03 18:41:23] [PHP] > Checking "Image Processing and GD" (gd): OK!
[2018-12-03 18:41:23] [PHP] > Checking "JavaScript Object Notation" (json): OK!
[2018-12-03 18:41:23] [PHP] > Checking "LibXML" (libxml): OK!
[2018-12-03 18:41:23] [PHP] > Checking "Multibyte String" (mbstring): OK!
[2018-12-03 18:41:23] [PHP] > Checking "MySQL Improved" (mysqli): OK!
[2018-12-03 18:41:23] [PHP] > Checking "SimpleXML" (SimpleXML): OK!
[2018-12-03 18:41:23] [Config] Load settings [config/UASECO.xml]
[UASECO Warning] [XML Error 80] Comment must not contain '--' (double-hyphen) on line 32
[UASECO Fatal Error] Could not read/parse config file [config/UASECO.xml]! on line 926 in file C:\Users\user\Desktop\Serveur\UASECO-0.9.5_2017-06-08\uaseco.php
Appuyez sur une touche pour continuer...

Silicine
Posts: 2
Joined: 02 Apr 2019, 07:07

Re: TUTORIEL COMPLET : Créer un serveur Maniaplanet avec Uaseco

Post by Silicine » 02 Apr 2019, 07:38

Bonjour à tous,

Premièrement, merci pour ce tuto. J'ai pu monter un serveur facilement.
Je rencontre un problème lors de la mise en place de Uaseco, j'ai du mal à comprendre mon erreur.

Dans un premier temps, j'ai suivi les différentes étapes et j'ai du m'adapter avec les MaJ de Wamp/PHP.
Dans mon fichier php.ini je n'ai pas de PHP_ftp.dll de ce fait j'ai modifié à la ligne 912

Code: Select all

extension=ftp
j'ai enlevé les ";" devant pour dé-commenter la ligne.

J'ai par lui suite modifié correctement le fichier UASECO\config\UASECO.xml avec le changement de password du SuperAdmin, le port (identique à la config du serveur TMStadium préalablement configuré). J'ai mis mon login en masteradmin puis renseigné les identifiants pour log sur la BD de Wamp.
J'ai enfin changé le path dans par :

Code: Select all

<dedicated_installation>E:\ManiaPlanet Server</dedicted_installation> 
dans ce path se trouve mon .exe pour le serveur.
J'ai de plus modifié UASECO.xml pour stipuler le bon fichier à prendre MatchSetting

Ensuite, j'ai modifié le dedimani.xml en suivant les infos du serveur créé sur dedimania. J'ai modifier le mania_karma.xml en rajoutant FRA.

Arrive le moment ou je dois modifier les deux .bat
1.uaseco.bat

Code: Select all

set INSTPHP=E:\Wamp\bin\php\php7.3.1
2.webrequest.bat
IDEM

Hors quand je lance les deux .bat (peu importe le sens) j'ai des erreurs. Voici les messages de logs:

uaseco.bat

Code: Select all

PHP:  syntax error, unexpected END_OF_LINE, expecting '=' in E:\Wamp\bin\php\php7.3.1\php.ini on line 2

Fatal error: Uncaught Error: Class 'mysqli' not found in E:\ManiaPlanet Server\UASECO\includes\core\database.class.php:38
Stack trace:
#0 E:\ManiaPlanet Server\UASECO\uaseco.php(94): require_once()
#1 {main}
  thrown in E:\ManiaPlanet Server\UASECO\includes\core\database.class.php on line 38
PHP:  syntax error, unexpected END_OF_LINE, expecting '=' in E:\Wamp\bin\php\php7.3.1\php.ini on line 2

Fatal error: Uncaught Error: Call to undefined function mb_internal_encoding() in E:\ManiaPlanet Server\UASECO\uaseco.php:77
Stack trace:
#0 {main}
  thrown in E:\ManiaPlanet Server\UASECO\uaseco.php on line 77
webrequest.bat

Code: Select all

PHP:  syntax error, unexpected END_OF_LINE, expecting '=' in E:\Wamp\bin\php\php7.3.1\php.ini on line 2

Fatal error: Uncaught Error: Call to undefined function mb_internal_encoding() in E:\ManiaPlanet Server\UASECO\webrequest.php:32
Stack trace:
#0 {main}
  thrown in E:\ManiaPlanet Server\UASECO\webrequest.php on line 32
---

Pour uaseco.bat :
J'ai vérifier la présence de la déclaration de la classe mysqli dans le fichier database.class.php

Code: Select all

class Database extends mysqli {
	public $debug			= false;
	public $settings		= array();
	public $table_prefix		= 'uaseco_';
	public $type			= 'MySQL';
	public $version			= '0.0.0';
	public $version_full		= '0.0.0';
	public $placeholder		= '%prefix%';
La voici.

Pour webrequest.bat :
J'ai l'erreur qui se répete chez uaseco.bat aussi avec la variable

Code: Select all

mb_internal_encoding('UTF-8');
J'ai tenté de la commenter mais ca ne fonctionne toujours pas.

User avatar
TMarc
Posts: 15060
Joined: 05 Apr 2011, 19:10
Location: Europe
Contact:

Re: TUTORIEL COMPLET : Créer un serveur Maniaplanet avec Uaseco

Post by TMarc » 02 Apr 2019, 15:24

L'erreur se trouve dans php.ini non ?
maniaplanet forum global moderator

Link list with FAQ, Support, Wiki, Tutorials, Community activities, and much more.

System specs: Intel i7-970 12GB RAM, nVidia RTX 2060 6GB, Creative SB X-Fi, 2xSSD 1xHDD

Silicine
Posts: 2
Joined: 02 Apr 2019, 07:07

Re: TUTORIEL COMPLET : Créer un serveur Maniaplanet avec Uaseco

Post by Silicine » 03 Apr 2019, 13:21

Justement, j'ai fais plusieurs vérifications hier soir.

Premièrement j'ai regardé d'un peu plus près la configuration de WAMP.

Dans un premier temps, WAMP ne prenait pas la bonne version de php, donc avec un php.ini ou l'extension ftp désactivée.
J'ai du coup forcé WAMP a utiliser la bonne version de php avec cette fois la php.ini correctement configuré.

De plus, l'erreur stipulant un problème avec une fonction php vient de de la library 'mbstring' qui après vérification est bien activé sur WAMP.

J'ai regardé directement sur le site uaseco, leur tuto en allemand, j'ai rajouté du coup un dossier 'images' pour la configuration du UASECO.xml.

Le résultat reste le même..

SuperSilver
Posts: 1
Joined: 08 Apr 2019, 12:22

Re: TUTORIEL COMPLET : Créer un serveur Maniaplanet avec Uaseco

Post by SuperSilver » 08 Apr 2019, 12:26

bonjour j'ai un soucis similaire , jai forcé wamp a utiliser la derniere version de php , j'ai active l'extension a la ligne 912 dans le .ini.J'ai tous fait comme expliqué cependant lors de l executions des .bat uaseco la console ne m'affiche que :"Page de codes active : 65001" et ne fait absolument rien, pas de record en jeu, ni rien sur la page web....

LoupphoKTM
Posts: 11
Joined: 02 Aug 2018, 15:25

Re: TUTORIEL COMPLET : Créer un serveur Maniaplanet avec Uaseco

Post by LoupphoKTM » 08 May 2019, 15:48

Moi j'ai vérifié plein de fois sur les ports correspondaient et tout mais le serv pour els autres marchent pas

Mamire
Posts: 1
Joined: 16 May 2019, 14:01

Re: TUTORIEL COMPLET : Créer un serveur Maniaplanet avec Uaseco

Post by Mamire » 16 May 2019, 14:07

Bonjour, je viens à vous car après suivit de ce tuto et de nombreuses recherches je n'arrive pas à trouver une solution à ce problème :

ERR [Libs/Nadeo/MP4/TPLagoon/Components/LocalPlay/LocalPlayController.Script.txt: 191, 58] The procedure Join_GetServerInfo_Result failed to complete :
No server to join. Call GetServerInfo() before.
LocalPlayController::JoinServerCheck() [191, 58]
LocalPlayController::Loop() [256, 17]
MenuController::LoopAll() [269, 48]
MainMenuLagoon::Main() [16, 17]
[11218] Main Lagoon
New version for test
11218> [MenuController] Private_LoadXml(): XML successfully loaded: file://Media/XML/HorizonAddOn.xml
WARN [Libs/Nadeo/MP4/TPLagoon/Components/LocalPlay/LocalPlayAPI.Script.txt: 347, 14] Could not find the server
LocalPlayAPI::Loop() [347, 14]
LocalPlayController::Loop() [228, 14]
MenuController::LoopAll() [269, 48]
MainMenuLagoon::Main() [16, 17]

Error_Net_ServerNotFound
ERR [Libs/Nadeo/MP4/TPLagoon/Components/LocalPlay/LocalPlayController.Script.txt: 191, 58] The procedure Join_GetServerInfo_Result failed to complete :
No server to join. Call GetServerInfo() before.
LocalPlayController::JoinServerCheck() [191, 58]
LocalPlayController::Loop() [256, 17]
MenuController::LoopAll() [269, 48]
MainMenuLagoon::Main() [16, 17]

Le serveur se lance très bien, je le trouve en réseau local/online mais impossible de s'y connecter et je me retrouve avec cette erreur, si quelqu'un comprends quelque chose, merci d'avance !

Fsx
Posts: 1
Joined: 28 May 2019, 21:01

Re: TUTORIEL COMPLET : Créer un serveur Maniaplanet avec Uaseco

Post by Fsx » 28 May 2019, 21:22

Super Tuto, fonctionne très bien. Juste un ptit détail. Quelle(s) manip(s) faut-il effectuer si je veux afficher uniquement le nom de la map ainsi que les locals records ?

Post Reply

Return to “Multijoueur”

Who is online

Users browsing this forum: No registered users and 1 guest