AdminServ-Neo PHP problem

Moderator: German Moderator

Flighthigh
Posts: 427
Joined: 29 Jun 2010, 06:48

Re: AdminServ-Neo [Current Version: 3.0.0-b1]

Post by Flighthigh » 22 Jan 2018, 14:04

Hallo Chris,

lange haben wir drauf gewartet und nun ist es da.

Fehlermeldung unter https://gitlab.com/Chris92de/AdminServ-Neo/issues geht nicht ;-)

Install Instruction
Punkt 1. abgearbeitet - OK
Punkt 2. Datei umbenannt in test.env - OK
Punkt 3. gebe ich die Zeile ein bekomme ich eine Fehlermeldung:

Code: Select all

[myname@xxxxxxxxxx ad-serv]# php artisan key:generate
PHP Parse error:  syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /var/www/vhosts/xxxxxxxxxxxxx.de/httpdocs/ad-serv/artisan on line 31
und nu ? ;)

vieleicht gleich zu 4. und 5. gefragt mein enlisch ist nicht das Beste deshalb versteh ich die Zeilen gar nicht. Was muss man da machen?

6. die URL zum verzeichnis reicht oder muss da noch nee Datei aufgerufen werden?

7. Würde mich mit stolz erfüllen. Aber bis es soweit ist wird wohl noch etwas Zeit vergehen ;-)

User avatar
Chris92
Translator
Translator
Posts: 943
Joined: 15 Jun 2010, 13:22
Location: Vilshofen, Germany
Contact:

Re: AdminServ-Neo [Current Version: 3.0.0-b1]

Post by Chris92 » 22 Jan 2018, 14:39

Flighthigh wrote:
22 Jan 2018, 14:04
Hallo Chris,

lange haben wir drauf gewartet und nun ist es da.

Fehlermeldung unter https://gitlab.com/Chris92de/AdminServ-Neo/issues geht nicht ;-)

Install Instruction
Punkt 1. abgearbeitet - OK
Punkt 2. Datei umbenannt in test.env - OK
Punkt 3. gebe ich die Zeile ein bekomme ich eine Fehlermeldung:

Code: Select all

[myname@xxxxxxxxxx ad-serv]# php artisan key:generate
PHP Parse error:  syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /var/www/vhosts/xxxxxxxxxxxxx.de/httpdocs/ad-serv/artisan on line 31
und nu ? ;)

vieleicht gleich zu 4. und 5. gefragt mein enlisch ist nicht das Beste deshalb versteh ich die Zeilen gar nicht. Was muss man da machen?

6. die URL zum verzeichnis reicht oder muss da noch nee Datei aufgerufen werden?

7. Würde mich mit stolz erfüllen. Aber bis es soweit ist wird wohl noch etwas Zeit vergehen ;-)
GitLab Issues sollten nun für jedermann zugänglich sein, woops!

Zu 2. - Die Datei muss exakt ".env" heißen, nicht test.env, asdf.env oder flighthigh.env
Dann sollte alles andere auch funktionieren.
Schritt 4 und 5 heißt, dass du unter Plesk oder was auch immer du benutzt eine neue Subdomain für AdminServ einrichten sollst oder deinen Webserver so einstellen musst, dass er standardmäßig auf den /a/b/c/adminserv-neo/public zugreift. Da jeder einen anderen Webserver benutzt oder andere Panels kann ich hier keine genaueren Anweisungen geben.
Schritt 6 wäre dann entweder die Subdomain die du angelegt hast (die dann direkt auf den [..]/public Order zeigt, hinterm Slash muss nix stehen, AdminServ macht das dann alles automatisch (leitet dich auf subdomain.domain.tld/setup/1 weiter)
Check out my Personal Twitter account!

Flighthigh
Posts: 427
Joined: 29 Jun 2010, 06:48

Re: AdminServ-Neo [Current Version: 3.0.0-b1]

Post by Flighthigh » 22 Jan 2018, 15:02

Du bist ja schneller als der Schall.

Eine Datei ohne jeglichen Namen?? :shock: Das geht unter Windows schon mal gar nicht. Unter Linux wird die Datei dann in der Konsol nicht mehr angezeigt. Aber egal. Datei ist ohne Namen nur als .env umbenannt.
PKT 3. Bleibt aber bei der Fehlermeldung

Code: Select all

[xxxxx@xxxxxxx ad-serv]# php artisan key:generate
PHP Parse error:  syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /var/www/vhosts/xxxxxxxx.de/httpdocs/ad-serv/artisan on line 31
Pkt. 4 und 5
OK eine Subdomain unter Plesk das bekomme ich noch hin. MOD_REWRITE bekomme ich auch noch hin.

Pkt. 6
Die subdomain im Browser aufrufen bekomme ich auch grad so hin. Aber ....... diese Subdomain ist doch leer. Sollte man da nicht irgendwann mal was reinkopieren :mrgreen:

Bisher ist in der Installbeschreibung nicht die Rede davon wo man das ganz hin tut. Also habe ich es einfach mal in ein Unterverzeichnis meiner Domain getan (sieht man ja oben). Was spricht dagegen das ich es in einem Unterverzeichnis meiner Domain laufen lassen kann?
Die Zeile "php artisan key:generate" (die den Fehler ausgibt) erschliesst sich mir auch noch nicht so richtig.

User avatar
Chris92
Translator
Translator
Posts: 943
Joined: 15 Jun 2010, 13:22
Location: Vilshofen, Germany
Contact:

Re: AdminServ-Neo [Current Version: 3.0.0-b1]

Post by Chris92 » 22 Jan 2018, 15:12

Flighthigh wrote:
22 Jan 2018, 15:02
Du bist ja schneller als der Schall.

Eine Datei ohne jeglichen Namen?? :shock: Das geht unter Windows schon mal gar nicht. Unter Linux wird die Datei dann in der Konsol nicht mehr angezeigt. Aber egal. Datei ist ohne Namen nur als .env umbenannt.
Unter Linux nennt man Dateien die mit einem . starten versteckte Dateien, werden in der Konsole dann mit ls -al sichtbar.
Ist unter Windows auch hinzukriegen, versuch die Datei mal auf ".env." umzubenennen, beachte den Punkt am Ende, dann sollte das funktionieren ;)

Wegen dem Problem mit `php artisan key:generate` meldest du dich bitte mal bei mir in Discord, dann können wir uns das genauer anschauen. Was das genau macht ist einen kryptographischen Key zu erstellen, mit dem dann alles was mit Passwörter Hashes, Sessions etc zu tun hat generiert werden.

Achja, in deiner CMD oder im Terminal, mach mal "php -v" und sag mir was für ne Version der ausspuckt. Scheint mir als wäre deine PHP Version zu alt.
Flighthigh wrote:
22 Jan 2018, 15:02
Pkt. 6
Die subdomain im Browser aufrufen bekomme ich auch grad so hin. Aber ....... diese Subdomain ist doch leer. Sollte man da nicht irgendwann mal was reinkopieren :mrgreen:
War der Ansicht, dass Leute das dann schon verstehen, wenn da steht man sollte den DocumentRoot der Subdomain dann dahin ändern wo man AdminServ entpackt hat :roflol:
Check out my Personal Twitter account!

Flighthigh
Posts: 427
Joined: 29 Jun 2010, 06:48

Re: AdminServ-Neo [Current Version: 3.0.0-b1]

Post by Flighthigh » 23 Jan 2018, 09:40

Moin Chris,

sorry aber gestern blieb keine Zeit mehr um sich darum zu kümmern.

Als erstes:
Du hast die Installanweisung geändert :thumbsup: Jetzt auch für Dummies wie mich :oops:

Bei mir läuft CentOS Linux 7.3.1611 (Core) mit einer alte Version 5.4.16 als default. ABER ich habe eine parallele Installation von 5.6.33 für die Domain die ich auch schon für die Forensoftware nutze. Hier muss ich ja nur den richtigen Pfad angeben um die 5.6. zu laden.

Das hatt ich gestern vergessen :oops: Also habe ich noch mal neu begonnen.

Code: Select all

/opt/plesk/php/5.6/bin/php composer.phar install
- hat funktioniert gibt aber eine Reihe von Meldungen aus die ich nicht verstehe :D

nur die 3 ersten Zeilen verstehe ich und denke das da auch schon das Problem liegt. Ich weiß nur nicht warum.

Code: Select all

Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - laravel/framework v5.4.9 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.8 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.7 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.6 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.5 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.4 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.36 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.35 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.34 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.33 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.32 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.31 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.30 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.3 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.29 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.28 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.27 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.26 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.25 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.24 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.23 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.22 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.21 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.20 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.2 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.19 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.18 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.17 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.16 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.15 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.14 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.13 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.12 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.11 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.10 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.1 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - laravel/framework v5.4.0 requires paragonie/random_compat ~1.4|~2.0 -> satisfiable by paragonie/random_compat[v1.4.0, v1.4.1, v1.4.2, v1.x-dev, v2.0.0, v2.0.1, v2.0.10, v2.0.11, v2.0.2, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.0.9] but these conflict with your requirements or minimum-stability.
    - Installation request for laravel/framework 5.4.* -> satisfiable by laravel/framework[v5.4.0, v5.4.1, v5.4.10, v5.4.11, v5.4.12, v5.4.13, v5.4.14, v5.4.15, v5.4.16, v5.4.17, v5.4.18, v5.4.19, v5.4.2, v5.4.20, v5.4.21, v5.4.22, v5.4.23, v5.4.24, v5.4.25, v5.4.26, v5.4.27, v5.4.28, v5.4.29, v5.4.3, v5.4.30, v5.4.31, v5.4.32, v5.4.33, v5.4.34, v5.4.35, v5.4.36, v5.4.4, v5.4.5, v5.4.6, v5.4.7, v5.4.8, v5.4.9].
Hoffe Du weißt was zu tun ist. :thumbsup:

Flighthigh
Posts: 427
Joined: 29 Jun 2010, 06:48

Re: AdminServ-Neo [Current Version: 3.0.0-b1]

Post by Flighthigh » 23 Jan 2018, 16:32

Nachtrag: nachdem ich gelesen habe das die php-version 5.6.33 auch nicht richtig ist habe ich dann noch nee 7er-Version installiert. Aber die Fehlermeldungen sind die gleichen.

User avatar
Chris92
Translator
Translator
Posts: 943
Joined: 15 Jun 2010, 13:22
Location: Vilshofen, Germany
Contact:

AdminServ-Neo PHP problem

Post by Chris92 » 23 Jan 2018, 17:32

5.6.33 reicht, 5.6.4 ist vorausgesetzt und 33 > 4. Lies bitte den letzten Changelog hier im thread, da ist dein Problem gelöst -> viewtopic.php?p=294841#p294841
Check out my Personal Twitter account!

Flighthigh
Posts: 427
Joined: 29 Jun 2010, 06:48

Re: AdminServ-Neo [Current Version: 3.0.0-b1]

Post by Flighthigh » 24 Jan 2018, 07:47

Hallo

ok habe ich übersehen. Also zip runtergeladen und neu auf den Server getan.

Dann "/opt/plesk/php/5.6/bin/php composer.phar install" laufen lassen. Hat auch nee Weile gut funktioniert. Aber zum Ende kamen dann wieder Fehler.

Siehe hier habe ich mal das ganze geloggt

Vermute das da was mit dem "artisan" nicht stimmt.

User avatar
Chris92
Translator
Translator
Posts: 943
Joined: 15 Jun 2010, 13:22
Location: Vilshofen, Germany
Contact:

Re: AdminServ-Neo [Current Version: 3.0.0-b1]

Post by Chris92 » 24 Jan 2018, 09:13

artisan funktioniert einwandfrei, bist du dir sicher, dass .env umbenannt ist? Und melde dich bitte mal im Discord bei mir, erster Post, dann hätten wir das Problem längst gelöst

EDIT:

Versuch nochmal den Artisan befehl mit PHP 5.6 auszuführen, composer geht vom standard PHP aus, daher ging der letzte befehl nicht.
Check out my Personal Twitter account!

Flighthigh
Posts: 427
Joined: 29 Jun 2010, 06:48

Re: AdminServ-Neo [Current Version: 3.0.0-b1]

Post by Flighthigh » 24 Jan 2018, 09:21

Hallo

bei mir gibt es keinTeamspeaker, Discord usw. weil kein Mikrofone oder Lautsprecher. Sorry aber es bleibt uns nichts weiter als zu schreiben.

Was mir aufgefallen ist:

Das artisan wird ja mit php aufgerufen. Nun wie bereits gesagt läuft bei mir Standard php v 5.0.xx Deshalb rufe ich das ganze ja auch mit dem Pfad zu 5.6.33=4 ;) auf. In der Abfolge, auf die ich nicht eingreifen kann wird aber "php artisan optimize" aufgerufen. Das sollte dann an der "alten" php version liegen und auch scheitern??

Post Reply

Return to “Werkstatt”

Who is online

Users browsing this forum: No registered users and 1 guest