Page 5 of 6

Re: [How to] Mood.MoodSettings.Xml

Posted: 04 Nov 2015, 18:02
by Ozon
Fix wrote:They are made to be used inside a mod yes.
Do you report that \modwork folder, with a moodsetiings.xml in it, will skip the all mod files int the zip associated with the map excepted the moodsetting.xml if there is one ?
I placed the moodsetting inside the skins/valley/modwork/[...]/Sunset folder and from there on, it won't let me load the mod. It always loads the default textures.

Is there a workaround?

Re: [How to] Mood.MoodSettings.Xml

Posted: 07 Nov 2015, 21:44
by kadaz
Yah Oz, when you use any modifications that is in Modwork, it will, presumptuously, in my experience, shut down any external mod uses and use only the default maniaplanet game textures.

Re: [How to] Mood.MoodSettings.Xml

Posted: 08 Nov 2015, 02:43
by Ozon
kadaz wrote:Yah Oz, when you use any modifications that is in Modwork, it will, presumptuously, in my experience, shut down any external mod uses and use only the default maniaplanet game textures.
Too bad :? . I found a great tool to work around it though. Nerpson made a great job with his Moodifier, so I don't need to use the default mod anymore :)

Re: [How to] Mood.MoodSettings.Xml

Posted: 19 Nov 2015, 19:22
by adamkooo2
Can´t launch any map with mood.mood.settings.xml :(

Re: [How to] Mood.MoodSettings.Xml

Posted: 14 Jan 2016, 16:41
by Dommy
Can somebody tell what is correct path to color correction files here? (For example Fantasy cc)

Re: [How to] Mood.MoodSettings.Xml

Posted: 14 Jan 2016, 17:17
by Fix
adamkooo2 wrote:Can´t launch any map with mood.mood.settings.xml :(
isn't it Mood.MoodSettings.xml ?

Re: [How to] Mood.MoodSettings.Xml

Posted: 14 Jan 2016, 17:53
by adamkooo2
Fix wrote:
adamkooo2 wrote:Can´t launch any map with mood.mood.settings.xml :(
isn't it Mood.MoodSettings.xml ?
sorry, I wrote wrong name :oops:
but the problem still exists

Re: [How to] Mood.MoodSettings.Xml

Posted: 14 Jan 2016, 18:57
by Fix
maybe there is a mistake inside the xml. maybe try another one to see if it works, and compare both (a missing character for instance)

Re: [How to] Mood.MoodSettings.Xml

Posted: 18 Dec 2016, 13:19
by nilakite2
Yo,
when I try to use this mood settings my game crash and I'm 100% sure that I did everything as you.
Map is loading and then game crash.
I have it in /Documents/ManiaPlanet/Skins/Stadium/ModWork/Moods/Sunset/Mood.MoodSettings.xml
Using this script:

Code: Select all

<Mood>
   <Light EnableStars="1" Latitude="65" DayTime01="0.73" LocalLightX="0.8" HelperHdrX="1">
      <LAmbient Color="f7dcff" Scale="0.319" />
      <LDirSun Color="ff8f39" Scale="2" />
      <LDirMoon Color="000000" Scale="1" />
      <T3SpecularLocal ScaleIntens="1.3" ScaleExponent="1.2" />
      <T3LightMap MaxHDR="2.7" BounceFactor="2" SkyFactor="1" SkyUseClouds="1" />
   </Light>
   <Atmo MoonHdrScale="1" FxSmSelfIllumScaleGamePlay="1">
      <HdrSun Power="5e+005">
         <Atmo1 Power="30" Color="ff5f12" Scale="2.97" />
         <Atmo2 Power="1.5" Color="ffaa69" Scale="1.09" />
      </HdrSun>
      <Clouds MinRgb="000000" MinRgbX="1" MaxRgb="ffffff" MaxRgbX="1" GodLightIntens="0.05" SunThroughIntens="0.6">
         <EdgeLight>
            <Layer0 Power="12" Scale="4" />
            <Layer1 Power="2" Scale="2" />
            <Layer2 Power="1" Scale="1" />
         </EdgeLight>
      </Clouds>
      <CloudsX2 MinRgb="dadfff" MinRgbX="0.392" MaxRgb="fffdfc" MaxRgbX="0.647" />
      <CloudsVortex MinRgb="000000" MaxRgb="ffffff" />
      <FogMatter Count="0" />
   </Atmo>
   <Fog Enabled="1" DepthMin="32" DepthMax="2.5e+003" Exponant="0.9" IntensMin="0" IntensMax="1" Color="685d74">
      <Height YBottom="-500" YTop="600" MulBottom="1" MulTop="0.85" />
      <Clouds DepthMax="6e+004" Exponant="0.8" IntensMax="0.834" />
      <SkyClouds GlobalIntens="0" />
   </Fog>
   <Fx>
      <T3Bloom StreaksIntens="0.2" StreaksAttenuation="0.7">
         <HdrNorm_to_Intens>
            <Key In="0" Out="0" />
            <Key In="1" Out="0" />
            <Key In="4" Out="0.5" />
            <Key In="64" Out="0.01" />
         </HdrNorm_to_Intens>
      </T3Bloom>
      <T3ToneMap FilmCurve="Preset3">
         <AutoExp MinExposure="-2" MaxExposure="4.5" SecondsToMidFalloff="0.3">
            <AvgLumi_to_KeyValue>
               <Key In="0.001" Out="0.01" />
               <Key In="0.005" Out="0.02" />
               <Key In="0.01" Out="0.04" />
               <Key In="0.02" Out="0.07" />
               <Key In="0.04" Out="0.1" />
               <Key In="0.06" Out="0.12" />
               <Key In="0.1" Out="0.155" />
               <Key In="0.2" Out="0.22" />
               <Key In="0.3" Out="0.27" />
               <Key In="0.5" Out="0.32" />
               <Key In="1" Out="0.5" />
            </AvgLumi_to_KeyValue>
         </AutoExp>
      </T3ToneMap>
   </Fx>
</Mood>

Re: [How to] Mood.MoodSettings.Xml

Posted: 18 Dec 2016, 14:59
by maxi031
nilakite2 wrote:

Code: Select all

<Mood>
   <Light EnableStars="1" Latitude="65" DayTime01="0.73" LocalLightX="0.8" HelperHdrX="1">
      <LAmbient Color="f7dcff" Scale="0.319" />
      <LDirSun Color="ff8f39" Scale="2" />
      <LDirMoon Color="000000" Scale="1" />
      <T3SpecularLocal ScaleIntens="1.3" ScaleExponent="1.2" />
      <T3LightMap MaxHDR="2.7" BounceFactor="2" SkyFactor="1" SkyUseClouds="1" />
   </Light>
   <Atmo MoonHdrScale="1" FxSmSelfIllumScaleGamePlay="1">
      <HdrSun Power="5e+005">
         <Atmo1 Power="30" Color="ff5f12" Scale="2.97" />
         <Atmo2 Power="1.5" Color="ffaa69" Scale="1.09" />
      </HdrSun>
      <Clouds MinRgb="000000" MinRgbX="1" MaxRgb="ffffff" MaxRgbX="1" GodLightIntens="0.05" SunThroughIntens="0.6">
         <EdgeLight>
            <Layer0 Power="12" Scale="4" />
            <Layer1 Power="2" Scale="2" />
            <Layer2 Power="1" Scale="1" />
         </EdgeLight>
      </Clouds>
      <CloudsX2 MinRgb="dadfff" MinRgbX="0.392" MaxRgb="fffdfc" MaxRgbX="0.647" />
      <CloudsVortex MinRgb="000000" MaxRgb="ffffff" />
      <FogMatter Count="0" />
   </Atmo>
   <Fog Enabled="1" DepthMin="32" DepthMax="2.5e+003" Exponant="0.9" IntensMin="0" IntensMax="1" Color="685d74">
      <Height YBottom="-500" YTop="600" MulBottom="1" MulTop="0.85" />
      <Clouds DepthMax="6e+004" Exponant="0.8" IntensMax="0.834" />
      <SkyClouds GlobalIntens="0" />
   </Fog>
   <Fx>
      <T3Bloom StreaksIntens="0.2" StreaksAttenuation="0.7">
         <HdrNorm_to_Intens>
            <Key In="0" Out="0" />
            <Key In="1" Out="0" />
            <Key In="4" Out="0.5" />
            <Key In="64" Out="0.01" />
         </HdrNorm_to_Intens>
      </T3Bloom>
      <T3ToneMap FilmCurve="Preset3">
         <AutoExp MinExposure="-2" MaxExposure="4.5" SecondsToMidFalloff="0.3">
            <AvgLumi_to_KeyValue>
               <Key In="0.001" Out="0.01" />
               <Key In="0.005" Out="0.02" />
               <Key In="0.01" Out="0.04" />
               <Key In="0.02" Out="0.07" />
               <Key In="0.04" Out="0.1" />
               <Key In="0.06" Out="0.12" />
               <Key In="0.1" Out="0.155" />
               <Key In="0.2" Out="0.22" />
               <Key In="0.3" Out="0.27" />
               <Key In="0.5" Out="0.32" />
               <Key In="1" Out="0.5" />
            </AvgLumi_to_KeyValue>
         </AutoExp>
      </T3ToneMap>
   </Fx>
</Mood>
I tried your code and it works, for me game does not crash.