Can't play after going spec on passworded server

Moderator: NADEO

Locked
User avatar
eyebo
Translator
Translator
Posts: 2826
Joined: 15 Jun 2010, 12:01
Contact:

Can't play after going spec on passworded server

Post by eyebo » 24 Jun 2013, 21:28

This is an old bug, and I don't know why I never got around to reporting it. It's probably because I so rarely play on passworded servers.

Here's how to reproduce:
- Host a vanilla in-game server. Set the password the same for spectator and players.
- Have a player join and race.
- The player manually goes to spectator mode.
- The player wants to rejoin the race by respawning or unticking the "spectator" option in the menu... but the server says "Unable to change: Incorrect password".

Current workaround:
The player must rejoin the server and enter the pass again.

Desired functionality:
The server should either ask for the password again... or remember that the player had entered the correct password when he joined the server.

This probably applies to the dedicated server too, but I haven't tested it.
My videos on: YouTube

i7 2600K (OC'd to 4.6Ghz) / 32GB DDR3 1600 / GTX 1080 (390.77) / Win10

User avatar
undef.de
Posts: 1712
Joined: 06 Apr 2011, 21:57
Location: Germany
Contact:

Re: Can't play after going spec on passworded server

Post by undef.de » 25 Jun 2013, 17:05

eyebo wrote:This probably applies to the dedicated server too, but I haven't tested it.
It does, this problem i have at my (dedicated) development server all the time when i switch.
Developer of UASECO, a controller with support of the Modescript Gamemodes for TM².
Visit the official website for more: UASECO.org


Developer of various plugins for XAseco/XAseco2 and MPAseco, visit my lab: www.undef.name

You like what I do? Then award a ManiaStar.

User avatar
hacki65
Posts: 66
Joined: 20 Mar 2012, 12:56

Re: Can't play after going spec on passworded server

Post by hacki65 » 12 Jul 2013, 17:48

This is a general Bug. This stupid thing does on normal Servers too (without passwords). Also on Clientbased Server.

Anyone who goes in specmode can't play again and MUST rejoin on the Server.

Nadeo please fix this soon.

User avatar
Omnixor
Translator
Translator
Posts: 2959
Joined: 03 Jul 2010, 17:07
Location: Vilnius, Lithuania

Re: Can't play after going spec on passworded server

Post by Omnixor » 18 Aug 2013, 20:22

can approve.
- staff head of ESL TM²Stadium -

User avatar
tombuilder
Posts: 319
Joined: 28 Feb 2013, 10:33

Re: Can't play after going spec on passworded server

Post by tombuilder » 16 Sep 2013, 14:58

Same problem on our (password protected) team server.
A fix would be highly appreciated.

User avatar
Alinoa
Nadeo
Nadeo
Posts: 4061
Joined: 14 Jun 2010, 11:55
Location: France, Paris
Contact:

Re: Can't play after going spec on passworded server

Post by Alinoa » 17 Sep 2013, 10:22

Thanks all for your reports :)

Hacki65, this issue only concerns server with password. When you play on a server without password, please unstick the spectator option to be able to play on the server.
Ubisoft Support
Your Player Page

More information about maniaplanet, support, contents, community activities: useful links

ManiaPlanet technical documentation portal (Dedicated server, Mediatracker, ManiaLink, ManiaScript, Titles...)

noclantalula
Posts: 30
Joined: 23 Mar 2013, 13:56

Re: Can't play after going spec on passworded server

Post by noclantalula » 04 Oct 2013, 16:38

People i know this bug and someone just told me to use this plugin in xaseco, in the Custom Plugins (TMS-Files) just instal it and restart xaseco no need to edit . this is the name of the plugin: SpecJam XML bfix
Have fun all

User avatar
tombuilder
Posts: 319
Joined: 28 Feb 2013, 10:33

Re: Can't play after going spec on passworded server

Post by tombuilder » 05 Oct 2013, 20:36

noclantalula wrote:People i know this bug and someone just told me to use this plugin in xaseco, in the Custom Plugins (TMS-Files) just instal it and restart xaseco no need to edit . this is the name of the plugin: SpecJam XML bfix
Have fun all
Thank you very much! That fixed the problem indeed!

User avatar
w1lla
Posts: 2360
Joined: 15 Jun 2010, 11:09
Location: Netherlands
Contact:

Re: Can't play after going spec on passworded server

Post by w1lla » 05 Oct 2013, 20:41

A solution is also:

Set https://github.com/maniaplanet/document ... by.txt#L36 from

Code: Select all

False
to

Code: Select all

True
That solved it for me.
TM² Info
SM Info
QM Info

OS: Windows 10 x64 Professional
MB: MSI 970A-G46
Processor: AMD FX-6300 3500 mHz
RAM Memory: 16 GB DDR3
Video: SAPPHIRE DUAL-X R9 280X 3GB GDDR5
KB: Logitech G510s
Mouse: Logitech G300s
Mode Creation
ManiaScript Docs

DrRock
Posts: 9
Joined: 15 Feb 2012, 02:52

Re: Can't play after going spec on passworded server

Post by DrRock » 11 Dec 2013, 03:54

Thanks w1lla! That worked for me too.

Locked

Return to “Trackmania² Canyon Reports”

Who is online

Users browsing this forum: No registered users and 1 guest