Page 1 of 1

Internal Server Error (when connecting to master server)

Posted: 08 Apr 2014, 23:47
by Clem
Hi !

I've a problem with my dedicated servers since 2h.

I see my servers up when connecting with adminserv interface (on xml-rpc port), and I can see the process running with a "ps x" command via SSH, but I don't see the servers in Shootmania.

So, I tried to reboot my servers, but it doesn't work ... after a reboot attempt, the server isn't reachable via rpc anymore, and the process doesn't show.

I get this in the server logs :

[2014/04/08 23:22:39] Initializing...
[2014/04/08 23:22:39] Configuration file : CFG_obst_1.txt
[2014/04/08 23:22:39] Loading system configuration...
[2014/04/08 23:22:39] ...system configuration loaded
[2014/04/08 23:22:39] Loading cache...
[2014/04/08 23:22:39] ...OK
[2014/04/08 23:22:39] Listening for xml-rpc commands on port 5001.
[2014/04/08 23:22:39] Loading dedicated server configuration...
[2014/04/08 23:22:39] ...Dedicated server configuration loaded
[2014/04/08 23:22:40] Connecting to master server...
[2014/04/08 23:22:40] ...ERROR: Internal server error
[2014/04/08 23:22:40] Please wait, loading...
[2014/04/08 23:22:43] URL: maniaplanet://#join=
[2014/04/08 23:22:43] Match settings file : MatchSettings\MS_obst_1.txt
[2014/04/08 23:22:43] Loading match settings...
[2014/04/08 23:22:43] ...Match settings loaded
[2014/04/08 23:22:43] Autostart server on internet
[2014/04/08 23:22:43] Server not running, exiting.
[2014/04/08 23:22:44] Exiting...

I must clarify : I didn't change anything in my CFG files, starting scripts or anything, and all the servers were working just fine until tonight.

I think the error with the "master server" is maybe a problem with the Nadeo master server ? I guess there is a nadeo server that check the online dedicated servers, and display them in the game if everything is working fine ?

If it's not, could someone help me to understand the problem ? I'm looking for anything I would have miss for the 2 last hours, but can't figure it out o_O

Thank you !!


Re: Internal Server Error (when connecting to master server)

Posted: 09 Apr 2014, 09:17
by legor
Does the problem persist ? What is the login of your dedicated server account ? Which version of the dedicated server do you run ?

Re: Internal Server Error (when connecting to master server)

Posted: 09 Apr 2014, 22:09
by Clem
Ok, post translated :)

Thank you for your quick response, I worked all the day so I'm the one that is late to meet, but thank you anyway :)

So yes, I still have the same problem, with the same error when trying to start a dedicated server.

My account : rancebrume
(My nickname : Hysteria // Clem, Hysteria team leader, you may already have seen our servers :))

The affected servers are :

I didn't find any file giving me the dedicated server version i'm running, but the file is dated 18/11/2013 on my server. Considering that I downloaded it in 2014, I can assume this is the date when it was uploaded to your server. (I think this is the last update, I downloaded it last month)

Do not hesitate to ask for more informations, and thank you for helping hand !

P.S : Maybe would you prefer me to write in english, so that everybody can understand what I'm saying and maybe find some help with their own problems ? If you would, I'll edit this message to translate it in english :) (DONE !)

Re: Internal Server Error (when connecting to master server)

Posted: 10 Apr 2014, 11:15
by legor
Yep, bugs should be reported in english so that everybody can benefit from it, that would be nice from you if you could translate your post then :).

So, it's very strange beacause I can't find any error on my side. I wonder if you are not connecting to a wrong server :shock:. Could you please try "ping" and "ping" ?

Also, what is your IP address ?

And, is it possible for you to send a tcpdump trace when the error occurs ?

I hope that with this information we can help you.

Re: Internal Server Error (when connecting to master server)

Posted: 10 Apr 2014, 21:59
by Clem
Ok, never mind, I found my problem, it had nothing to do with your servers -_-'

But you showed me the way :D I tried to ping "" and "", and couldn't ping it. So, I tried to ping "" and couldn't ping it neither o_O

To get to the bottom, I tried to ping ( IP), and this time, I could ping it !!
That way, I discovered that my problem was with my DNS configuration.

If it can help anybody who has the same problem : I recently uninstalled "bind9", a software that allows you to use your dedicated server as a DNS server. But when I uninstalled it, my DNS remained "" in the server configuration ...

To fix it, you just have to edit the "etc/resolv.conf" file, and replace "nameserver" by :
(This is the Google's DNS, you can use any DNS you want instead of (or in addition to) those ones)

Legor, thank you again for your time and your help ! :)