Colour-Linking slows Editior down a lot.

Talk about the map editor here

Moderator: English Moderator

Post Reply
User avatar
trueWohoohi
Posts: 63
Joined: 02 Apr 2014, 22:14

Colour-Linking slows Editior down a lot.

Post by trueWohoohi » 12 Feb 2016, 12:03

Hi.
I've got a little problem with the colour-linking.
I really like the colour-linking feature, looks pretty cool in my opinion.
My problem is, when ever I use it (I tend to use it pretty massivly), it takes like ages to build any block with colourlinking. (The ones without are not affected, i can build & erase them instantly). It is really not any fun anymore.
It also does not depend on the graphic quality I am playing with. I just tried it with a resolution 640*480 and it still took me 9 Seconds to erase a healpad (or any other block with colourlinking).

You can test it on this map: https://sm.mania-exchange.com/maps/view ... =royal-orb
So, am I the only one with that problem? Do I just use this feature in a to massive scale?

My PC-Specs might interesting for this:
GPU: AMD Radeon R9 380 (some version by Sapphire) with 4GB Videomemory (even though Maniaplanet only recognizes 3 GB)
CPU: Intel Core i5 4460
RAM: 8GB Dual-Channel DDR3
Motherboard: ASRock H97 Anniversay
OS: Windows 7
and it is all stored on my 250GB SSD

(should be good enough to edit some maps in a game that came out early 2013)

User avatar
trueWohoohi
Posts: 63
Joined: 02 Apr 2014, 22:14

Re: Colour-Linking slows Editior down a lot.

Post by trueWohoohi » 04 Jun 2016, 22:17

As Nadeo is super active on the forum lately (which is awesome!), might I get an answer? :P
I know there aren't that many people that are affected by it, but maybe it can still get a fix? :D

User avatar
toffe
Posts: 664
Joined: 15 Jun 2013, 10:57
Location: The Netherlands
Contact:

Re: Colour-Linking slows Editior down a lot.

Post by toffe » 26 Jul 2016, 15:37

Looks like a heavy for loop ^^.

It takes like 3 to 4 seconds on my computer, but keep in mind, my processor has a high clockspeed (4,2-4,5Ghz), and that would maybe make a big difference.
It locks up all the game when removing it. I think it could be more efficient in some way.

User avatar
trueWohoohi
Posts: 63
Joined: 02 Apr 2014, 22:14

Re: Colour-Linking slows Editior down a lot.

Post by trueWohoohi » 27 Jul 2016, 19:39

Yeah, seems like it is an CPU related then, as it takes reasonable longer with my i5 4460 @ 3,2 GHz.
But I guess it is safe to say, a CPU like yours shouldn't be required. This game came out in early 2013, my CPU is a 'medium-class' 4 core processor from late 2014, it should handle the game easily.

This issue is especially important, considering how much effort Nadeo actually put into the Colour-Linking feature. Almost every 'tech' block can be coloured! Of course, normally, there are less blocks connected then on this map, but this problem is also noticable when using Colour-Linking on a small scale, it just interrups the Map building flow. It is not fun by any means. Considering this as an CPU Problem, the problem will be even bigger, if your PC has an older Processor, which probably isn't uncommon at all. So far ShootMania has always been really performant, I can even get 60 fps (well, playing on small maps) playing on my Laptop with the onboard graphics card of my i3 :D.

As this is a mayor cut-off to Map-Building and Creativity, I'd be really happy to this optimised/fixed. :thumbsup:

Post Reply

Return to “Map Editor”

Who is online

Users browsing this forum: No registered users and 2 guests