[MP4][UPDATE 01/09/2017] Broken Permissions?

Moderators: w1lla, NADEO

Post Reply
User avatar
Posts: 44
Joined: 29 May 2012, 16:26

[MP4][UPDATE 01/09/2017] Broken Permissions?

Post by jar009 » 02 Aug 2017, 20:38

so today I went online again after some time (holidays)
and saw another small update 27-29 MB size. so thougfht this won't take to long.
upon downloading the second pack an error occured telling me to retry the download.
so I press retry (otherwise I couldn't get on the game)
everything went fine from here on. the newly downloaded packages needed to be installed and needed to close/re-open MP4.
then suddenly nothing happens from this point. after waiting 25 minutes I think lets try to run the Maniaplanet launcher as adminstrator.
then these errors pop up...Image
any solutions to this?

tried to completely unistall MP4 and get a clean setup. : failed
Checked firewall : failed
checked if I still was the adminstrator (only user on this PC) : Failed
Last edited by jar009 on 01 Sep 2017, 21:06, edited 2 times in total.

User avatar
Posts: 15430
Joined: 05 Apr 2011, 19:10
Location: Europe

Re: [MP4][UPDATE 02/08/2017] Cannot load the game anymore

Post by TMarc » 02 Aug 2017, 21:53

Strange. The update worked fine for me.

Check your UAC and set it to off only for the time of the update?

User avatar
Posts: 44
Joined: 29 May 2012, 16:26

Re: [MP4][UPDATE 02/08/2017] Cannot load the game anymore

Post by jar009 » 03 Aug 2017, 09:12

oaky checked everything, rebooted my PC completely removed everything from Maniaplanet and tried to install a clean build. after 3 tries it worked...
still to me this may not happen so many times...

User avatar
Posts: 44
Joined: 29 May 2012, 16:26

Re: [MP4][UPDATE 01/09/2017] Cannot load the game anymore, again and still being ignored?

Post by jar009 » 01 Sep 2017, 20:57

new update got released. I updated my game and guess what?!
again this freaking thing... and yet none of the nadeo crew looked at it?

ran a checksum promt as some peeps in the community told me to do.. they are helping me more then you guys.

so this is what they let me do so far:
github prompt on maniaplanet folder result:
jarno@DESKTOP-4J0VNTA MINGW32 /c/Program Files (x86)/ManiaPlanet
$ find -type f -exec md5sum "{}" +
5bf8e37fa1e25227480f9cd2aca21fb6 *./d3dcompiler_46.dll
7fd5346b9eab166987728936793bcee3 *./GameData/GfxDevicePerfs.txt
3847b0779a543408dc9c43594cb02495 *./GameData/Translations/cs/cs.mo
ee72ed8af8ac5dcc70e733e49b9f889e *./GameData/Translations/da/da.mo
b2f747035d3acb034af2034b2d99675e *./GameData/Translations/de/de.mo
c8daa2502347473319e51cdca435e665 *./GameData/Translations/en/en.mo
388f977c80fb60d57c86e2356b43dfb3 *./GameData/Translations/en_GB/en_GB.mo
1836d310f39b40aa1aeeecda3b34f0c0 *./GameData/Translations/es/es.mo
8548762bb3397321c6fb39c627de45ea *./GameData/Translations/fi/fi.mo
a4e7380be293778a4272ffd0939d3052 *./GameData/Translations/fr/fr.mo
9ba23734bbfc680aeaa732fa390a352b *./GameData/Translations/hu/hu.mo
66c4ec1919a135a8e454bd6385bd0492 *./GameData/Translations/it/it.mo
83fa757e9990282db7b363075c83a28f *./GameData/Translations/ja/ja.mo
cf7dca183560ac422c6674803ba11ef4 *./GameData/Translations/ko/ko.mo
7aab5fd1b38a532701b2ca2a0acca7b5 *./GameData/Translations/nb/nb.mo
31b93946378e3fcd35666ef569412f44 *./GameData/Translations/nl/nl.mo
385bf11b187824926d42aee100cbe91e *./GameData/Translations/pl/pl.mo
db83e5e616be890a658b1aa4f999ddff *./GameData/Translations/pt/pt.mo
f1a46b2d4bd5053870c95ed340891b84 *./GameData/Translations/pt_BR/pt_BR.mo
aa35ff6ee84b5d55b66322149ad7e021 *./GameData/Translations/ro/ro.mo
aa42f830c911ad65ea09db9697e467d6 *./GameData/Translations/ru/ru.mo
aa83264bf313ffb4c9477c401e2752c6 *./GameData/Translations/sk/sk.mo
6e66a561f92fe7e91f6b4aeebb7a9ba8 *./GameData/Translations/sv/sv.mo
fa9e1459937b0b7ebe063e0e1e8195d5 *./GameData/Translations/tr/tr.mo
e16895b26725b8d1ada5197d1eb388da *./GameData/Translations/zh_CN/zh_CN.mo
06f4e322a0cd5d866244790908e07780 *./GameData/updater_files.txt
7a9a58094e0df8547aa37907b946abf7 *./gbx.ico
59571e6dbb75f6a549df82b8c87ca52f *./libwebp.dll
md5sum: ./ManiaPlanet.exe: Permission denied
573ded69a921aa70e22af132de38bd21 *./ManiaPlanetLauncher.exe
d09db97d5c48dd8dc0321f772925e3e4 *./Nadeo.ini
0179464939d4efcdfef99ac11f4b6260 *./ogg.dll
2f30363d9827ae470fbeffbba67990cb *./OpenAL32_bundled.dll
2fdfa82223228c1e9430d0bad68a8328 *./openvr_api.dll
0b567c353087dd4c31decc405c3419bf *./Packs/GpuCache_D3D11_SM4.zip
5f5c230bbd3ac47f6b8e4b6dbfeb817b *./Packs/GpuCache_D3D11_SM5.zip
2e18e53eda6b7ea2699bae655b096bb5 *./Packs/ManiaPlanet.pak
c568ee06ce01d58be780562c61dab7d3 *./Packs/Resource.pak
04c58bd2e83dd1aae1ab2bff988f5451 *./steam_api.dll
89fd95f6ec8788eca95d317f27427d3d *./ThumbGbx.tlb
02d2866f271614402a4e2850b7e71171 *./unins000.dat
fae59b2545e094d0544f4a10b3fb5ced *./unins000.exe
f2df0929a868cf47129d065028227a77 *./unins000.msg
e6a6c2ebaef2ed028813b61c51468e6e *./Updater.exe
e55a071bf1d3976e3ca668ec38386b10 *./uplay_r1_loader.dll
cc1b2775726f66fb7574f1f100066717 *./vorbis.dll

note the bold: "md5sum: ./ManiaPlanet.exe: Permission denied" in the middle

next up they asked me to look if all the admin settings were correct. wich in the end were all fine. (I'm the only user on the computer, and set as admin)
copied the Maniaplanet.exe and ran the prompt again..
$ find -type f -exec md5sum "{}" + | clip
md5sum: ./ManiaPlanet.exe: Permission denied

next up they gave me a clean Maniaplanet.exe to let me copy paste it into the folder...
permission as admin was asked. accepted the popup. suddenly acces to this folder got denied.

so far the only thing we can find are that some of the permissions become broken after each single update.
MP4 Beta wprled perfectly fine, but ever since every single update after it this problem occured.

my "quick" fix was to completely delete all files from maniaplanet and the games including. and get a fresh clean setup from maniaplanet.com... and a nice wait time of a few hours for all the updates to push through at the same time... with countless of restarts...

a permanent fix would be great...
I know I've been not so pollite in the past. but please also understand it from my point.. you work a whole week. then you play once or twice in the weekend. and suddenly an "hotfix" update (5-200mb) ruins the entire game?
and best thing of all you guys only work in the week... that's totally frustrating....

MP4 error again.png
again the same bug? still getting ignored
MP4 error again.png (387.93 KiB) Viewed 189 times

Post Reply

Return to “Maniaplanet Reports”

Who is online

Users browsing this forum: No registered users and 1 guest