[MP4] [BUG?] MP2 titlepack env-mix maps load in standard titlepacks

Moderators: w1lla, NADEO

Post Reply
User avatar
pjw
Halloween Mapper 2011
Posts: 99
Joined: 16 Jun 2010, 01:15
Location: Madison, WI, USA
Contact:

[MP4] [BUG?] MP2 titlepack env-mix maps load in standard titlepacks

Post by pjw » 09 Jan 2018, 04:19

This is something that might not technically be a bug, but it's at least poorly implemented and potentially confusing to users.

Being able to load standard MP2 titlepack maps in regular MP4 titlepacks. <--This is good.
Being able to load env-mix MP2 titlepack maps in regular MP4 titlepacks. <--This is bad.

I was playing regular MP4 Valley tonight, and loaded an unplayed map from my downloads folder and found various CPs that I could not complete. I eventually realized that it was an MP2 titlepack valley map that used the Lagoon car.

Ideally, one of three things should happen:
1) MP2 env-mix maps should not show up in the maplist when browsing from an MP4 station, or
2) There should be a warning displayed that indicates the map is env-mix and may not work properly unless loaded in MP2, or
3) The env-mix option should be supported in MP4, assuming the player has the required environments (and they should see an "unable to load" message explaining what the problem is if they don't).

#1 would be pretty quick and low-effort while we wait on #3... :)

Edit: Added some clarity re: game version vs. titlepack

User avatar
Dommy
Translator
Translator
Posts: 1809
Joined: 25 Aug 2011, 21:45
Location: Poland
Contact:

Re: [MP4] [BUG?] MP2 titlepack env-mix maps load in standard titlepacks

Post by Dommy » 09 Jan 2018, 07:46

You can still download and use Trackmania 2 title, the one used for multi-environment servers back in MP3. You can download it from here. There still are titles, which work with all environments, including Mr Sloppi's pack and Pursuit Multienvironment.

I agree that different cars should be playable in one environment based packs, since Nadeo moved all vehicles files to common directory, meaning that they technically are available in any title (even Storm), without need of owning the environment car comes from.

User avatar
pjw
Halloween Mapper 2011
Posts: 99
Joined: 16 Jun 2010, 01:15
Location: Madison, WI, USA
Contact:

Re: [MP4] [BUG?] MP2 titlepack env-mix maps load in standard titlepacks

Post by pjw » 09 Jan 2018, 08:01

Dommy wrote:
09 Jan 2018, 07:46
Nadeo moved all vehicles files to common directory, meaning that they technically are available in any title (even Storm), without need of owning the environment car comes from.
:shock: I did not know that.

If that's the case then...yeah...it's simply broken as-is, and tracks with non-standard vehicles should just work correctly.

Edit: After thinking about this for a while today, I suspect there might be a difference between something being present and usable, code-wise, and something being usable legally in certain ways? Even if the vehicles are in common (which might be the case for any number of technical reasons), that doesn't necessarily mean that Nadeo would be okay with them being used by packs that are specifically dedicated to a different vehicle? Dunno...

That being said, the whole situation with the TM2 pak and the game being split up into chunks after TM2 has never made a lot of sense to me anyway, so my opinion probably isn't really relevant. :)

The bottom line is that these tracks don't function properly under certain circumstances, which needs to be fixed somehow.

Post Reply

Return to “Maniaplanet Reports”

Who is online

Users browsing this forum: No registered users and 1 guest