Performance report

Moderators: w1lla, NADEO

Post Reply
User avatar
Hylis
Nadeo
Nadeo
Posts: 3917
Joined: 14 Jun 2010, 11:58

Performance report

Post by Hylis » 23 Jul 2012, 09:24

Hi,

To people who would like to see us work on improving performance, I would need more precise reports

Please specify, at minimum

1. Conditions of bad performances
Low number of players vs many players framerate

2. Your configuration
CPU and GPU

3. Indicate the setting, and prefer a lot the default ones to help us
Very Fast/ Fast / High quality / Very high quality
If you tweak your configuration, it is more difficult for us to read the issue

4. TCpu and TGpu for any framerate given
example:
100 FPS / TCpu 8.0 / TGpu / 10.0
To see the TCpu and TGpu, press 3 times CTRL + F11
It will help us to see if it is a CPU issue or GPU one.

We may ask for a screenshot of this report in order to help us optimize better.

User avatar
Miguel
Posts: 120
Joined: 24 Jul 2011, 04:37
Location: France
Contact:

Re: Performance report

Post by Miguel » 23 Jul 2012, 13:27

1. Conditions of bad performances
The more players there is on a server : low FPS and less GPU usage.
In replay editor of the same match, more FPS and GPU usage.
Alone in the map : much more FPS.

2. Your configuration
Intel i7 2700K OC @ 4.8 GHz
2x GTX 680 SLI
16 Go DDR3
Windows 7 x64 Pro
120Hz Asus 3D screen, vsync and triple buffering (so it's locked at 120 FPS).

3. Indicate the setting, and prefer a lot the default ones to help us
Very high quality (Haute qualité dans le launcher FR)

4. TCpu and TGpu for any framerate given
First test, BattleWaves, 60 players :
- In game (red spawn) : 48 FPS / TCpu 20.1 / TGpu 17.0
- In game (displaying scores) : 38 FPS / TCpu 26.4 / TGpu 19.1
- Replay editor (same spot) : 70 FPS / TCpu 13.8 / TGpu 15.2
- Map editor (same spot) : 121 FPS / TCpu 7.1 / TGpu 8.5
- In game (red spawn but less players on screen) : 54 FPS / TCpu 18.1 / TGpu 12.6

Second test, Melee, 29 players :
- In game (spawn) : 100 FPS / TCpu 10.5 / TGpu 11.8
- Replay editor (same spot) : 96 FPS / TCpu 10.0 / TGpu 12.3
- Map editor (same spot) : 120 FPS / TCpu 6.5 / TGpu 9.0

It seems that CPU is the bottleneck as GPU usage decreases when there is more players.

It's like the game is using two threads, it's locked to 25 % CPU usage online with many players.

User avatar
Hylis
Nadeo
Nadeo
Posts: 3917
Joined: 14 Jun 2010, 11:58

Re: Performance report

Post by Hylis » 23 Jul 2012, 13:44

- In game (displaying scores) : 38 FPS / TCpu 26.4 / TGpu 19.1
- Replay editor (same spot) : 70 FPS / TCpu 13.8 / TGpu 15.2
- Map editor (same spot) : 121 FPS / TCpu 7.1 / TGpu 8.5

You can basically take 1000 ms and divide by the higher value CPU or GPU to get the FPS. It is means that sometimes it is GPU, sometimes it CPU. CPU is likely to be the limitation with many players at the moment, and this is the optimization we would like to work soon on.

You go from 121 FPS to 38 FPS when you are drawing in the map editor without opponents to full action with interfaces on. I think our target FPS on this situation can be quite higher than 38 FPS and we will look at working on it.

And thank you for this detailed report Miguel!

tcq
Posts: 2705
Joined: 15 Jun 2010, 11:02

Re: Performance report

Post by tcq » 23 Jul 2012, 20:12

1. Conditions of bad performances
The more players there is on a server, the lower the FPS. Seems to be map dependent.
Alone in the map : much more FPS.

2. Your configuration
Intel Core2Duo T7500 @ 2.2 GHz
Nvidia 8600mGT 256mb
3 GB DDR2
Windows 7 x32 Professional

3. Indicate the setting, and prefer a lot the default ones to help us
Very fast (only max filtering from anisotropic 4x to bilinear).
Resolution at 1440x900.

4. TCpu and TGpu for any framerate given
First test: Alone on one server,
- In game (spawn point) : 48 FPS / TCpu 10.2 / TGpu 19,6
Second test: 16players Royal
- In game: 18FPS / TCpu 17,5 / TGpu 53,4
Third test: 27 players BattleWaves
- joining the game (spawn point): 48FPS / TCpu 19.4 / TGpu 18.7
- getting around the corner with 2-3 team mates and nothing else: 19.6 FPS / TCpu 27.6 / TGpu 49.4
- getting killed and respawning: 47.1 FPS / TCpu 16.1 / TGpu 18.8
The strange thing is, that the FPS drop down (as soon as I get into motion) seems to be unrelated to the amount on action on the screen. It stays between 18-25 independent of the amount of players, the amount of rockets and such stuff.
Fourth test: 28 players Battlewaves (another server)
- directly in the action with lots of shooting: 37FPS / TCpu 18.5 / TGpu 26.2
No problems at all.

My finale conclusion would be, that this FPS drop is map specific.
The one that made the huge problems had a lot of close quarter combat, while the flawless one was very open and nearly only mountains.
You do not have the required permissions to view the files attached to this post.

User avatar
MatheusKS
Posts: 325
Joined: 08 Sep 2011, 20:44
Location: Carazinho, RS. Brazil

Re: Performance report

Post by MatheusKS » 23 Jul 2012, 21:00

Hylis wrote:1. Conditions of bad performances
Low number of players vs many players framerate
In both situations. In the Brazilian servers FPS was even lower than in French servers [average of + or - 10 FPS in French servers (with a lot of people), 7-9 in Brazilian servers (with a few people)]. The game crashes if you open saved maps and edit replays, also crashing the editor when you create new maps after a round in multiplayer or by accessing manialinks (this occurring at various resolutions).
Hylis wrote:2. Your configuration
CPU and GPU
AMD Sempron 140 with nVidia GeForce 7025/nForce 630a.
Hylis wrote:Indicate the setting, and prefer a lot the default ones to help us
Very Fast/ Fast / High quality / Very high quality
If you tweak your configuration, it is more difficult for us to read the issue
Sorry for my English, I could not understand very well. When I started testing the game, my best performance was at a minimum resolution (640x480) on the small screen, yet with low FPS (12 - 15).
Some images of my game configuration: https://www.dropbox.com/s/ofjz4vu4nvn0n7y/Capturar.JPG, https://www.dropbox.com/s/1kwelet2ssdr54s/Capturar3.JPG and https://www.dropbox.com/s/22q5qz1hg0albjv/Capturar2.JPG.
Hylis wrote:TCpu and TGpu for any framerate given
example:
100 FPS / TCpu 8.0 / TGpu / 10.0
To see the TCpu and TGpu, press 3 times CTRL + F11
It will help us to see if it is a CPU issue or GPU one.
My video driver crashed.
CPU: Intel Core i5 (1.6 GHz); Video: ATI Radeon 8670M; RAM: 8GB; HD: 1TB; OS: Win8 SL 64 bits. Will be replaced soon.

marval25
Posts: 4
Joined: 24 Jul 2012, 04:44

Re: Performance report

Post by marval25 » 24 Jul 2012, 04:55

1. Conditions of bad performances
- Most of the time when the map is big, seems that the players didnt change anything.

2. Your configuration
AMD x6 3,4Ghz 1090T and SLI of GTX 470

3. Indicate the setting, and prefer a lot the default ones to help us
Actually i'm playing in "Fast" to run the game smoother but i was in Very high settings (But the game still be at a low FPS on a big map even if i'm at "Fast" setting)
I putted the Very high settings for the next test

4. TCpu and TGpu for any framerate given
In Very high settings=> 28FPS / TCpu 27,5 / TGpu 25,2
Link of Screenshot : http://image.noelshack.com/fichiers/201 ... stitre.jpg

P.S: When the round just started i was at 18FPS / TCPU 48,0 / TGpu 68,0
P.S²: My pc is clean, i'm running games like BF3 at Very high settings really smooth.

LuckyBoy
Nadeo
Nadeo
Posts: 468
Joined: 14 Jun 2010, 17:43

Re: Performance report

Post by LuckyBoy » 24 Jul 2012, 09:50

marval25 wrote: 4. TCpu and TGpu for any framerate given
In Very high settings=> 28FPS / TCpu 27,5 / TGpu 25,2
Link of Screenshot : http://image.noelshack.com/fichiers/201 ... stitre.jpg
As Hylis pointed out to me, you got a specially high "CpuWaitGpu" (last line of the left stats).
What is your cpu / gpu synchro mode ?
What is your display synchro mode (with optionnal triple buffer) ?
Do you have enabled SLI during the test ?
Do you have anything specific to cpu/gpu synchro (also called maximum buffered frames), display synchro, SLI whic applies to ManiaPlanet in your NVidia control panel ?

Thanks

marval25
Posts: 4
Joined: 24 Jul 2012, 04:44

Re: Performance report

Post by marval25 » 24 Jul 2012, 13:21

I dont know what is the cpu/gpu synchro mode, same for the display synchro mode (i also dont know how to change it of course)

I tried to disabled the SLI and i've got 14 on CpuWaitGpu :?

User avatar
Miguel
Posts: 120
Joined: 24 Jul 2011, 04:37
Location: France
Contact:

Re: Performance report

Post by Miguel » 24 Jul 2012, 13:27

You can change it in the launcher, in the Display advanced settings, there is a "Compatibility" button, then you can change the synchro mode (mine is set to None), and the vsync option.

Triple buffering is not saved (I made a post about it), but you can change it, as well as the synchro and vsync option ingame to see changes on the go, just click on the settings button in the upper bar ingame, then click the advanced button.

And to get better SLI performance scaling, I use the parameters found in this topic.

marval25
Posts: 4
Joined: 24 Jul 2012, 04:44

Re: Performance report

Post by marval25 » 24 Jul 2012, 13:58

I've set the Cpu/Gpu mode in None, and disabled rje Vsync and Triple Buffering.
I've also put the "Sli Setting" with Nvidia Inspector

Its better but i still cant be at more than 35fps :cry:

EDIT : Screenshot with new settings
http://image.noelshack.com/fichiers/201 ... -titre.jpg

Post Reply

Return to “Shootmania Reports”

Who is online

Users browsing this forum: No registered users and 1 guest