[SOLVED][MP4.1][BUG] Unable to validate map

Moderators: w1lla, NADEO

matt0926
Posts: 39
Joined: 02 Jun 2017, 20:39

[SOLVED][MP4.1][BUG] Unable to validate map

Post by matt0926 » 17 May 2019, 04:57

My map is 5 minutes long and has a lot of media tracker elements. When I get to the finish , the camera zooms out like normal, but it stays frozen like that and I don't get the dialog to exit. Pushing enter does not work. If I push ESC key, I'll get the "return to editor?" prompt. But clicking on yes does nothing. Only way out of it is to exit the game.


Steps to reproduce:
1. Validate map

User avatar
Miss
Posts: 1824
Joined: 05 Jan 2016, 11:34
Location: The Netherlands
Contact:

Re: [MP4.1][BUG] Unable to validate map

Post by Miss » 17 May 2019, 11:10

It could help if you posted a map file that reproduces the issue, too.
1070 GTX, i7 4790k, 16GB RAM, Windows 10
Forum moderator, opinions are my own. :thx:
Check out Image openplanet, the alternative ManiaPlanet & Turbo scripting platform! (Openplanet subforum)
I also stream on Twitch and tweet on Twitter.

matt0926
Posts: 39
Joined: 02 Jun 2017, 20:39

Re: [MP4.1][BUG] Unable to validate map

Post by matt0926 » 17 May 2019, 18:37

Miss wrote:
17 May 2019, 11:10
It could help if you posted a map file that reproduces the issue, too.
Alright, but the map is hard, I wouldn't want you to spend too much time on it.
https://www.dropbox.com/s/k5zpa99r7a1v6 ... p.Gbx?dl=1

User avatar
nighthawk4571
Posts: 530
Joined: 20 Aug 2011, 06:39
Location: QLD, Australia
Contact:

Re: [MP4.1][BUG] Unable to validate map

Post by nighthawk4571 » 18 May 2019, 02:13

Hi Matt

I had a look and I see that you have not computed shadows before running Validation. This might solve the problem - worked for me. I suggest computing at 'High' (NOT Ultra, as this may slow the map and the graphics down for many players).

When I hit the finish line, I got the normal 'Improve' or 'Exit & Validate' box and could then save the map ok. I sent you a pm with a link to my finished copy of your map.
* Caution: Saved with the same name as yours, so might be wise to download this file to a different folder. ;)

My Validation time (07'20''23) is quite bad, so you might like to load my copy of the map into Editor and set a better time. Hopefully this will complete your work. :arrow: :? ... :thumbsup:
Cheers ..... :pil
Nighthawk
Getting old, forgetting most of what I ever learned !
My name is Nighthawk. The 4571 used to be my IQ.
Image

Admin: http://bagracing.freeforums.org/portal.php
U-tUbe: https://www.youtube.com/user/bvnighthawk

matt0926
Posts: 39
Joined: 02 Jun 2017, 20:39

Re: [MP4.1][BUG] Unable to validate map

Post by matt0926 » 18 May 2019, 05:52

Yeah , that didn't work for me. Even when I compute shadows for me I'm getting the same problem. And each time I load the map , it's doing a "work in progress" which I'm guessing it's computing shadows every time.

matt0926
Posts: 39
Joined: 02 Jun 2017, 20:39

Re: [MP4.1][BUG] Unable to validate map

Post by matt0926 » 18 May 2019, 18:12

Well now I'm not getting the "Work in progress" dialog each time I load the map, but also my compute shadow options are disabled. And it still won't let me validate it.

User avatar
TMarc
Posts: 14947
Joined: 05 Apr 2011, 19:10
Location: Europe
Contact:

Re: [MP4.1][BUG] Unable to validate map

Post by TMarc » 18 May 2019, 20:09

Once the lightmap is calculated you cannot let calculate it, unless you modify the map.
maniaplanet forum global moderator

Link list with FAQ, Support, Wiki, Tutorials, Community activities, and much more.

System specs: Intel i7-970 12GB RAM, nVidia RTX 2060 6GB, Creative SB X-Fi, 2xSSD 1xHDD

User avatar
nighthawk4571
Posts: 530
Joined: 20 Aug 2011, 06:39
Location: QLD, Australia
Contact:

Re: [MP4.1][BUG] Unable to validate map

Post by nighthawk4571 » 18 May 2019, 22:56

I'm not sure you understood my post above. If you download my finished copy of the map, it's done! No need for you to recalculate shadows. All you need to do in the Editor is improve the validation time, then save.

Cheers ..... :pil
Nighthawk
Getting old, forgetting most of what I ever learned !
My name is Nighthawk. The 4571 used to be my IQ.
Image

Admin: http://bagracing.freeforums.org/portal.php
U-tUbe: https://www.youtube.com/user/bvnighthawk

matt0926
Posts: 39
Joined: 02 Jun 2017, 20:39

Re: [MP4.1][BUG] Unable to validate map

Post by matt0926 » 19 May 2019, 08:22

nighthawk4571 wrote:
18 May 2019, 22:56
I'm not sure you understood my post above. If you download my finished copy of the map, it's done! No need for you to recalculate shadows. All you need to do in the Editor is improve the validation time, then save.

Cheers ..... :pil
I tried it with yours, and it worked! Even when I make a few changes and validate after that it still works. I still don't understand why it wouldn't work with mine. Thank you.

User avatar
Miss
Posts: 1824
Joined: 05 Jan 2016, 11:34
Location: The Netherlands
Contact:

Re: [SOLVED][MP4.1][BUG] Unable to validate map

Post by Miss » 19 May 2019, 12:18

I'll mark this thread as Solved then. :thumbsup:
1070 GTX, i7 4790k, 16GB RAM, Windows 10
Forum moderator, opinions are my own. :thx:
Check out Image openplanet, the alternative ManiaPlanet & Turbo scripting platform! (Openplanet subforum)
I also stream on Twitch and tweet on Twitter.

Post Reply

Return to “Trackmania² Reports”

Who is online

Users browsing this forum: No registered users and 1 guest