[Dropped] PHP 5.3 Support

ManiaControl, the completely new designed and easy to use controller managing all your Maniaplanet server.

Moderators: kremsy, Jocy, Wabbitface, steeffeen, NADEO

Locked

Does ManiaControl need to support PHP5.3?

Poll ended at 09 May 2014, 13:46

Yes, I still want to keep PHP5.3 for a long time.
1
8%
I don't mind.
2
15%
No, ManiaControl should move on and make use of the new features in PHP5.4!
10
77%
 
Total votes: 13

User avatar
steeffeen
Translator
Translator
Posts: 2472
Joined: 14 Oct 2012, 16:22
Location: Germany

[Dropped] PHP 5.3 Support

Post by steeffeen » 05 May 2014, 13:46

Hey there!

So we've been trying to completely support PHP 5.3
Though it makes some of the code for building features efficiently kind of obstructed.
Moreover plugin authors would have to support 5.3 as well, limiting the freedom.

Note: Official support for 5.3 drops in July 2014!
Source: PHP 5.3 Reaching End of Life

Please take a look at this poll and think about whether it's actually necessary to support PHP5.3 before answering.

Regards,
Steff
    Game Mode and Title Pack Creator, Developer, ShootMania-Player & more

    ManiaControl, FancyManiaLinks

    The_Big_Boo
    Posts: 1041
    Joined: 15 Jun 2010, 15:46

    Re: PHP 5.3 Support

    Post by The_Big_Boo » 05 May 2014, 14:44

    As it seems I'm only one who voted for 5.3 support at the moment, I'll explain my point of view (and also for you to know who voted for this option, so you don't think someone really wants 5.3 support in case I'm staying the only one ^_^)

    Though I agree that people should move on at least 5.4, I think supporting 5.3 isn't that hard and isn't really limiting freedom. The "new features" of 5.4 as listed by the PHP team are mainly syntaxic sugar than real additions:
    - Support for traits has been added.
    Not that useful. It's a way to do multiple inheritance, which should be avoided except in really particular cases.
    - Short array syntax has been added, e.g. $a = [1, 2, 3, 4]; or $a = ['one' => 1, 'two' => 2, 'three' => 3, 'four' => 4];.
    - Function array dereferencing has been added, e.g. foo()[0].
    - Closures now support $this.
    - <?= is now always available, regardless of the short_open_tag php.ini option.
    - Class member access on instantiation has been added, e.g. (new Foo)->bar().
    - Class::{expr}() syntax is now supported.
    Syntaxic sugar.
    - Binary number format has been added, e.g. 0b001001101.
    Rarely useful.
    - Improved parse error messages and improved incompatible arguments warnings.
    Not essential for users, only for developpers.
    - The session extension can now track the upload progress of files.
    - Built-in development web server in CLI mode.
    Server controllers aren't concerned.


    Anyway, if people who want to use ManiaControl already have 5.4 or can update to 5.4, you shouldn't even care about that question. ^_^

    Edit: btw, 5.5 has what I consider as a great addition: the "finally" keyword.
    OS: Win 7 Pro x64
    RAM: 2x4GB Corsair @ 1600MHz
    CPU: Intel i5 760 @ 3.6GHz
    Mobo: Asus P7P55D-E
    GPU: NVidia GTX 760 2GB
    HDD: WD Black 1TB
    Sound: VIA VT1828S (onboard)
    Peripherals: Razer DeathAdder - Razer DeathStalker - Logitech F310

    User avatar
    steeffeen
    Translator
    Translator
    Posts: 2472
    Joined: 14 Oct 2012, 16:22
    Location: Germany

    Re: PHP 5.3 Support

    Post by steeffeen » 05 May 2014, 14:54

    The_Big_Boo wrote:
    - Closures now support $this.
    Syntaxic sugar.
    that's actually the main reason

    to use closures you have to pass all variables that you want to access with a use() statement to the closure
    like the local object $this, the maniacontrol object and private properties
    private method access is impossible, too
      Game Mode and Title Pack Creator, Developer, ShootMania-Player & more

      ManiaControl, FancyManiaLinks

      User avatar
      steeffeen
      Translator
      Translator
      Posts: 2472
      Joined: 14 Oct 2012, 16:22
      Location: Germany

      Re: PHP 5.3 Support

      Post by steeffeen » 09 May 2014, 17:36

      Alright.
      It's official: We will go with the time and only support PHP 5.4 or higher! :pil

      P.s. I apologise for those who would like to keep using 5.3 :?
        Game Mode and Title Pack Creator, Developer, ShootMania-Player & more

        ManiaControl, FancyManiaLinks

        User avatar
        nighthawk4571
        Posts: 573
        Joined: 20 Aug 2011, 06:39
        Location: QLD, Australia
        Contact:

        Re: [Dropped] PHP 5.3 Support

        Post by nighthawk4571 » 09 May 2014, 21:00

        * Gee that was a quick vote, taken while we Aussies were sleeping! I am writing this post at 6:00am :(

        ** I tend to agree with The_Big_Boo on his points but then, we are not really in control of these tools, so the authors will do whatever they choose and we will have to accept that.

        *** I have no confidence in upgrading my PHP until 5.4 or 5.5 or whatever is at least as stable as 5.3. My server runs on Linux CentOS 6.5 and PHP 5.4 is a risky choice at the moment. This server is racked and is 200km away from my place, costs me quite a bit to lease each month, hosts email, web services as well well as game servers, so I don't like to mess with the OS too much.

        **** I would like to use tools like ManiaControl and eXpansion on some of my servers (have used xaseco and XAseco2 for years) but I am happy to check in from time-to-time and see if future developments will work for me.

        So although I was snoring during the voting period, I guess I would have gone with Choice No. 2, as I will stick with Xymph's# tools until other choices become compatible (and better if that's really possible :)) for me.

        The wording in Choice No. 3 looks like the decision was already made anyway:
        "No, ManiaControl should move on and make use of the new features in PHP5.4!" ... is not exactly a neutral question is it? :o

        Thanks guys and keep up your good work. Don't be discouraged if things get a bit difficult at times because what you are doing for the TM Community is more than millions of people could even think of trying (including me!) :thx:

        Cheers :pil

        # Xymph is a legend - he will live forever!
        Nighthawk
        Getting old, forgetting most of what I ever learned !
        My name is Nighthawk. The 4571 used to be my IQ.
        Image

        Admin: http://bagracing.freeforums.org/portal.php
        U-tUbe: https://www.youtube.com/user/bvnighthawk

        User avatar
        steeffeen
        Translator
        Translator
        Posts: 2472
        Joined: 14 Oct 2012, 16:22
        Location: Germany

        Re: [Dropped] PHP 5.3 Support

        Post by steeffeen » 09 May 2014, 21:36

        nighthawk4571 wrote:* Gee that was a quick vote, taken while we Aussies were sleeping! I am writing this post at 6:00am :(
        you did have time to vote during the last 4 days :D
        are you really sleeping that long? ;)
        nighthawk4571 wrote:The wording in Choice No. 3 looks like the decision was already made anyway:
        "No, ManiaControl should move on and make use of the new features in PHP5.4!" ... is not exactly a neutral question is it? :o
        if we would put 3 neutral votes the poll would be kind of useless ^.^
          Game Mode and Title Pack Creator, Developer, ShootMania-Player & more

          ManiaControl, FancyManiaLinks

          User avatar
          nighthawk4571
          Posts: 573
          Joined: 20 Aug 2011, 06:39
          Location: QLD, Australia
          Contact:

          Re: [Dropped] PHP 5.3 Support

          Post by nighthawk4571 » 09 May 2014, 23:19

          steeffeen wrote: you did have time to vote during the last 4 days :D
          are you really sleeping that long? ;)
          Really?! I check the forums at least once every day and I didn't see this vote. My apologies... must be going blind.
          nighthawk4571 wrote:The wording in Choice No. 3 looks like the decision was already made anyway:
          "No, ManiaControl should move on and make use of the new features in PHP5.4!" ... is not exactly a neutral question is it? :o
          if we would put 3 neutral votes the poll would be kind of useless ^.^[/quote]

          Fair enough. So it's called "PHP5.4!" and not "PHP5.4" ? Language is a powerful tool. :)

          Cheers :pil
          Nighthawk
          Getting old, forgetting most of what I ever learned !
          My name is Nighthawk. The 4571 used to be my IQ.
          Image

          Admin: http://bagracing.freeforums.org/portal.php
          U-tUbe: https://www.youtube.com/user/bvnighthawk

          Locked

          Return to “ManiaControl”

          Who is online

          Users browsing this forum: No registered users and 1 guest