Page 1 of 1

Dedimania plugin error

Posted: 20 Jan 2019, 17:34
by chapelier
Weird :
i have 6 servers. On 5 servers everything works fine. But on one server dedimania plugin doesnt work.
Here is the log message (Thanks for help !) :

Code: Select all

[20-Jan-2019 16:21:44 UTC] [INFO] Ch√Ępelier skipped the current Map!
[20-Jan-2019 16:22:05 UTC] [INFO] Dedimania Submitting Map Times at End-Map Start
string(16) "Dedimania Debug:"
string(355) "<h1>Error 400: Bad Request</h1>
<br>
Request host: dedimania.net:8082
<br>
Request path: /Dedimania (POST /Dedimania HTTP/1.1)
<br>
Request agent: ManiaControl v0.232
<br>
Request error: <h1>Error 400: Bad Request</h1>
<br>
Request host: dedimania.net:8082
<br>
Request path: /Dedimania (POST /Dedimania HTTP/1.1)
<br>
Request agent: ManiaControl v0.232

"
[20-Jan-2019 16:22:07 UTC] [INFO] Try to fetch Dedimania Records
[20-Jan-2019 16:22:07 UTC] [INFO] 0 Dedimania Records Fetched succesfully!
[20-Jan-2019 16:23:06 UTC] [INFO] Ch√Ępelier skipped to Map [miniRPG] Not suitable A01!
[20-Jan-2019 16:23:29 UTC] [INFO] Try to fetch Dedimania Records
[20-Jan-2019 16:23:30 UTC] [INFO] 0 Dedimania Records Fetched succesfully!

Re: Dedimania plugin error

Posted: 17 Apr 2020, 11:07
by jocio13
hello, I have the same problem, see below my ManiaControl logs.
Did I miss a configuration to be operationnel ?

Code: Select all

[17-Apr-2020 09:57:25 UTC] [INFO] Dedimania Submitting Map Times at End-Map Start
string(16) "Dedimania Debug:"
string(355) "<h1>Error 400: Bad Request</h1>
<br>
Request host: dedimania.net:8082
<br>
Request path: /Dedimania (POST /Dedimania HTTP/1.1)
<br>
Request agent: ManiaControl v0.251
<br>
Request error: <h1>Error 400: Bad Request</h1>
<br>
Request host: dedimania.net:8082
<br>
Request path: /Dedimania (POST /Dedimania HTTP/1.1)
<br>
Request agent: ManiaControl v0.251

"
[17-Apr-2020 09:57:27 UTC] [ERROR] Dedimania Records could not be fetched, debuginfo:["s8350:1587116131.1197",{"UId":"ovlsTbPB47EdE9lSR1iPDk_BKvl","Name":"$o$000Pim#$w$0f0Ca$0f0s$4f4i$8f8n$cfco","Environment":"Stadium","Author":"rexxar","NbCheckpoints":4,"NbLaps":2},null,{"SrvName":"$09fPim#$zPOC Histo Stadium","Comment":"Le serveur TM2 Stadium des PIM ! Pouf c'est tout !","Private":false,"NumPlayers":1,"MaxPlayers":32,"NumSpecs":0,"MaxSpecs":32},[{"Login":"jocio","IsSpec":false}]]
[17-Apr-2020 09:57:54 UTC] [INFO] Pim#Jocio skipped to Map Pim#ThreeFeathersCasino_v08!

Re: Dedimania plugin error

Posted: 17 Apr 2020, 12:41
by Miss
I'm not a ManiaControl developer so I can't speak for them, but just looking at the logs makes me think of Dedimania's general instability. It has issues like this, regularly. We just kinda have to live with it. :( This is likely something you'd want to bring up on the Dedimania forums as well.

Re: Dedimania plugin error

Posted: 19 May 2020, 13:07
by axelalex2
Hey,
we know about Dedimania Plugin instabilities, and i already tried to fix a lot of this stuff, but it is not easy. For some reason, records on maps with custom items are not getting accepted by Dedimania.net, while the requests are equally structured to those on maps without custom items, so finding a fix was not successful yet.

We will have a look in the future again, possibly rewriting the whole plugin, if nothing else works.