eXpansion 1.0.0 ~ Beta (06/03/2016)

The next generation of server controlling with clean and powerful user interface

Moderators: reaby, oliverde8, NADEO

Locked
hackie
Posts: 1142
Joined: 19 Jul 2012, 22:43

Re: eXpansion 1.0.0 ~ Beta (06/03/2016)

Post by hackie » 13 Mar 2016, 12:34

Searching on mania exchange not working anymore , keeps searching.


Another strange thing :

In console I see errors at mapchange
error while reading mapdata File is not a map ( but still loads the map , maybe also fu... windows )
System Specs:
OS: Windows 7 Professionnal x64
CPU: Intel Core i7-6700K / 4 GHz - 8 MB cache
GPU: MSI GTX 980TI GAMING 6G - OC Edition
Motherboard: ASUS MAXIMUS VIII RANGER
RAM : 32Gb Kingston HyperX Savage - DDR4
DirectX 11

oliverde8
Posts: 1328
Joined: 16 Jun 2010, 07:33
Location: in a Blue Box

Re: eXpansion 1.0.0 ~ Beta (06/03/2016)

Post by oliverde8 » 13 Mar 2016, 13:08

hackie wrote:Searching on mania exchange not working anymore , keeps searching.


Another strange thing :

In console I see errors at mapchange
error while reading mapdata File is not a map ( but still loads the map , maybe also fu... windows )
First did you run the update ? Because I can't reproduce on windows.

You can download maps and everything normally, it will just not run it in a new processs. There will be a small freeze then it will continue to work as intended.

Second part I have no idea, that part of the code is 2 years old. And I have no issues on PHP5.4 PHP5.6 and PHP7 on both windows and linux servers.Does it do that error foreach map or some maps only?
Image
Developper for The next generation, Clean and Powerfull controller eXpansion for your SM & TM server . Working on eXpansion² with full MP4 support and many other awesome features...

hackie
Posts: 1142
Joined: 19 Jul 2012, 22:43

Re: eXpansion 1.0.0 ~ Beta (06/03/2016)

Post by hackie » 13 Mar 2016, 13:48

sended you pm

screenie
System Specs:
OS: Windows 7 Professionnal x64
CPU: Intel Core i7-6700K / 4 GHz - 8 MB cache
GPU: MSI GTX 980TI GAMING 6G - OC Edition
Motherboard: ASUS MAXIMUS VIII RANGER
RAM : 32Gb Kingston HyperX Savage - DDR4
DirectX 11

TheBigG.
Posts: 403
Joined: 11 Jun 2011, 16:11

Re: eXpansion 1.0.0 ~ Beta (06/03/2016)

Post by TheBigG. » 13 Mar 2016, 15:07

hello

it seems like dedimania still not work in laps mode. eXpansion says

Code: Select all

[DediMania/Connection]
Warning in method_helper.php(1254): IGNORE RECORD for the-big-gll. on UAQHRSQ4hOiYdiuBygUvcLOf3cg,2,1 for the-big-gll. : bad num of checkpoints (84 for 28) ! (34306,43167,51838,54538,58896,62475,64458,65942,73053,87992,94904,100525,107528,109574,113051,149010,151531,157137,165183,174764,182755,187237,192180,194673,199451,208805,216814,224416,226001,234981,242945,245496,249745,253295,254871,256265,263074,277923,284420,292281,299413,301478,304978,312232,314794,320252,328688,338203,346168,350591,355531,358017,362791,372000,380072,387581,389138,397985,405940,408463,412715,416250,417948,419478,426648,441147,447398,461302,468148,470248,473778,480932,483538,489722,497134,506154,515022,519539,524491,526983,531761,543453,551431,558928)
If 28 if not the real number of cp then contact the Dedimania maintainer to correct it. (34306,43167,51838,54538,58896,62475,64458,65942,73053,87992,94904,100525,107528,109574,113051,149010,151531,157137,165183,174764,182755,187237,192180,194673,199451,208805,216814,224416,226001,234981,242945,245496,249745,253295,254871,256265,263074,277923,284420,292281,299413,301478,304978,312232,314794,320252,328688,338203,346168,350591,355531,358017,362791,372000,380072,387581,389138,397985,405940,408463,412715,416250,417948,419478,426648,441147,447398,461302,468148,470248,473778,480932,483538,489722,497134,506154,515022,519539,524491,526983,531761,543453,551431,558928)
Warning in method_helper.php(1359): VReplay has not the same number of checks as best time (84,28) !
Client:
OS: Win10/Debian CPU: Intel 9900k GPU: NVIDIA 1080TI Display: 3x Acer Predator XB271HUbmiprz 1440p@165 Hz

Server:
OS: Debian Stable @ Backports Kernel CPU: Intel 6700k RAM: 32 GB Storage: 2x 256 GB NVMe SSD@Raid 1

User avatar
w1lla
Posts: 2373
Joined: 15 Jun 2010, 11:09
Location: Netherlands
Contact:

Re: eXpansion 1.0.0 ~ Beta (06/03/2016)

Post by w1lla » 13 Mar 2016, 15:21

Cant seem to download the contents due to a error in the api get contents of manialive-lib. But it seems the url is good, wondering where the problem might be. Running on Win10.
TM² Info
SM Info
QM Info

OS: Windows 10 x64 Professional
MB: MSI 970A-G46
Processor: AMD FX-6300 3500 mHz
RAM Memory: 16 GB DDR3
Video: SAPPHIRE DUAL-X R9 280X 3GB GDDR5
KB: Logitech G510s
Mouse: Logitech G300s
Mode Creation
ManiaScript Docs

oliverde8
Posts: 1328
Joined: 16 Jun 2010, 07:33
Location: in a Blue Box

Re: eXpansion 1.0.0 ~ Beta (06/03/2016)

Post by oliverde8 » 13 Mar 2016, 17:15

hackie wrote:sended you pm

screenie
Hey,

thanks I found the error, I wasn't getting the proper path to php.exe, it worked fine on my machine that I had configured properly and it worked fine on linux but not on windows. Hopefully it is now fixed.

so all my fault, should be fine now ;)
w1lla wrote:Cant seem to download the contents due to a error in the api get contents of manialive-lib. But it seems the url is good, wondering where the problem might be. Running on Win10.
Hi, github has a limit in queries, does it asks you for a github token? You will probably need to create one in github or wait until your daily quote resets.
TheBigG. wrote:hello

it seems like dedimania still not work in laps mode. eXpansion says
I think reaby is working on it,we never did fix it so normal that it should still nor work :roflol:
Image
Developper for The next generation, Clean and Powerfull controller eXpansion for your SM & TM server . Working on eXpansion² with full MP4 support and many other awesome features...

hackie
Posts: 1142
Joined: 19 Jul 2012, 22:43

Re: eXpansion 1.0.0 ~ Beta (06/03/2016)

Post by hackie » 13 Mar 2016, 20:27

MX thingy is fixed , thanks.


Reaby told me that it is possible to add maps local with expansion.
Menu / add local map

When I do that the screen pops up but not showing any maps.

I saved my maps in : dedicatedserver/userdata/maps/downloaded/(and here put I my maps)
System Specs:
OS: Windows 7 Professionnal x64
CPU: Intel Core i7-6700K / 4 GHz - 8 MB cache
GPU: MSI GTX 980TI GAMING 6G - OC Edition
Motherboard: ASUS MAXIMUS VIII RANGER
RAM : 32Gb Kingston HyperX Savage - DDR4
DirectX 11

reaby
Posts: 973
Joined: 29 Dec 2010, 23:26
Location: Eastern Finland
Contact:

Re: eXpansion 1.0.0 ~ Beta (06/03/2016)

Post by reaby » 13 Mar 2016, 21:01

oliverde8 wrote:
TheBigG. wrote:hello

it seems like dedimania still not work in laps mode. eXpansion says
I think reaby is working on it,we never did fix it so normal that it should still nor work :roflol:
It saves now dedimania times with laps legacy gamemode! Atleast it works for my dev-server xD
hackie wrote: When I do that the screen pops up but not showing any maps.

I saved my maps in : dedicatedserver/userdata/maps/downloaded/(and here put I my maps)
I said also you need to create *titleId* folder there, examples:
on linuxes also capital letters counts.

stadium server:

Code: Select all

Dedicated\UserData\Maps\Downloaded\TMStadium\
multi envir server:

Code: Select all

Dedicated\UserData\Maps\Downloaded\Trackmania_2@nadeolabs\

hackie
Posts: 1142
Joined: 19 Jul 2012, 22:43

Re: eXpansion 1.0.0 ~ Beta (06/03/2016)

Post by hackie » 13 Mar 2016, 21:15

O , my misstake.

I did post it wrong , I had the maps installed in :

Dedicated\UserData\Maps\Downloaded\TMStadium\( here are my maps )

Sorry about that , I had the right folder but expansion did not show the maps.
System Specs:
OS: Windows 7 Professionnal x64
CPU: Intel Core i7-6700K / 4 GHz - 8 MB cache
GPU: MSI GTX 980TI GAMING 6G - OC Edition
Motherboard: ASUS MAXIMUS VIII RANGER
RAM : 32Gb Kingston HyperX Savage - DDR4
DirectX 11

hackie
Posts: 1142
Joined: 19 Jul 2012, 22:43

Re: eXpansion 1.0.0 ~ Beta (06/03/2016)

Post by hackie » 13 Mar 2016, 21:53

I found the problem I think , about add map local :

I use converted maps from TMX , ported to TM2.
The files still have the extension .Challenge instead of .map

So maybe expansion does not search for maps like : veryshort10.Callenge
System Specs:
OS: Windows 7 Professionnal x64
CPU: Intel Core i7-6700K / 4 GHz - 8 MB cache
GPU: MSI GTX 980TI GAMING 6G - OC Edition
Motherboard: ASUS MAXIMUS VIII RANGER
RAM : 32Gb Kingston HyperX Savage - DDR4
DirectX 11

Locked

Return to “eXpansion”

Who is online

Users browsing this forum: No registered users and 1 guest