[SOLVED]Problem during starting eXpansion

The next generation of server controlling with clean and powerful user interface

Moderators: reaby, oliverde8, NADEO

wazerti
Posts: 99
Joined: 05 Nov 2012, 15:41

[SOLVED]Problem during starting eXpansion

Post by wazerti » 31 Oct 2016, 16:42

Hello,

I'm trying to set up eXpansion on Ubuntu 16.04
I've followed the steps described in the tutorial. I've downloaded all packages needed.
Then I went into the Mysql Console and I created a new databases utf8_unicode_ci.

I think I configured correctly the config.ini

And when I want to start eXpansion I get this :

Code: Select all

root@xxxxx:~/Nascar/eXpansion# ./run --start
Launching ManiaLive Daemon with the following arguments:
Writing process id : 9869 to file.
Then I searched in the logs and I found that :

Code: Select all

[2016-09-10T17:25:33+00:00] [eXpansion] AutoLoading eXpansion pack ...
[2016-09-10T17:25:33+00:00] Unknown plugin path : libraries/ManiaLivePlugins
[2016-09-10T17:26:04+00:00]


                     __   __                      _
                     \ \ / /                     (_)
                  ___ \ ' / _ __   __ _ _ __  ___ _  ___  _ __
                 / _ \ > < | '_ \ / _` | '_ \/ __| |/ _ \| '_ \
                |  __// . \| |_) | (_| | | | \__ \ | (_) | | | |
                 \___/_/ \_\ .__/ \__,_|_| |_|___/_|\___/|_| |_|
...........................| |.........Plugin Pack for Manialive...............
                           |_|
[2016-09-10T17:26:05+00:00] Dedicated Server running for title: TMStadium
[2016-09-10T17:26:05+00:00] Dedicated Server api version in use: 2013-04-16
[2016-09-10T17:26:05+00:00] eXpansion version: 1.0.0.5
[2016-09-10T17:26:05+00:00] Minimum Dedicated version 2014.7.24: Pass (2015.6.16
[2016-09-10T17:26:05+00:00] Minimum PHP version 5.4.3: Pass (5.6.19)
[2016-09-10T17:26:05+00:00] Garbage Collector enabled: Pass
[2016-09-10T17:26:06+00:00]
[2016-09-10T17:26:06+00:00] Checking write permission in directories :
[2016-09-10T17:26:06+00:00] Permissions are fine for directory : 'tmp'
[2016-09-10T17:26:06+00:00] Permissions are fine for directory : 'tmp/nascar_1'
[2016-09-10T17:26:06+00:00]
[2016-09-10T17:26:06+00:00] eXpansion needs PHP extension com_dotnet to run. Ena
[2016-09-10T17:26:06+00:00] eXpansion works better with PHP extension gd2 :
[2016-09-10T17:26:15+00:00] Version 1.0.0.5 build 2016-04-03 10:23:12 AM
[2016-09-10T17:26:15+00:00]
[2016-09-10T17:26:15+00:00] Language support detected for: de,en,fi,fr!
[2016-09-10T17:26:15+00:00] Enabling default locale:
[2016-09-10T17:26:15+00:00]
[2016-09-10T17:26:15+00:00]
[2016-09-10T17:26:15+00:00] ----------------------------------------------------
[2016-09-10T17:26:15+00:00]
[2016-09-10T17:26:28+00:00] [eXpansion] AutoLoading eXpansion pack ...
[2016-09-10T17:26:28+00:00] Unknown plugin path : libraries/ManiaLivePlugins
[2016-09-10T17:26:34+00:00]
And I get this repeated for few lines...

Thank you

tcq
Posts: 2705
Joined: 15 Jun 2010, 11:02

Re: Problem during starting eXpansion

Post by tcq » 31 Oct 2016, 17:51

Code: Select all

[2016-09-10T17:26:06+00:00] eXpansion needs PHP extension com_dotnet to run. Ena
According to this post, you might need to enable it manually.
In previous versions of PHP, COM was embedded. Starting from PHP 5.4.5, there is a new extension called php_com_dotnet.dll. In order to continue to use COM, add the following line to php.ini:

Code: Select all

extension=php_com_dotnet.dll
But as I don't know anything about php, I might be totally on the wrong track :D

oliverde8
Posts: 1319
Joined: 16 Jun 2010, 07:33
Location: in a Blue Box

Re: Problem during starting eXpansion

Post by oliverde8 » 31 Oct 2016, 18:46

tcq wrote:

Code: Select all

[2016-09-10T17:26:06+00:00] eXpansion needs PHP extension com_dotnet to run. Ena
According to this post, you might need to enable it manually.
In previous versions of PHP, COM was embedded. Starting from PHP 5.4.5, there is a new extension called php_com_dotnet.dll. In order to continue to use COM, add the following line to php.ini:

Code: Select all

extension=php_com_dotnet.dll
But as I don't know anything about php, I might be totally on the wrong track :D
confirming that is the issue.

Need to make that more clear in the check at start, even I have issues finding it in the logs.
Image
Developper for The next generation, Clean and Powerfull controller eXpansion for your SM & TM server . Working on eXpansion² with full MP4 support and many other awesome features...

wazerti
Posts: 99
Joined: 05 Nov 2012, 15:41

Re: Problem during starting eXpansion

Post by wazerti » 31 Oct 2016, 19:56

Thanks for your fast answer :)

I've added this line into the php.ini file but I get the same 2 lines message.

I've more checked the log files and I noticed there aren't any line for the last 3 days.
The logs lines stops at the October 28th 2016.
There are no logs for the days when I tried to start with Ubuntu :? (I was on Windows before...)

Or maybe I don't search in the right file, I've seen manialive-error.log and manialive-nascar.console.log
And I use ./run --start in the eXpansion folder to start.

Thanks

oliverde8
Posts: 1319
Joined: 16 Jun 2010, 07:33
Location: in a Blue Box

Re: Problem during starting eXpansion

Post by oliverde8 » 31 Oct 2016, 20:40

oo sorry,

I didn't read well your first post on you being on Ubuntu. You don't need dotnet on Ubuntu.

Can you try to launch php bootstrap.php it should then print some information directly in console.
Image
Developper for The next generation, Clean and Powerfull controller eXpansion for your SM & TM server . Working on eXpansion² with full MP4 support and many other awesome features...

wazerti
Posts: 99
Joined: 05 Nov 2012, 15:41

Re: Problem during starting eXpansion

Post by wazerti » 31 Oct 2016, 21:01

No problem x)

When I write php bootsrapper.php in the console in the eXpansion folder I get this :

Code: Select all

root@MONVPS2:~/Nascar/eXpansion# php bootstrapper.php

 _|      _|                      _|            _|        _|
 _|_|  _|_|    _|_|_|  _|_|_|          _|_|_|  _|            _|    _|    _|_|
 _|  _|  _|  _|    _|  _|    _|  _|  _|    _|  _|        _|  _|    _|  _|_|_|_|
 _|      _|  _|    _|  _|    _|  _|  _|    _|  _|        _|  _|  _|    _|
 _|      _|    _|_|_|  _|    _|  _|    _|_|_|  _|_|_|_|  _|    _|        _|_|_|
-----------------------------------------------------
PHP Environment Compatibility Test
-----------------------------------------------------
PHP 5.3.1 or newer    -> required  -> [ Yes ] 7.0.8-0ubuntu0.16.04.3
Standard PHP Library  -> required  -> [ Yes ]
JSON                  -> required  -> [ Yes ]
cURL with SSL         -> required  -> [ Yes ] 7.47.0 (with OpenSSL/1.0.2g)
MySQL                 -> optional  -> [ No  ]
MySQLI                -> optional  -> [ Yes ]
SQLite3               -> optional  -> [ Yes ]
-----------------------------------------------------
Timezone is not set in php.ini. Please edit it and change/set "date.timezone" appropriately. Setting to default: 'America/New_York'
MySQL is disabled, threading will not work. ManiaLive may encounter some perfomance trouble.
Running ManiaLive 4.0.0...
PHP Fatal error:  Uncaught Error: Call to undefined function Maniaplanet\DedicatedServer\Xmlrpc\simplexml_load_string() in /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Xmlrpc/Request.php:146
Stack trace:
#0 /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Xmlrpc/GbxRemote.php(201): Maniaplanet\DedicatedServer\Xmlrpc\Request::decode('<?xml version="...')
#1 /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Xmlrpc/GbxRemote.php(130): Maniaplanet\DedicatedServer\Xmlrpc\GbxRemote->flush(true)
#2 /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Connection.php(153): Maniaplanet\DedicatedServer\Xmlrpc\GbxRemote->query('Authenticate', Array)
#3 /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Connection.php(173): Maniaplanet\DedicatedServer\Connection->execute('Authenticate',  in /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Xmlrpc/Request.php on line 146

Fatal error: Uncaught Error: Call to undefined function Maniaplanet\DedicatedServer\Xmlrpc\simplexml_load_string() in /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Xmlrpc/Request.php:146
Stack trace:
#0 /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Xmlrpc/GbxRemote.php(201): Maniaplanet\DedicatedServer\Xmlrpc\Request::decode('<?xml version="...')
#1 /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Xmlrpc/GbxRemote.php(130): Maniaplanet\DedicatedServer\Xmlrpc\GbxRemote->flush(true)
#2 /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Connection.php(153): Maniaplanet\DedicatedServer\Xmlrpc\GbxRemote->query('Authenticate', Array)
#3 /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Connection.php(173): Maniaplanet\DedicatedServer\Connection->execute('Authenticate',  in /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Xmlrpc/Request.php on line 146

oliverde8
Posts: 1319
Joined: 16 Jun 2010, 07:33
Location: in a Blue Box

Re: Problem during starting eXpansion

Post by oliverde8 » 31 Oct 2016, 22:55

Ok,

so we are discovering things on Ubuntu & PHP7 it's missing a library.

It should be something like this, depending on how you installed PHP7

Code: Select all

sudo apt-get install php7.0-xml
it's missing basic php xml library,
Image
Developper for The next generation, Clean and Powerfull controller eXpansion for your SM & TM server . Working on eXpansion² with full MP4 support and many other awesome features...

wazerti
Posts: 99
Joined: 05 Nov 2012, 15:41

Re: Problem during starting eXpansion

Post by wazerti » 31 Oct 2016, 23:05

Thank for your answer

I've downloaded the package and now when I do php bootstrapper.php I get :

Code: Select all

 _|      _|                      _|            _|        _|
 _|_|  _|_|    _|_|_|  _|_|_|          _|_|_|  _|            _|    _|    _|_|
 _|  _|  _|  _|    _|  _|    _|  _|  _|    _|  _|        _|  _|    _|  _|_|_|_|
 _|      _|  _|    _|  _|    _|  _|  _|    _|  _|        _|  _|  _|    _|
 _|      _|    _|_|_|  _|    _|  _|    _|_|_|  _|_|_|_|  _|    _|        _|_|_|
-----------------------------------------------------
PHP Environment Compatibility Test
-----------------------------------------------------
PHP 5.3.1 or newer    -> required  -> [ Yes ] 7.0.8-0ubuntu0.16.04.3
Standard PHP Library  -> required  -> [ Yes ]
JSON                  -> required  -> [ Yes ]
cURL with SSL         -> required  -> [ Yes ] 7.47.0 (with OpenSSL/1.0.2g)
MySQL                 -> optional  -> [ No  ]
MySQLI                -> optional  -> [ Yes ]
SQLite3               -> optional  -> [ Yes ]
-----------------------------------------------------
Timezone is not set in php.ini. Please edit it and change/set "date.timezone" appropriately. Setting to default: 'America/New_York'
MySQL is disabled, threading will not work. ManiaLive may encounter some perfomance trouble.
Running ManiaLive 4.0.0...
[PluginHandler] Start plugin load process:

Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'
Runtime  error: Connect Error (1698) Access denied for user
      'root'@'localhost'


[PluginHandler] All registered plugins have been loaded

reaby
Posts: 919
Joined: 29 Dec 2010, 23:26
Location: Eastern Finland
Contact:

Re: Problem during starting eXpansion

Post by reaby » 31 Oct 2016, 23:16

check your config.ini for mysql settings, as you have wrong credentials there.
you could also try to run:

Code: Select all

php setup.php
and answer the questions there.
It checks everything is right (dedicated server connection + mysql connection)

wazerti
Posts: 99
Joined: 05 Nov 2012, 15:41

Re: Problem during starting eXpansion

Post by wazerti » 01 Nov 2016, 14:22

Thanks for your answer Reaby.
I went to the mysql console and I wrote this command to see the users :

Code: Select all

select user from mysql.user;
It shows :

Code: Select all

+------------------+
| user             |
+------------------+
| debian-sys-maint |
| mysql.sys        |
| dozo             |
| root             |
+------------------+
4 rows in set (0.00 sec)
Tried this command to give all rights to root for the nascar database :

Code: Select all

GRANT ALL ON nascar.* TO "root"@"localhost";
And created a new user named dozo

Then I changed configuration in config.ini :

Code: Select all

; Dedicated Server
;------------------
 config.maxErrorCount = 15
 server.host = 'localhost'
 server.port = 5003
 server.user = '********'
 server.password = '*********'

;------------------
; Database
;------------------
 database.enable = true

; Connection configuration
 database.host = 'localhost'
 database.port = 3306
 database.username = 'root'
 database.password = ''
 database.database = 'nascar'
I didn't write any password for root and dozo, I let it blank.

And I get exactly the same message when I run with root as database username but when I run with dozo I don't get the same error here is the log :

Code: Select all

 _|      _|                      _|            _|        _|
 _|_|  _|_|    _|_|_|  _|_|_|          _|_|_|  _|            _|    _|    _|_|
 _|  _|  _|  _|    _|  _|    _|  _|  _|    _|  _|        _|  _|    _|  _|_|_|_|
 _|      _|  _|    _|  _|    _|  _|  _|    _|  _|        _|  _|  _|    _|
 _|      _|    _|_|_|  _|    _|  _|    _|_|_|  _|_|_|_|  _|    _|        _|_|_|
-----------------------------------------------------
PHP Environment Compatibility Test
-----------------------------------------------------
PHP 5.3.1 or newer    -> required  -> [ Yes ] 7.0.8-0ubuntu0.16.04.3
Standard PHP Library  -> required  -> [ Yes ]
JSON                  -> required  -> [ Yes ]
cURL with SSL         -> required  -> [ Yes ] 7.47.0 (with OpenSSL/1.0.2g)
MySQL                 -> optional  -> [ No  ]
MySQLI                -> optional  -> [ Yes ]
SQLite3               -> optional  -> [ Yes ]
-----------------------------------------------------
Timezone is not set in php.ini. Please edit it and change/set "date.timezone" appropriately. Setting to default: 'America/New_York'
MySQL is disabled, threading will not work. ManiaLive may encounter some perfomance trouble.
Running ManiaLive 4.0.0...
[PluginHandler] Start plugin load process:
[PluginHandler] Loading plugin "\ManiaLivePlugins\eXpansion\AutoLoad\AutoLoad" 1.0.1.2...
[eXpansion][AutoLoad] AutoLoading eXpansion pack ...
[PluginHandler] Loading plugin "\ManiaLivePlugins\eXpansion\Core\Core" 1.0.1.2...
[eXpansion][Core]


                     __   __                      _
                     \ \ / /                     (_)
                  ___ \ ' / _ __   __ _ _ __  ___ _  ___  _ __
                 / _ \ > < | '_ \ / _` | '_ \/ __| |/ _ \| '_ \
                |  __// . \| |_) | (_| | | | \__ \ | (_) | | | |
                 \___/_/ \_\ .__/ \__,_|_| |_|___/_|\___/|_| |_|
...........................| |.........Plugin Pack for Manialive...............
                           |_|
[eXpansion][Core] Dedicated Server running for title: TMStadium
[eXpansion][Core] Dedicated Server api version in use: 2013-04-16
[eXpansion][Core] eXpansion version: 1.0.1.2
[eXpansion][Core] Minimum Dedicated version 2014.7.24: Pass (2015.6.16)
[eXpansion][Core] Minimum PHP version 5.4.3: Pass (7.0.8-0ubuntu0.16.04.3)
[eXpansion][Core] Garbage Collector enabled: Pass
[eXpansion][Core]
[eXpansion][Core] Checking write permission in directories :
[eXpansion][Core] Permissions are fine for directory : 'tmp'
[eXpansion][Core] Permissions are fine for directory : 'tmp/nascar_1'
[eXpansion][Core]
[eXpansion][Core] eXpansion works better with PHP extension xmlrpc : It will have better performances !
[eXpansion][Core] eXpansion works better with PHP extension gd : gd2 needs to be enabled for better performances reading maps
[eXpansion][Core] Version 1.0.1.2 build 2016-10-23 09:22:24 AM
[eXpansion][Core]
[eXpansion][Core] Language support detected for: de,en,fi,fr!
[eXpansion][Core] Enabling default locale:
[eXpansion][Core]
[eXpansion][Core]
[eXpansion][Core] -------------------------------------------------------------------------------
[eXpansion][Core]
[PluginHandler] Loading plugin "\ManiaLivePlugins\eXpansion\AdminGroups\AdminGroups" 1.0.1.2...
[PluginHandler] Loading plugin "\ManiaLivePlugins\eXpansion\AutoUpdate\AutoUpdate" 1.0.1.2...
[PluginHandler] Loading plugin "\ManiaLivePlugins\eXpansion\ChatAdmin\ChatAdmin" 1.0.1.2...
[PluginHandler] Loading plugin "\ManiaLivePlugins\eXpansion\Gui\Gui" 0.1...
[PluginHandler] Loading plugin "\ManiaLivePlugins\eXpansion\Adm\Adm" 1.0.1.2...
[PluginHandler] Loading plugin "\ManiaLivePlugins\eXpansion\Database\Database" 1.0.1.2...
PHP Fatal error:  Uncaught Error: Call to undefined function Maniaplanet\DedicatedServer\mb_check_encoding() in /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Connection.php:4253
Stack trace:
#0 /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Connection.php(2331): Maniaplanet\DedicatedServer\Connection->secureUtf8('')
#1 /root/Nascar/eXpansion/vendor/ml-expansion/expansion/Core/Core.php(422): Maniaplanet\DedicatedServer\Connection->setForcedMusic(false, '')
#2 /root/Nascar/eXpansion/vendor/ml-expansion/expansion/Core/types/BasicPlugin.php(253): ManiaLivePlugins\eXpansion\Core\Core->eXpOnReady()
#3 /root/Nascar/eXpansion/vendor/maniaplanet/manialive-lib/ManiaLive/PluginHandler/PluginHandler.php(69): ManiaLivePlugins\eXpansion\Core\types\BasicPlugin->onReady()
#4 /root/Nascar/eXpansion/vendor/ml-expansion/expansion/AutoLoad/AutoLoad.php(232): ManiaLive\PluginHandler\PluginHandler->ready('\\ManiaLivePlugi...')
#5 /root/Nasca in /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Connection.php on line 4253

Fatal error: Uncaught Error: Call to undefined function Maniaplanet\DedicatedServer\mb_check_encoding() in /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Connection.php:4253
Stack trace:
#0 /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Connection.php(2331): Maniaplanet\DedicatedServer\Connection->secureUtf8('')
#1 /root/Nascar/eXpansion/vendor/ml-expansion/expansion/Core/Core.php(422): Maniaplanet\DedicatedServer\Connection->setForcedMusic(false, '')
#2 /root/Nascar/eXpansion/vendor/ml-expansion/expansion/Core/types/BasicPlugin.php(253): ManiaLivePlugins\eXpansion\Core\Core->eXpOnReady()
#3 /root/Nascar/eXpansion/vendor/maniaplanet/manialive-lib/ManiaLive/PluginHandler/PluginHandler.php(69): ManiaLivePlugins\eXpansion\Core\types\BasicPlugin->onReady()
#4 /root/Nascar/eXpansion/vendor/ml-expansion/expansion/AutoLoad/AutoLoad.php(232): ManiaLive\PluginHandler\PluginHandler->ready('\\ManiaLivePlugi...')
#5 /root/Nasca in /root/Nascar/eXpansion/vendor/maniaplanet/dedicated-server-api/libraries/Maniaplanet/DedicatedServer/Connection.php on line 4253


Sorry for the very long message :oops:

Thanks

Post Reply

Return to “eXpansion”

Who is online

Users browsing this forum: No registered users and 2 guests