[ACTION MAKER][WEAPON][SCRIPT] Strange Vec3 behaviour

Moderator: NADEO

Post Reply
User avatar
weerwolf
Posts: 630
Joined: 15 Jun 2010, 21:21
Location: Wijchen, Netherlands
Contact:

[ACTION MAKER][WEAPON][SCRIPT] Strange Vec3 behaviour

Post by weerwolf » 11 Mar 2019, 14:33

The projectile sometime chooses a other direction, and seems to be 1 of 2 directions only.
Also it seems to be related to the spawning of the player and/or a jump in the spawn
In the video i have set the projectile to be launched in the aim direction, and log that
direction vector. You can see that the vector is identical, though the second projectile is
going a really different way :-S
https://www.youtube.com/watch?v=k_MkocK3lt4

cgdb
Nadeo
Nadeo
Posts: 13
Joined: 23 Oct 2018, 12:33

Re: [ACTION MAKER][WEAPON][SCRIPT] Strange Vec3 behaviour

Post by cgdb » 11 Mar 2019, 15:00

I don't know much about the Action Maker, but the "Speed = <0.0,0.0,0.0>" seems strange to me, I guess the Projectile_CreateAtLocation function refuses to create a projectile with no velocity and use a default value instead. I suggest testing "Speed = Owner.AimDirection" to check whether it changes the projectile behaviour or not.

User avatar
weerwolf
Posts: 630
Joined: 15 Jun 2010, 21:21
Location: Wijchen, Netherlands
Contact:

Re: [ACTION MAKER][WEAPON][SCRIPT] Strange Vec3 behaviour

Post by weerwolf » 11 Mar 2019, 16:26

Yes, as far as i understood back then that was used to let the projectile use its configured speed. In mp3 that worked as intended, but i'll look into that , tnx
EDIT : setting "Speed = Owner.AimDirection" gives exactly the same.

User avatar
weerwolf
Posts: 630
Joined: 15 Jun 2010, 21:21
Location: Wijchen, Netherlands
Contact:

Re: [ACTION MAKER][WEAPON][SCRIPT] Strange Vec3 behaviour

Post by weerwolf » 19 Mar 2019, 07:51

Before i proceed further with RR, i must understand if either i am doing something wrong / don't understand or there is something bugging which needs fixing. For that i shot a long video doing some of this positioning and u will see this change of direction happening.

User avatar
weerwolf
Posts: 630
Joined: 15 Jun 2010, 21:21
Location: Wijchen, Netherlands
Contact:

Re: [ACTION MAKER][WEAPON][SCRIPT] Strange Vec3 behaviour

Post by weerwolf » 02 Apr 2019, 17:07

Done some more testing, with Miss also watching live and advised me to elaborate some more upon the above video.

Code: Select all

declare Vec3 Position	= <192.0, 8.0, 192.0>;
declare Vec3 Direction	= <0.0, -1.0, 0.0>;
declare Vec3 Speed	= <1.0, 1.0, 1.0>;
declare Proj1 = Projectile_CreateAtLocation(ProjectileId1, Owner, Position, Direction, Speed);
This creates the projectile on the middle of the map, approx 1 block high of the ground, and when fired the rocket will go
straight down. As ment to be as the direction is set -1 on the Y-axis.
But for the yet unknown reasons @ random it will not go in the programmed direction and although it seems that in a lot
of cases the rocket has direction a sort of opposite? (seen this happening with the meteor shower in Royal Roulette going up).
Judging the direction it would be something like -1.0, 1.0, 0.5; but ive seen a couple of diverent directions

Help needed ;)
Greetz, WW

User avatar
weerwolf
Posts: 630
Joined: 15 Jun 2010, 21:21
Location: Wijchen, Netherlands
Contact:

Re: [ACTION MAKER][WEAPON][SCRIPT] Strange Vec3 behaviour

Post by weerwolf » 15 Apr 2019, 10:06

Image

Post Reply

Return to “ActionMaker and Item editor”

Who is online

Users browsing this forum: No registered users and 1 guest