[Items]fuite de lumière par les edges[RESOLU]

Section pour échanger et s'entraider dans la création de titres (script, importer, ghosts editor, item editor et action maker).

Moderator: French Moderator

User avatar
Fix
Nadeo
Nadeo
Posts: 1247
Joined: 14 Jun 2010, 17:28

Re: [Items]fuite de lumière par les edges

Post by Fix » 08 Jun 2015, 15:14

bravo pour tous les progrès, faire des uv2 qui encaissent pas trop mal, ça demande d'en avoir fait un petit paquet.
Pour bien faire le test, il vaut mieux charger un très grosse map, afin d'avoir une lightmap à la résolution bien pourrie (tes bavures faisaient quelques centimètres, là elles feront plusieurs mètres).
sinon, mauvaise idée de changer la taille de faces; c'est casse gueule et la lumière peut venir de différents endroits suivant les blocs voisins.

User avatar
BusardCendre
Posts: 163
Joined: 30 May 2013, 09:40

Re: [Items]fuite de lumière par les edges

Post by BusardCendre » 26 Jun 2015, 17:55

Merci pour vos encouragement :thumbsup:

bon, j'ai fait des tests, pas autant que j'aurais dû en faire pour être vraiment content de moi,
mais aucune des modifs que j'ai faites sur la lightmap ne me convenait ...
et il y a tant à faire et à apprendre avec ManiaPlanet,
que j'ai préféré rester sur ce que j'avais.
j'ai aussi décliné mon objet sous plusieurs versions :
Un Départ (75ko)
Image

Un Départ Multilap (76ko)
Image

Un CheckPoint (79ko)
Image

Une Arrivée(73ko)
Image

Une Arrivée visible de loin la nuit(78ko)
Image

Dans la version éclairée de l'arrivée, les faces qui se touchent et qui se trouvent sur un même coté de l'objet sont collées entre elles dans la lightmap,
par contre vu le résultat obtenu avec cette lightmap de jour,
tous les objets non-éclairés ont une lightmap faite par blender ...

je marque le topic comme résolu
Merci encore
Ah et histoire que je sache pour la prochaine fois :
la taille d'affiche des images sur le forum n'est-elle pas de 800px de large ?
aucune de mes capture d'écran n'est centrée du coup
Image

CPU : AMD FX-4170 (4 CPUs, ~4.2 GHz)
GPU : Sapphire Radeon HD 7850, 2 Go , DX 11
RAM : 8 Go DDR3
Win 7 Ultimate x64

User avatar
Nerpson
Translator
Translator
Posts: 1383
Joined: 27 Sep 2013, 18:02
Location: France
Contact:

Re: [Items]fuite de lumière par les edges[RESOLU]

Post by Nerpson » 27 Jun 2015, 15:32

800px sont autorisés mais étant donné qu'il y a la barre de profil, cela masque une partie des images.
ImageImageImageImage

User avatar
BusardCendre
Posts: 163
Joined: 30 May 2013, 09:40

Re: [Items]fuite de lumière par les edges[RESOLU]

Post by BusardCendre » 01 Jul 2015, 17:34

Merci pour l'info , je ferai mes images plus petites dorénavant =)

Par contre, je retire ce que j'ai dit sur mes objets ...
lors de mes tests d'objets de jour, je les plaçais toujours en plein soleil ...
depuis, j'ai fait une map et les ai placés à l'ombre pour la plupart ...
c'est une horreur ! toutes les faces créées dans blender sont visibles ...
j'ai tenté de reprendre le truc et ai trouvé une autre façon de créer la lightmap automatiquement par blender,
mais le résultat n'est vraiment pas concluant ...
je vais continuer à chercher et reviendrai donner ma soluce, enfin si j'en trouve une ...
Image

CPU : AMD FX-4170 (4 CPUs, ~4.2 GHz)
GPU : Sapphire Radeon HD 7850, 2 Go , DX 11
RAM : 8 Go DDR3
Win 7 Ultimate x64

User avatar
meuh21
Posts: 1264
Joined: 15 Jun 2010, 17:00
Location: Dans mon champ...
Contact:

Re: [Items]fuite de lumière par les edges[RESOLU]

Post by meuh21 » 01 Jul 2015, 18:11

Tu es sûr que le problème ne vient pas de la lighmap de la map ? Quand on a une map trop chargée le moteur du jeu peine et crée des traits pas toujours très jolis... Et ça doit être pire online car si j'ai bien compris la lightmap de la map est de taille réduite.
OS : Windows 7 Édition Familiale Premium 64-bit (6.1, Build 7601) Service Pack 1
Processor: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz (8 CPUs), ~3.7GHz
Memory: 8192MB RAM
DirectX 11
NVIDIA GeForce GTX 960

User avatar
BusardCendre
Posts: 163
Joined: 30 May 2013, 09:40

Re: [Items]fuite de lumière par les edges[RESOLU]

Post by BusardCendre » 02 Jul 2015, 00:55

oui j'ai lu ça aussi, mais la map n'était pas très grosse ( pas plus de 5000)
Image

CPU : AMD FX-4170 (4 CPUs, ~4.2 GHz)
GPU : Sapphire Radeon HD 7850, 2 Go , DX 11
RAM : 8 Go DDR3
Win 7 Ultimate x64

User avatar
BusardCendre
Posts: 163
Joined: 30 May 2013, 09:40

Re: [Items]fuite de lumière par les edges[RESOLU]

Post by BusardCendre » 05 Jul 2015, 01:07

ça y est !! j'ai la soluce !!!
Un grand merci à Tipiizor pour sa démonstration via un logiciel de partage d'écran :clap:
pour mes objets, il fallait faire un mark seam sur les tubes puis un Smart UV Project juste avec eux,
ensuite sortir les tubes dépliés de la zone d'unwarp et les mettre juste à coté,
et enfin refaire un Smart UV Project sur le reste de l'objet en réglant le Island Margin sur presque 1.
et voilà, plus de fuites ni de soucis quand placé à l'ombre !!
[edit] il manquait aussi un réglage Flat (onglet shading/UV) sur ce qui n'est pas tube ...
Il semble que c'est ce qui donnait l'aspect semi-ombragé à mon finish lorsque placé en plein soleil .

Merci encore pour vos encouragement et vos précieux conseils :thx: :1010
je retourne de suite finir ceux qu'il me reste à reprendre ...
Last edited by BusardCendre on 05 Jul 2015, 17:02, edited 1 time in total.
Image

CPU : AMD FX-4170 (4 CPUs, ~4.2 GHz)
GPU : Sapphire Radeon HD 7850, 2 Go , DX 11
RAM : 8 Go DDR3
Win 7 Ultimate x64

User avatar
TMarc
Posts: 14391
Joined: 05 Apr 2011, 19:10
Location: Europe
Contact:

Re: [Items]fuite de lumière par les edges[RESOLU]

Post by TMarc » 05 Jul 2015, 08:54

il fallait faire un quoi ? :shock:

Qu'est-ce que c'est compliqué :|

Vivement la suite ... sans fuite :mrgreen:
maniaplanet forum global moderator

Link list with FAQ, Support, Wiki, Tutorials, Community activities, and much more.

System specs: Intel i7-970 12GB RAM, nVidia GTX 970, Creative SB X-Fi, 2xSSD

User avatar
meuh21
Posts: 1264
Joined: 15 Jun 2010, 17:00
Location: Dans mon champ...
Contact:

Re: [Items]fuite de lumière par les edges[RESOLU]

Post by meuh21 » 05 Jul 2015, 10:15

Content de voir que tu t'en sors ;) A priori c'est donc juste les tubes qui posaient problème (je ne comprenais pas comment cela pouvait venir de la lightmap du béton qui me paraissait très bien...).

Va falloir que j'essaye d'utiliser "mark seam" et "island margin" (peut faire gagner du temps notamment pour les véhicules). Merci de l'info et pour le suivi du topic :thumbsup:
OS : Windows 7 Édition Familiale Premium 64-bit (6.1, Build 7601) Service Pack 1
Processor: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz (8 CPUs), ~3.7GHz
Memory: 8192MB RAM
DirectX 11
NVIDIA GeForce GTX 960

User avatar
BusardCendre
Posts: 163
Joined: 30 May 2013, 09:40

Re: [Items]fuite de lumière par les edges[RESOLU]

Post by BusardCendre » 05 Jul 2015, 15:59

TMarc wrote:il fallait faire un quoi ? :shock:
un TMarc Seam :mrgreen: : ça sert à dire à Blender quelle arrête choisir pour couper l'objet avant de le déplier ;)
meuh21 wrote:Va falloir que j'essaye d'utiliser "mark seam" et "island margin" (peut faire gagner du temps notamment pour les véhicules). Merci de l'info et pour le suivi du topic :thumbsup:
Le margin peut être utile pour pouvoir refaire ta peinture avec toshop ;)
Le suivi du topic ... ça me paraît normal, surtout qu'il est pas facile de choper les infos que l'on cherche ...
Alors si en plus on ne donne pas les soluces quand on les trouve :roll:
Merci encore à vous tous :clap:

[edit] il manquait aussi un réglage Flat (onglet shading/UV) sur ce qui n'est pas tube ...
Il semble que c'est ce qui donnait l'aspect semi-ombragé à mon finish lorsque placé en plein soleil
Image

CPU : AMD FX-4170 (4 CPUs, ~4.2 GHz)
GPU : Sapphire Radeon HD 7850, 2 Go , DX 11
RAM : 8 Go DDR3
Win 7 Ultimate x64

Post Reply

Return to “Titres des joueurs”

Who is online

Users browsing this forum: No registered users and 1 guest