[FIXED] Uaseco slowing down with 10+ players after a while

UASECO is a fork of the XAseco2/1.03 controller for Trackmania and has been overhauled to support the Modescript Gamemodes of Trackmania².

Moderators: undef.de, NADEO

oliverde8
Posts: 1328
Joined: 16 Jun 2010, 07:33
Location: in a Blue Box

Re: Uaseco slowing down with 10+ players after a while

Post by oliverde8 » 20 Jun 2017, 20:03

tcq wrote:
20 Jun 2017, 18:49
endbase wrote:
20 Jun 2017, 16:36
No can do we re on an another conrtroller now ! hope anybody else with the same problem can sort it out with Uaseco :pop:
And this is one of the most prig behaviour I have seen on the forum for quite some time.
agreed,

assomptions are made, and I know for a fact that nc1 database are not well optimised for anything but small DB. which could explain alot a well.

@Undef you should probably ask a few of us on your server when you have time, I would come and stick around if it helps you (hmm going on holiday end of the week so not lot's of time.).
Image
Developper for The next generation, Clean and Powerfull controller eXpansion for your SM & TM server . Working on eXpansion² with full MP4 support and many other awesome features...

User avatar
endbase
Posts: 459
Joined: 26 Jun 2011, 19:34

Re: Uaseco slowing down with 10+ players after a while

Post by endbase » 20 Jun 2017, 20:08

maybe I'm mistaken but 2 a 3 months of lagg and a lot of frustration and now it's gonna look if I don't want to work with the developer to solve it ? realy funny tho :teub: sort it out or what ever :clap:

Edit gonna answer the treath as solved before this get's out of hand :thx:

hackie
Posts: 1118
Joined: 19 Jul 2012, 22:43

Re: Uaseco slowing down with 10+ players after a while [Solved]

Post by hackie » 20 Jun 2017, 20:29

I "helped" Undef a lot with testing uaseco on a dedicated server , but I never heard him talking about uaseco laggy.

So 2 a 3 months lagg ? Sounds new to me. Why not come sooner then with this problem ?


The line : No can do were on an another conrtroller now ! ( das wel heel kort door de bocht Base :roflol: maar ik begrijp je wel ! )


EDIT :

I went to the ssm very-short canyon server to see what happens with 25 players on the server.
It took at least 40 sec for uaseco told me that I was on the server.
Then another 5 sec for showing the time tables ( dedi times , locals and live ranking )
System Specs:
OS: Windows 7 Professionnal x64
CPU: Intel Core i7-6700K / 4 GHz - 8 MB cache
GPU: MSI GTX 980TI GAMING 6G - OC Edition
Motherboard: ASUS MAXIMUS VIII RANGER
RAM : 32Gb Kingston HyperX Savage - DDR4
DirectX 11

User avatar
endbase
Posts: 459
Joined: 26 Jun 2011, 19:34

Re: Uaseco slowing down with 10+ players after a while [Solved]

Post by endbase » 20 Jun 2017, 20:54

The line : No can do were on an another conrtroller now ! ( das wel heel kort door de bocht Base :roflol: maar ik begrijp je wel ! )

Had er ff genoeg van idd :lol:

hackie
Posts: 1118
Joined: 19 Jul 2012, 22:43

Re: Uaseco slowing down with 10+ players after a while [Solved]

Post by hackie » 20 Jun 2017, 22:18

System Specs:
OS: Windows 7 Professionnal x64
CPU: Intel Core i7-6700K / 4 GHz - 8 MB cache
GPU: MSI GTX 980TI GAMING 6G - OC Edition
Motherboard: ASUS MAXIMUS VIII RANGER
RAM : 32Gb Kingston HyperX Savage - DDR4
DirectX 11

User avatar
Bagsor
Posts: 54
Joined: 05 Dec 2016, 22:15

Re: Uaseco slowing down with 10+ players after a while [Solved]

Post by Bagsor » 21 Jun 2017, 00:12

hackie wrote:
20 Jun 2017, 20:29
I "helped" Undef a lot with testing uaseco on a dedicated server , but I never heard him talking about uaseco laggy.

So 2 a 3 months lagg ? Sounds new to me. Why not come sooner then with this problem ?


The line : No can do were on an another conrtroller now ! ( das wel heel kort door de bocht Base :roflol: maar ik begrijp je wel ! )


EDIT :

I went to the ssm very-short canyon server to see what happens with 25 players on the server.
It took at least 40 sec for uaseco told me that I was on the server.
Then another 5 sec for showing the time tables ( dedi times , locals and live ranking )
From the beginning MP4 we have Problems with the Server (LolnAll). I understand endbase .... he is frustated because he works every Day on the Server (and its not his own), try to make it better. But maybe, endbase, its not so good to ask here (right Way :) ) for help and then refuse help. How i said, i understand you, but i understand the other Guys here too. Lets try to get the Data and more things, undef needs to look for the Error :-)

User avatar
endbase
Posts: 459
Joined: 26 Jun 2011, 19:34

Re: Uaseco slowing down with 10+ players after a while [Solved]

Post by endbase » 21 Jun 2017, 04:01

It is not that I'm not want to help ! But when I saw the list of things to do together with the frustrated factor I reacted the way I did. To be honest If there was'nt an alternitive like mania control we had to cope with the lagg untill solution. I must say that I should had bring this up much earlier instead of letting the frustration grow and yes it is not even my own server I'm just helping out in this case. Call me anything you want guys but I still don't see the solution that we go back to Uaseco and use an good runnning server as an test object to find an solution that is allready found with the change of controller ! I'm gladly to provide any info as for logs I still have them on nc1eu but that's it.

Greetz Base

User avatar
endbase
Posts: 459
Joined: 26 Jun 2011, 19:34

Re: Uaseco slowing down with 10+ players after a while

Post by endbase » 27 Jun 2017, 12:46

Ps on my own server I use Uaseco btw but the server is 20 slots and never crowded hehe ;)

speedychris
Posts: 152
Joined: 29 Dec 2011, 20:47

Re: Uaseco slowing down with 10+ players after a while

Post by speedychris » 08 Jul 2017, 09:14

any news about this Problem?

User avatar
undef.de
Posts: 1882
Joined: 06 Apr 2011, 21:57
Location: Germany
Contact:

Re: Uaseco slowing down with 10+ players after a while

Post by undef.de » 05 Jul 2018, 21:14

We had a test session today and we found which causes the slowdown: It's the plugin.checkpoint.php and it's widget <time_diff_widget>. If you turn this off the slowdown doesn't happen.

You have to setup config/checkpoints.xml <time_diff_widget><enabled> on 'false'.

EDIT: This is of course just a temporary work-a-round, I'll be working now on it to fix that problem. 8-)
Developer of UASECO, a controller with support of the Modescript Gamemodes for TM².
Visit the official website for more: UASECO.org


Developer of various plugins for XAseco/XAseco2 and MPAseco, visit my lab: www.undef.name

You like what I do? Then award a ManiaStar.

Post Reply

Return to “UASECO”

Who is online

Users browsing this forum: No registered users and 2 guests