Page 4 of 6

Re: Uaseco slowing down with 10+ players after a while

Posted: 11 Jul 2018, 14:26
by bern
hi undef.
I have noticed a problem with the update.
the TAB button to display the table of players' positions does not work
When a player arrives at the goal, the table of positions of the players does not appear
at the end of the race against time, the table of classifications of the players does not appear (EMERGING CLASSIFICATION TABLE)

Re: Uaseco slowing down with 10+ players after a while

Posted: 11 Jul 2018, 14:37
by undef.de
I don't have any problems with TAB or after finishing the map with the current development snapshot from github:

Image
Image

Maybe you did not update some config/*.xml files? The file docs/CHANGELOG.md lists all changes of them in detail.

EDIT: See viewtopic.php?p=299534#p299534
RelaxedRacer wrote:
10 Jul 2018, 20:40
I just updated the files, i cant click on "placement" buttons i created in records_eyepiece annymore.
This has been fixed and will be updated at github later this day. :thumbsup:

Re: Uaseco slowing down with 10+ players after a while

Posted: 11 Jul 2018, 15:56
by hacki65
Hi undef,

i think the changes you have made are buggy. If i have a local record on a map no time diff will be displayed. BUT: if a map runs and i have NO RECORD, then i drive a local record, in the the next try to drive a better time, the time diff WILL BE DISPLAYED !!!

Pls test this behaviour on your own server.

Re: Uaseco slowing down with 10+ players after a while

Posted: 11 Jul 2018, 16:01
by undef.de
hacki65 wrote:
11 Jul 2018, 15:56
If i have a local record on a map no time diff will be displayed. BUT: if a map runs and i have NO RECORD, then i drive a local record, in the the next try to drive a better time, the time diff WILL BE DISPLAYED !!!
I can't reproduce this on my own server, here this works very well. Anyway there is a bug in the fix, which does not init the array on a player connect, maybe that's related to your problem. The github update later this day will have this fix included.

Re: Uaseco slowing down with 10+ players after a while

Posted: 11 Jul 2018, 16:19
by hacki65
OK, thx. Will try it then.

Another thing happend in the log (plugin.checkpoints.php: Undefined index on line 444 & 559):

Code: Select all

[2018-07-11 15:16:50] [LocalRecords] Player [eathr349] finished with [0:59.860] and took the 25. Local Record!
[2018-07-11 15:16:51] [Event] Player Ranking Updated (Players)
[PHP Notice] Undefined index: foiki on line 444 in file /var/www/vhosts/speed-fun-driver.de/var/tm2/uaseco_srv_c_sr60/plugins/plugin.checkpoints.php
[PHP Notice] Undefined index: foiki on line 444 in file /var/www/vhosts/speed-fun-driver.de/var/tm2/uaseco_srv_c_sr60/plugins/plugin.checkpoints.php
[PHP Notice] Undefined index: foiki on line 444 in file /var/www/vhosts/speed-fun-driver.de/var/tm2/uaseco_srv_c_sr60/plugins/plugin.checkpoints.php
[2018-07-11 15:17:17] [Event] Player Ranking Updated (Players)
[PHP Notice] Undefined index: foiki on line 444 in file /var/www/vhosts/speed-fun-driver.de/var/tm2/uaseco_srv_c_sr60/plugins/plugin.checkpoints.php
[PHP Notice] Undefined index: foiki on line 444 in file /var/www/vhosts/speed-fun-driver.de/var/tm2/uaseco_srv_c_sr60/plugins/plugin.checkpoints.php
[PHP Notice] Undefined index: foiki on line 444 in file /var/www/vhosts/speed-fun-driver.de/var/tm2/uaseco_srv_c_sr60/plugins/plugin.checkpoints.php
[2018-07-11 15:18:09] [LocalRecords] Player [flutschei007] finished with [1:01.740] and took the 29. Local Record!
[2018-07-11 15:18:09] [Event] Player Ranking Updated (Players)
[PHP Notice] Undefined index: foiki on line 444 in file /var/www/vhosts/speed-fun-driver.de/var/tm2/uaseco_srv_c_sr60/plugins/plugin.checkpoints.php
[2018-07-11 15:18:58] [LocalRecords] Player [eathr349] finished with [0:57.648] and took the 18. Local Record!
[2018-07-11 15:18:58] [Event] Player Ranking Updated (Players)
[PHP Notice] Undefined index: foiki on line 559 in file /var/www/vhosts/speed-fun-driver.de/var/tm2/uaseco_srv_c_sr60/plugins/plugin.checkpoints.php
[2018-07-11 15:19:28] [LocalRecords] Player [foiki] finished with [1:08.299] and took the 44. Local Record!
[2018-07-11 15:19:28] [Dedimania] Player [foiki] finished with [1:08.299] and took the 47. Dedimania Record!
[2018-07-11 15:19:28] [Event] Player Ranking Updated (Players)
[2018-07-11 15:20:04] [LocalRecords] Player [kaspeeeer] finished with [0:56.515] and took the 16. Local Record!
Can you check this too?

Re: Uaseco slowing down with 10+ players after a while

Posted: 11 Jul 2018, 16:26
by undef.de
That's what I meantioned in my posting before, that has been fixed with the current github release (just updated).

Re: Uaseco slowing down with 10+ players after a while

Posted: 11 Jul 2018, 16:29
by bern
undef.de wrote:
11 Jul 2018, 14:37
I don't have any problems with TAB or after finishing the map with the current development snapshot from github:
Maybe you did not update some config/*.xml files? The file docs/CHANGELOG.md lists all changes of them in detail.
fixed up!!! thanks, I had to update some files
you had updated.
the cause is that I have a configuration a little different from the one that comes from base :clap:

Re: Uaseco slowing down with 10+ players after a while

Posted: 11 Jul 2018, 16:58
by fiendy
endbase wrote:
11 Jul 2018, 04:42
fiendy wrote:
10 Jul 2018, 23:05
Thanks Undef :thumbsup:

Installed on one of my servers, together with upgrade to latest MP4 (hadn't done that yet :oops: ).

Played for a couple of hours & only have one issue-the scoreboard no longer works, either by pressing Tab key or at end of round.
I may have missed some update of config files, just not sure what! Will take a look tomorrow.
Yep same here :pop:

ps quick fix from newinstall/config upload modescript_settings.xml
Thanks endbase, that sorted it! :thumbsup: :D

Re: Uaseco slowing down with 10+ players after a while

Posted: 11 Jul 2018, 19:00
by RelaxedRacer
undef.de wrote:
11 Jul 2018, 14:37
RelaxedRacer wrote:
10 Jul 2018, 20:40
I just updated the files, i cant click on "placement" buttons i created in records_eyepiece annymore.
This has been fixed and will be updated at github later this day. :thumbsup:

Thanx I just updated all the files, placement works perfect now :3 :mrgreen:

ps. Just knowthis a warning in the log, this happens when a player joins the server:

Code: Select all

[PHP Notice] Undefined variable: message on line 133 in file C:\TM_Server\UASECO\plugins\plugin.local_records.php
:roll:

Re: Uaseco slowing down with 10+ players after a while

Posted: 11 Jul 2018, 23:11
by hacki65
So, i have tested the new github release.

The checkpoints plugin does not work as expected. If i have a local rec then nothing happens. If i have no local and drove a local in the current round, it gives the time diff on the last time.

THEN i set over the chat command "/cps" my favorite time diff and NOW its working as expected !!!
BUT this can not be expected from the player to set her/his favorite behaviour. This is set (or not for new players or as default) in the DB.

Can you pls take a look at this point? THX hacki65

P.S.: Sorry for bad english, but the best way to explain and help is to discuss over your discord channel if you have a headset to do this.
It is horrible over and over to explain this all over this forum. Please let us talk directly and the solution can be near ;)