[Bug] Increasing event delays

UASECO is a fork of the XAseco2/1.03 controller for Trackmania and has been overhauled to support the Modescript Gamemodes of Trackmania².

Moderators: undef.de, NADEO

Post Reply
User avatar
braker
Posts: 4
Joined: 30 Dec 2017, 15:46

[Bug] Increasing event delays

Post by braker » 30 Dec 2017, 16:15

Hello undef,

I'm running a server with UASECO and I've been using it for a while now. But there's a considerable downside to this controller.
UASECO is getting progressively slower by each player that joins the server. Casting votes, opening /list and other things like echoes on new records get delayed beyond one minute. :x

This project still contains php4 code from decades ago and the mysql connection is far from efficient. In this spaghetti-code mess it is hard to pin down the problem what might cause it. As it is not getting faster again after people leave, but stays at the delay it reached I'll have a guess and say the garbage collection is just not working properly.
From testing a lot I figured the problem occurs after the 0.9.3 update.

So I ask you, undef, to look into it and fix it, else this server controller is just useless.
As it is your project I assume you should be able to determine the bug quickly.

speedychris
Posts: 109
Joined: 29 Dec 2011, 20:47

Re: [Bug] Increasing event delays

Post by speedychris » 31 Dec 2017, 10:29

Already discussed here:
viewtopic.php?f=522&t=42325
and
viewtopic.php?f=522&t=41945

Problem seams that undef can not find the reason on that.

User avatar
undef.de
Posts: 1612
Joined: 06 Apr 2011, 21:57
Location: Germany
Contact:

Re: [Bug] Increasing event delays

Post by undef.de » 31 Dec 2017, 11:15

speedychris wrote:
31 Dec 2017, 10:29
Problem seams that undef can not find the reason on that.
Correct, but if it is true that release 0.9.3 does not have this problem, I have now a starting point. But I can't test it so someone have to do it for me:
  1. Use the core from 0.9.3 and the plugins from 0.9.6
  2. Use the core from 0.9.6 and the plugins from 0.9.3
That should figure out if it is a core or a plugin problem. I'm unsure if you already can test this with the current files or if I have to change something. If you want to test it, do it and let me know the results.
Developer of UASECO, a controller with support of the Modescript Gamemodes for TM².
Visit the official website for more: UASECO.org


Developer of various plugins for XAseco/XAseco2 and MPAseco, visit my lab: www.undef.name

You like what i do? Then award a ManiaStar.

User avatar
braker
Posts: 4
Joined: 30 Dec 2017, 15:46

Re: [Bug] Increasing event delays

Post by braker » 31 Dec 2017, 11:58

I will report after testing

User avatar
ItsPhenom
Posts: 20
Joined: 24 Dec 2017, 11:40
Location: Kitzingen, Germany
Contact:

Re: [Bug] Increasing event delays

Post by ItsPhenom » 31 Dec 2017, 14:58

One thing i know for sure, it isnt the 0.9.6 plugin.records_eyepiece.php that causes the problem. All Evo servers are running 0.9.3 uaseco with 0.9.6 plugin.records_eyepiece.php without slowing down. The next days i take one of the servers and will switch more 0.9.6 plugins into it.

Post Reply

Return to “UASECO”

Who is online

Users browsing this forum: No registered users and 1 guest