Time Widget in foot line does not work correctly

UASECO is a fork of the XAseco2/1.03 controller for Trackmania and has been overhauled to support the Modescript Gamemodes of Trackmania².

Moderators: undef.de, NADEO

Post Reply
chekov
Posts: 32
Joined: 12 May 2017, 07:56

Time Widget in foot line does not work correctly

Post by chekov » 25 Aug 2019, 09:43

Hi,
I trie to discribe my problem in english. When I use uaseco, then I could have a small box/widget in the middel of my footline on the screen. There should be shown my time / timedifference with red or blue colors. When I use "Laps"-Mode with multilap-maps, in round 2 is the counting of the CP still ok, but the time is not rigth. It stopps when I cross the finish to the next lap.
I think, this is a bug. Could You solve it?
chekov

User avatar
undef.de
Posts: 1980
Joined: 06 Apr 2011, 21:57
Location: Germany, North Sea Coast
Contact:

Re: Time Widget in foot line does not work correctly

Post by undef.de » 25 Aug 2019, 16:01

If you do not run the current development snapshot from github, try it again with that please: https://github.com/undeflabs/UASECO/archive/master.zip

If that problem still exists, then please add a screenshot, I want to make sure I will look into the right plugin.
Developer of UASECO, a controller with support of the Modescript Gamemodes for TM².
Visit the official website for more: UASECO.org


Developer of various plugins for XAseco/XAseco2 and MPAseco, visit my lab: www.undef.name

You like what I do? Then award a ManiaStar.

ranig
Posts: 33
Joined: 27 May 2017, 01:07

Re: Time Widget in foot line does not work correctly

Post by ranig » 26 Aug 2019, 18:13

I might be wrong, but it looks like the local records store the total race time instead of the single lap time. Maybe the bug might related?
Your Trackmania resource for Nascar racing http://www.tm-nascar.com

User avatar
undef.de
Posts: 1980
Joined: 06 Apr 2011, 21:57
Location: Germany, North Sea Coast
Contact:

Re: Time Widget in foot line does not work correctly

Post by undef.de » 26 Aug 2019, 19:30

ranig wrote:
26 Aug 2019, 18:13
I might be wrong, but it looks like the local records store the total race time instead of the single lap time. Maybe the bug might related?
That's right and not a bug, because the race is over when all laps are done, that's how then mode "Laps" works. If you want to have the single lap time, then you have to switch to "TimeAttack".
Developer of UASECO, a controller with support of the Modescript Gamemodes for TM².
Visit the official website for more: UASECO.org


Developer of various plugins for XAseco/XAseco2 and MPAseco, visit my lab: www.undef.name

You like what I do? Then award a ManiaStar.

ranig
Posts: 33
Joined: 27 May 2017, 01:07

Re: Time Widget in foot line does not work correctly

Post by ranig » 27 Aug 2019, 06:36

I meant the bug of the CP time diff not showing after lap 1, not the "feature" that Laps mode store the entire race in local records ;)
Your Trackmania resource for Nascar racing http://www.tm-nascar.com

Post Reply

Return to “UASECO”

Who is online

Users browsing this forum: No registered users and 2 guests