why is it not working ?

UASECO is a fork of the XAseco2/1.03 controller for Trackmania and has been overhauled to support the Modescript Gamemodes of Trackmania².

Moderators: undef.de, NADEO

User avatar
Arifeek
Posts: 10
Joined: 17 Nov 2019, 10:25

why is it not working ?

Post by Arifeek » 18 Nov 2019, 12:18

hi i would like to know why some commands do not work ?? e.g./xlist map name and /stats

User avatar
Miss
Posts: 2116
Joined: 05 Jan 2016, 11:34
Location: The Netherlands
Contact:

Re: why is it not working ?

Post by Miss » 18 Nov 2019, 12:27

Check the logs when you type the commands. It should probably tell you why.
1070 GTX, Ryzen 3700X, 16GB RAM, Windows 10
Forum moderator, opinions are my own. :thx:
Check out Image openplanet, the alternative ManiaPlanet & Turbo scripting platform! (Openplanet subforum)
I also stream on Twitch and tweet on Twitter.

User avatar
Arifeek
Posts: 10
Joined: 17 Nov 2019, 10:25

Re: why is it not working ?

Post by Arifeek » 18 Nov 2019, 12:46

when I type the command / xlist map name

this information appears in the chat: no maps found, or MX is down

and when I type the command / stats, nothing appears, nothing happens

User avatar
Miss
Posts: 2116
Joined: 05 Jan 2016, 11:34
Location: The Netherlands
Contact:

Re: why is it not working ?

Post by Miss » 18 Nov 2019, 13:51

I mainly mean your server log (logs from Uaseco), not the chat window.
1070 GTX, Ryzen 3700X, 16GB RAM, Windows 10
Forum moderator, opinions are my own. :thx:
Check out Image openplanet, the alternative ManiaPlanet & Turbo scripting platform! (Openplanet subforum)
I also stream on Twitch and tweet on Twitter.

User avatar
Arifeek
Posts: 10
Joined: 17 Nov 2019, 10:25

Re: why is it not working ?

Post by Arifeek » 18 Nov 2019, 14:09

Code: Select all

[2019-11-17 16:08:18] [Chat] Player [cut3] used command "/xlist"
[2019-11-17 16:08:27] [Chat] Player [cut3] used command "/mxlist"
[PHP Warning] fopen(https://api.mania-exchange.com/tm/tracks/list/latest): failed to open stream: HTTP request failed! HTTP/1.1 500 Internal Server Error
 on line 223 in file /home/arif/tm2/serwer/UAseco/includes/maniaexchange/mxinfosearcher.inc.php
[PHP 4096] Object of class Message could not be converted to string on line 769 in file /home/arif/tm2/serwer/UAseco/includes/core/helper.class.php
[PHP Notice] Undefined variable: player on line 181 in file /home/arif/tm2/serwer/UAseco/plugins/plugin.mania_exchange.php
Last edited by undef.de on 18 Nov 2019, 14:25, edited 1 time in total.
Reason: Use code tags for code/logs

User avatar
undef.de
Posts: 2076
Joined: 06 Apr 2011, 21:57
Location: Germany, North Sea Coast
Contact:

Re: why is it not working ?

Post by undef.de » 18 Nov 2019, 14:26

This looks like an error in the API from ManiaExchange (returned HTTP 500 Server Error). You should report that at ManiaExchange (because I'm not sure that they listen here).

EDIT (added screenshot of ManiaExchange API):
ImageFull resolution
Developer of UASECO, a controller with support of the Modescript Gamemodes for TM².
Visit the official website for more: UASECO.org


Developer of various plugins for XAseco/XAseco2 and MPAseco, visit my lab: www.undef.name

You like what I do? Then award a ManiaStar.

User avatar
Arifeek
Posts: 10
Joined: 17 Nov 2019, 10:25

Re: why is it not working ?

Post by Arifeek » 18 Nov 2019, 14:54

when I type / stats nothing pops up :( as it is in tm1 :( nothing in this topic in uaseco logs

User avatar
undef.de
Posts: 2076
Joined: 06 Apr 2011, 21:57
Location: Germany, North Sea Coast
Contact:

Re: why is it not working ?

Post by undef.de » 18 Nov 2019, 15:21

Arifeek wrote:
18 Nov 2019, 14:54
when I type /stats nothing pops up :( as it is in tm1 :( nothing in this topic in uaseco logs
For the chat command /stats you have to enable the chat.stats.php in your config/plugins.xml, chat.stats.php is not enabled by default in UASECO.
Developer of UASECO, a controller with support of the Modescript Gamemodes for TM².
Visit the official website for more: UASECO.org


Developer of various plugins for XAseco/XAseco2 and MPAseco, visit my lab: www.undef.name

You like what I do? Then award a ManiaStar.

User avatar
Arifeek
Posts: 10
Joined: 17 Nov 2019, 10:25

Re: why is it not working ?

Post by Arifeek » 18 Nov 2019, 15:37

undef.de wrote:
18 Nov 2019, 15:21
Arifeek wrote:
18 Nov 2019, 14:54
when I type /stats nothing pops up :( as it is in tm1 :( nothing in this topic in uaseco logs
For the chat command /stats you have to enable the chat.stats.php in your config/plugins.xml, chat.stats.php is not enabled by default in UASECO.
work ;) thank you ;)

User avatar
Arifeek
Posts: 10
Joined: 17 Nov 2019, 10:25

Re: why is it not working ?

Post by Arifeek » 18 Nov 2019, 15:49

how can mass maps be added via the server?

Post Reply

Return to “UASECO”

Who is online

Users browsing this forum: No registered users and 3 guests