Running uaseco.sh

UASECO is a fork of the XAseco2/1.03 controller for Trackmania and has been overhauled to support the Modescript Gamemodes of Trackmania².

Moderators: undef.de, NADEO

Post Reply
savage24x
Posts: 22
Joined: 21 Jun 2011, 20:26

Running uaseco.sh

Post by savage24x » 01 Jul 2020, 21:45

Hello,

I have been running into an issue getting my windows installation of TM2 and UASECO working on Ubuntu 18.10 in Google Cloud Platform. Yes, I'm moving it to the cloud. I have been able to get the server to run successfully and connect to it. I can play maps and it sees me as a MasterAdmin properly. I can run webrequest.sh and it returns the random number as usual, but when I run uaseco.sh, it returns a number just like webrequest.sh would. I am not sure what the correct path the script should be changing directory to. In the UASECO documentation, it tells me to change directory to the same folder I'm already in, which makes no sense to me. What's the correct directory I should be going to?

Code: Select all

#!/bin/sh
cd /home/kendrick/Documents/UASECO/
php -d allow_url_fopen=on -d safe_mode=0 uaseco.php TM2 2>>logs/uaseco.log 1>&2 &
echo $!
You can see that it's currently set to: "/home/kendrick/Documents/UASECO/"

Here's what happens when I run it:

kendrick@tm2-dedicated:~/Documents/UASECO$ ./uaseco.sh
1805

Does anyone have any suggestions for this issue?

savage24x
Posts: 22
Joined: 21 Jun 2011, 20:26

Re: Running uaseco.sh

Post by savage24x » 01 Jul 2020, 21:49

Wow, I'm a complete idiot. Looked into an XASECO2 installation and you won't see output like you normally would on windows. You need to look at the logs under the log directory. Sorry everyone, waste of a thread.

User avatar
TMarc
Posts: 15430
Joined: 05 Apr 2011, 19:10
Location: Europe
Contact:

Re: Running uaseco.sh

Post by TMarc » 02 Jul 2020, 08:56

Not a waste, it might help others who encounter the same issue ;)

Post Reply

Return to “UASECO”

Who is online

Users browsing this forum: No registered users and 1 guest