Manage multiplayer scripts

Moderator: English Moderator

Post Reply
chapelier
Posts: 64
Joined: 08 Sep 2014, 16:43

Manage multiplayer scripts

Post by chapelier » 10 Mar 2018, 12:21

Hello,
I have an issue with creating a proram based on my title pack.
Until now i have this error "Script title in server configuration and program title must be the same".

if I understand the principle :
1. i create a program based on my title pack.
2. i create a server config based on a script of my title pack.
3. i can link together program and server config.

So i need to configure a script in my title pack. And logically it should be in "Manage multiplayer scripts".
so which file should i push as "Match settings" ? And what about "compatible map types" ?

My title pack is TMPLUS canyon and i want to configure a Time Attack server.

Thanks !

Tipiizor
Posts: 560
Joined: 17 Aug 2011, 01:19

Re: Manage multiplayer scripts

Post by Tipiizor » 12 Mar 2018, 13:32

:3
OS: Windows 7 Ultimate x64
CPU: QuadCore Intel Core i5-2500K@3.4GHz
RAM: 2x G Skill F3-12800CL9-4GBXL
GPU: Geforce GTX 970 EXOC
Motherboard: Asus P8P67-M
HDD(s): Sandisk ultra Pro II (240 Go) / WDC WD10EACS-14ZJB0 (931 Go)
Sound: Realtek ALC887

chapelier
Posts: 64
Joined: 08 Sep 2014, 16:43

Re: Manage multiplayer scripts

Post by chapelier » 27 Apr 2018, 12:32

So the answer is :
0. Go in the title pack admin panel, in the "Manage multiplayer scripts" submenu.
1. put a standard "Match settings" file like this one :

Code: Select all

<?xml version="1.0" encoding="utf-8" ?>
<playlist>
	<gameinfos>
		<game_mode>0</game_mode>
		<script_name>TimeAttack.Script.txt</script_name>
		<title>TMPlus_Canyon@tipii</title>
		<chat_time>10000</chat_time>
		<finishtimeout>1</finishtimeout>
		<allwarmupduration>0</allwarmupduration>
		<disablerespawn>0</disablerespawn>
		<forceshowallopponents>0</forceshowallopponents>
	</gameinfos>

	<hotseat>
		<game_mode>0</game_mode>
		<time_limit>300000</time_limit>
		<rounds_count>5</rounds_count>
	</hotseat>

	<filter>
		<is_lan>1</is_lan>
		<is_internet>1</is_internet>
		<is_solo>0</is_solo>
		<is_hotseat>0</is_hotseat>
		<sort_index>1000</sort_index>
		<random_map_order>0</random_map_order>
	</filter>

	<mode_script_settings>
		<setting name="S_TimeLimit" type="integer" value="7200"/>
	</mode_script_settings>
</playlist>
2. Verify what type of map your title set by default (see in the editor when you create a map). Write the same type in the "compatible map types" field. (in my case it was "race").

3. end !

Post Reply

Return to “Title Packs”

Who is online

Users browsing this forum: No registered users and 1 guest