My issues with ManiaPlanet 4.1

Moderator: English Moderator

Post Reply
User avatar
Timania
Posts: 34
Joined: 15 Jun 2017, 21:21
Location: Hannover, Germany
Contact:

My issues with ManiaPlanet 4.1

Post by Timania » 16 Nov 2018, 18:21

[The thread got updated in case for better organization. You can post your issues under this thread anyway.]



Hello! This is my thread to report my issues in ManiaPlanet 4.1 and i hope, the nadeo guys read this and fix it quickly. ^^

The list of issues/bugs/glitches gets daily updated. If there is a fixed bug, it will get a "(X)" for mark it as fixed.
Here are some issues i experienced:

Game:
- The game is really instable in its current status now. (X)
- Every camera change ingame via the numpad (standard) lags. That means, the whole game runs smooth while the cam change lags. (X)
- In the map editor if you click on "Record Mediatracker ghost" and you get the message "You need to place a standing point" your game completely freezes.
- In all titlepacks the 2D/3D decals are turning if the angle get adjusted. It may be annoying if you shoot some clips and bushes, trees and clouds turning because the camera do. Maybe make it solid 3d items. :D
- The shadows are not accurate, if you calculate it. On near, mid or far range the shadows looks like the antialiasing is broken. Even on ultra.

User Interface:
- Sound settings dont apply with the normal way (over the sound icon); they need to be changed over the new "settings" board to apply. (X)
- Translation are not 100% complete (for me it´s the german language). Theres are mixed way of English and your system language.
- At the "Crosshair" settings the crosshair doesn´t change in the preview if you choose another crosshair.
- At the "Crosshair" settings the player outline intensity doesn´t change in the preview if you change the intensity.
- The pictures of the channels doesn´t fit really into the new interface (normal title screen & future title screens). Maybe you should tell the channel creators to make some versions of the screens to fit these interface.
- Many information windows like "Planets" or the server information over this "Play the same server as your friend" button doesn´t disappear after leaving the menu. Maybe the menu should disappear if you click on a free space on the screen.
- [Idea] For the channels you maybe bring this preview back, if you clicked on a channel before you press "play".
- After clicking the ManiaPlanet button at the top bar the arrows doesn´t appear.
- At the "Options" from the left shortcut menu in the ManiaPlanet main menu the "Player Page" button don´t work and contains the old player page link.
- At the "input" settings you can´t change your analog deadzone. If you try to do it, it immediately goes back to default.
- At the "friends" window some people appears twice or even three times a row.

In-game overlay
- In-game the "vote" window on the left side of the screen overlaps things if you press "Tab" and you cant click anything there.
- [Issue report by rckz] In some cases you stuck in the "Please wait" screen while joining servers, server cant be left and the TA timer got ridicolus high (79h for example).
- [Idea] Apply most of the in game overlay to the new interface because with this mix it´s really weird. To that things count:
> Left shortcut menu in the ManiaPlanet main menu (and any menu there in the shortcut menu too)
> Sound volume settings (top bar, the volume icon)
> The whole titlepack overlay (in the ManiaPlanet main menu, if you view over your titlepacks and select a titlepack (where "Info", "Multiplayer" and "About" is))
> ManiaPlanet menu tutorial (if you click on the ManiaPlanet button in the top bar)
> Manialink overlay (the browser and the navigation buttons on the top bar)

Map editor
- You don´t have an indicator for the block position if you place or remove blocks. It is hard to find out where i place blocks. (X)

MediaTracker
- The reflections from a car that you anchored to a camera disappear for no reason.
- [Idea] Increase the car reflection. The only way to get really good reflections is to render the normal shot, then a shot with the car fully shiny and key it onto the normal shot.

Physics
- The physics of TrackMania²: Canyon are broken. Maybe it would be a good idea to bring back the MP3 canyon physics, since most of the players loved it. (X)

Titlepack
- Some nadeolive titlepacks (TM²: Platform for example) don´t work since the MP4 update. Please fix that.


Greetings
Timania
Last edited by Timania on 20 Dec 2018, 20:53, edited 10 times in total.
german trackmania artist.
est. MMXVII.
currently working as mediamaker for pulse and team artist for unbitn.

youtube. https://www.youtube.com/c/timania
twitter. https://www.twitter.com/timaniaTM
discord. https://discord.gg/FpexWue

User avatar
moimoi69
Posts: 41
Joined: 23 Oct 2016, 10:01
Contact:

Re: Some issues with ManiaPlanet 4.1

Post by moimoi69 » 16 Nov 2018, 18:25

So me i have this problem

-When we enter on shootmania storm the game does not find any server
-The game is a little slow
-For the channel mode I don't see much difference
- The parameters will have to be colorful with the game theme

moimoi69

User avatar
Timania
Posts: 34
Joined: 15 Jun 2017, 21:21
Location: Hannover, Germany
Contact:

Re: Some issues with ManiaPlanet 4.1

Post by Timania » 22 Nov 2018, 17:59

Ignore this post. See the top post to learn more.
Last edited by Timania on 28 Nov 2018, 16:28, edited 2 times in total.
german trackmania artist.
est. MMXVII.
currently working as mediamaker for pulse and team artist for unbitn.

youtube. https://www.youtube.com/c/timania
twitter. https://www.twitter.com/timaniaTM
discord. https://discord.gg/FpexWue

User avatar
purification
Posts: 1014
Joined: 11 Aug 2010, 17:59
Location: Resting at the beach, Coral Resorts, Lagoon
Contact:

Re: Some issues with ManiaPlanet 4.1

Post by purification » 22 Nov 2018, 18:29

- UI
We can ctrl-click on a replay, choose a mod, but can't choose an envicar anymore

Edit: I had a crash when attempting to load a Lagoon from other envi titlepack
Attachments
LogCrash_000000014080F2C1.txt
(50.31 KiB) Downloaded 3 times
YouTube
Ryzen 7 3700X - 32Gb RAM - GTX 1070 8GB
Windows 10 Home 64bits

Post Reply

Return to “MP4.1 REPORTS / BUGS / INFORMATION”

Who is online

Users browsing this forum: No registered users and 2 guests