Maniaplanet is crashing while loading the titles screen (online mode)

Moderator: English Moderator

User avatar
nighthawk4571
Posts: 530
Joined: 20 Aug 2011, 06:39
Location: QLD, Australia
Contact:

Re: Maniaplanet is crashing while loading the titles screen (online mode)

Post by nighthawk4571 » 20 May 2019, 23:27

That '443' still bugs me.

1. From your log (sample line):

Code: Select all

[Net] {10 140} NetHttpClient::Request POST relay02.v04.maniaplanet.com:443 game/request.php?session_id=8638594&request_id=4 (data = 685 bytes)
[MasterServer] {10 140} Request sent : GetStatsAndAchievements (relay02.v04.maniaplanet.com:443)
This is sending a request. I see no sign of a reply.

2. From my log (sample line):

Code: Select all

[Net] {128 231}  Headers(1) for https://relay02.v04.maniaplanet.com/game/request.php?session_id=8612543&request_id=22: HTTP/1.1 200 OK
Here is a request and a reply (HTTP/1.1 200 OK).

It is obscure, but my new suspect is a failed SSL request to the relay02.v04 server. Of course, SSL relies upon certificates, which need to match the client with the server to allow onforwarding to various (server-based) services. To me, this seems an unlikely scenario with a Maniaplanet host server. So I ask, is your router or some other device or system software blocking these outgoing requests? Is your firewall really allowing Maniaplanet to talk via the net, both outgoing AND incoming, particularly for chat?

Does this point at least give a clue? I think I am heading into a difficult area here, beyond my regular analytical skills, so maybe this is proof that I simply cannot see the problem - cannot offer a solution - because I've reached the limit of my stupidity...

But The '443' thing still tells me there's a faulty file or process somewhere, which brings me back to (possibly) net-related Windows or MP system files.

Sorry mate :cry: . ( Resumes banging head on walls ).

Cheers ..... :pil

PS: I wonder what this is about:

Code: Select all

[Net] {11 133} NetHttpClient::Request GET s3-eu-west-1.amazonaws.com:443 /maniaplanet-4-profilechunks/34186/
(amazonaws.com, also with a 443 suffix)? Is this a cloud service which NADEO use? I've never noticed this in any of my logs.
Nighthawk
Getting old, forgetting most of what I ever learned !
My name is Nighthawk. The 4571 used to be my IQ.
Image

Admin: http://bagracing.freeforums.org/portal.php
U-tUbe: https://www.youtube.com/user/bvnighthawk

User avatar
Miss
Posts: 1819
Joined: 05 Jan 2016, 11:34
Location: The Netherlands
Contact:

Re: Maniaplanet is crashing while loading the titles screen (online mode)

Post by Miss » 21 May 2019, 00:23

Yes, they use AWS for their big data storage.
1070 GTX, i7 4790k, 16GB RAM, Windows 10
Forum moderator, opinions are my own. :thx:
Check out Image openplanet, the alternative ManiaPlanet & Turbo scripting platform! (Openplanet subforum)
I also stream on Twitch and tweet on Twitter.

User avatar
TMarc
Posts: 14937
Joined: 05 Apr 2011, 19:10
Location: Europe
Contact:

Re: Maniaplanet is crashing while loading the titles screen (online mode)

Post by TMarc » 21 May 2019, 16:38

interesting thoughts with the port 443.
I have just checked, 443 is not used and also not blocked after startup of Windows 10.
For testing, I have set my PC to get unfiltered access to the internet in the Fritzbox, but it did not help either.

Using netstat -na I can see many requests active using :443, mostly some Windows / Microsoft services.
And I'm also able to login to the player page using the webbrowser and https:// connection, which also uses Port 443.

I had one thought: I used the second ethernet port of my mainboard by error, but switching back to the first port did not help either.

So this leads me to the conclusion that it is either related to the later Windows 10 updates and an option I'm not aware of,
or that my Maniaplanet profile is buggy online.

Also changing the distro between beta and release did not help.

However, Maniaplanet should not crash like that :!: :roll:
maniaplanet forum global moderator

Link list with FAQ, Support, Wiki, Tutorials, Community activities, and much more.

System specs: Intel i7-970 12GB RAM, nVidia RTX 2060 6GB, Creative SB X-Fi, 2xSSD 1xHDD

User avatar
nighthawk4571
Posts: 530
Joined: 20 Aug 2011, 06:39
Location: QLD, Australia
Contact:

Re: Maniaplanet is crashing while loading the titles screen (online mode)

Post by nighthawk4571 » 21 May 2019, 23:02

OK, that's one more theory gone into the bin. More thought needed. We are both still sane (sort of in my case) and you are at least able to play. So we shouldn't give up yet.

On the other hand, fate may hand you a solution: As you know, there have been a few small game updates over the past week or so. Maybe another one will inadvertently fix your issue (i.e.if it is indeed within the Maniaplanet package).

Cheers for now ..... :pil
Nighthawk
Getting old, forgetting most of what I ever learned !
My name is Nighthawk. The 4571 used to be my IQ.
Image

Admin: http://bagracing.freeforums.org/portal.php
U-tUbe: https://www.youtube.com/user/bvnighthawk

User avatar
TMarc
Posts: 14937
Joined: 05 Apr 2011, 19:10
Location: Europe
Contact:

Re: Maniaplanet is crashing while loading the titles screen (online mode)

Post by TMarc » 07 Jul 2019, 18:43

Unfortunately the issue persits with the latest updates.

Starting Maniaplanet in online mode crashes.
Starting Maniaplanet in silent or offline mode is working fine.
But it crashes whenever I enable the chat.

This is really weird.
A crash log does not exist, and the debug log is just cut...
maniaplanet forum global moderator

Link list with FAQ, Support, Wiki, Tutorials, Community activities, and much more.

System specs: Intel i7-970 12GB RAM, nVidia RTX 2060 6GB, Creative SB X-Fi, 2xSSD 1xHDD

Post Reply

Return to “MP4.1 REPORTS / BUGS / INFORMATION”

Who is online

Users browsing this forum: No registered users and 1 guest