Page 1 of 2

Laps mode server instability

Posted: 25 May 2019, 17:00
by Spammiej
19 months ago I found the issue where playing laps mode with a massive amount of players results in very bad server behaviour. Today I decided to give it another go and see if the latest updates to the dedicated have done something for this mode. Long story short, I think it has become even worse than it already was... In previous forum post which dates back to June 2018 I've mentioned the notorious lap 12 problem. Today I had the same server problem occuring in lap 12...

Down here is a list of findings that happened to a lot of players after lap 12;

Some of the clips have me or others acting pretty strange. I was in a emotional rollercoaster of things braking down and I needed to find my laughter somehow sorry.

1. Cars shrinking, cars jumping & high pitched engine sound (This particular engine was custom made so it was higher compared to other cars) https://clips.twitch.tv/SilkySuperBaconDoritosChip
2. VRAM went skyrocketing (client side)
3. Cars were visible even when having them turned off. Scoreboard was showing them as Team Display (Red and Blue colors) https://gyazo.com/a5d84d3c65a2ed2f1f396d8acbdd35fd
4. People got reset to the start lap 1 https://clips.twitch.tv/PolishedDaintyBatMau5
5. People were forced into spectate
6. People got a desktop crash (See attachments)
7. People received a Maniascript error https://gyazo.com/93152a35d35cee347ecf63601ac6ecb0 this resulted into huge FPS drops to about 20~ I myself got this error also https://clips.twitch.tv/FrozenFurtiveHyenaOpieOP
8. Timer froze and checkpoints would not count
9. Lost complete control over the car, not able to steer etc
10. Speed and distance were set to 0 no matter how fast you drive

I am kinda at a loss for words but what would be needed for you guys to figure out the rootcause of these issues? It's just that it's been going on for 19 months and I am getting sad...

Complete VOD from start to finish: https://www.twitch.tv/videos/429703478
Old topic where this problem was discussed: viewtopic.php?t=42355

Thanks for reading...

Re: Laps mode server instability

Posted: 25 May 2019, 17:20
by Nerpson
What is this laps game mode? Is this the official one that you can find here? Or are you sure you had the scripts up-to-date? The MS error screen shows us a weird code not even respecting the code conventions established by Nadeo.

Re: Laps mode server instability

Posted: 25 May 2019, 17:25
by Spammiej
Nerpson wrote:
25 May 2019, 17:20
What is this laps game mode? Is this the official one that you can find here? Or are you sure you had the scripts up-to-date? The MS error screen shows us a weird code not even respecting the code conventions established by Nadeo.
Yes it is indeed the official laps mode

Re: Laps mode server instability

Posted: 25 May 2019, 18:12
by Nerpson
Were you using server plugins? Apparently yes according to the video. The error screen must have been triggered by them. One of them is doing heavy work on every waypoint and seem not to be optimized for 12 laps with this amount of players. The CTDs are not normal in all cases and must have been triggered by something more serious.

Re: Laps mode server instability

Posted: 25 May 2019, 18:20
by toffe
@Nerpson
The server had a lighter version of PyPlanet running. Lighter means that for example the most performance impacting apps were not activated. The few widgets that were active are not that heavy and are well optimized.

Re: Laps mode server instability

Posted: 25 May 2019, 18:38
by Nerpson
Ok, do you recognize one of your plugins in the error screen then?

Re: Laps mode server instability

Posted: 25 May 2019, 19:15
by Spammiej
I appreciate your help, however in the past 19 months we've done multiple test editions where we have disabled all plugins which result in the same server issues. Focussing on this main error does not remove the fact that cars get small and all of the other above, this problem is way deeper then just this small error message you are focussing on.

To add something to this, the current plugins used during this race also are being used for the riolu's XD race which runs flawless

Re: Laps mode server instability

Posted: 25 May 2019, 20:34
by undef.de
Maybe it is a good idea to test if the controller cause this problems or the gamemode only.

Re: Laps mode server instability

Posted: 25 May 2019, 20:59
by Miss
So what this looks like to me (what you're describing, all these issues) is some player class objects (likely CGamePlayerInfo being overwritten randomly. This can have many different causes, and is 100% an engine bug, not a gamemode bug. (Although it could definitely be triggered by something specific to the laps mode script..)

Is this reproducable reliably for you? If so, Nadeo could connect to your server and find out what's writing to those objects and fix the problem from there.

Edit: It's a wild guess of course.. there's a lot of different things that could be happening but it's definitely something going wrong with player info objects.

Re: Laps mode server instability

Posted: 25 May 2019, 21:19
by w1lla
i wonder why the existkeys don't use a ! especially for those player objects so i think Miss is true on that part and it might solve probably 25% of the issues.