ManiaPlanet 2 Beta Server 2012-08-14 - beta1.2e

Moderator: NADEO

User avatar
alexudallaTM2
Posts: 37
Joined: 09 Sep 2011, 18:55

Re: ManiaPlanet 2 Beta Server 2012-08-30 - beta1.2e

Post by alexudallaTM2 » 31 Aug 2012, 02:29

Please check your work before posting anything, this version does not work. :(

User avatar
xbx
Nadeo
Nadeo
Posts: 1154
Joined: 14 Jun 2010, 17:35

Re: ManiaPlanet 2 Beta Server 2012-08-30 - beta1.2e

Post by xbx » 31 Aug 2012, 11:14

alexudallaTM2 wrote:Please check your work before posting anything, this version does not work. :(
can you be more specific?
which version doesn't work, and how?
is it the windows server? I maybe didn't test the latest buld on windows, I don't remeber. I'll have a look.
(beacuse I'm running the linux server at the moment without any major problems)

User avatar
Jojo_44
Posts: 500
Joined: 12 Jul 2010, 15:58
Location: Germany->Bavaria
Contact:

Re: ManiaPlanet 2 Beta Server 2012-08-14 - beta1.2e

Post by Jojo_44 » 31 Aug 2012, 12:02

Hey,

I guess he´s talking about the windows server version because this version doesn´t work for me as well. Here is the crash log:
LogCrash_00456695.txt
The consolelog looks normal, maps is loaded sucessfully.

regards, Jojo
You do not have the required permissions to view the files attached to this post.
Image
my english sounds very unfriendly but it isn´t ;)

User avatar
xbx
Nadeo
Nadeo
Posts: 1154
Joined: 14 Jun 2010, 17:35

Re: ManiaPlanet 2 Beta Server 2012-08-14 - beta1.2e

Post by xbx » 31 Aug 2012, 14:23

aaah. it's actually trackmania that doesn't work, while shootmania does. sry... :oops:

User avatar
Jojo_44
Posts: 500
Joined: 12 Jul 2010, 15:58
Location: Germany->Bavaria
Contact:

Re: ManiaPlanet 2 Beta Server 2012-08-14 - beta1.2e

Post by Jojo_44 » 31 Aug 2012, 14:28

xbx wrote:aaah. it's actually trackmania that doesn't work, while shootmania does. sry... :oops:
Ups sorry, I should have mentioned it ^^
Image
my english sounds very unfriendly but it isn´t ;)

kremsy
Posts: 1720
Joined: 21 Jul 2011, 09:51

Re: ManiaPlanet 2 Beta Server 2012-08-14 - beta1.2e

Post by kremsy » 31 Aug 2012, 14:40

xbx wrote: Please note that we're also testing a different setting in the bandwith control that will pretty much max out the bandwith you set in the configuration file.
Can you be a little bit more specific, what will be the best Speed setting in the Config?? Should it be a value like 1000000 or something real?
Lukas alias Kremsy, Developer of:
ManiaControl: http://www.maniacontrol.com
ParagonLeague: http://league.paragon-esports.com
MPAseco: http://mpaseco.org
ManiaViewer: http://www.maniaviewer.com

User avatar
xbx
Nadeo
Nadeo
Posts: 1154
Joined: 14 Jun 2010, 17:35

Re: ManiaPlanet 2 Beta Server 2012-08-14 - beta1.2e

Post by xbx » 31 Aug 2012, 16:28

Slig wrote:There are still also problems with callbacks, at least for Canyon in Rounds mode :

Using the old API : 2 BeginRace after the BeginChallenge, and a 2nd EndRace after EndChallenge.
fixed.
Slig wrote: Using 'SetApiVersion','2012-06-19', BeginMatch and EndMatch are each sent 2 times, and BeginRound/EndRound are totally missing, and also no ManualFlowControlTransition is received (if ManualFlowControlEnable is used : the game just hang, waiting the ManualFlowControlProceed).
yes the situation is tricky here.
actually, if you want the callbacks for the "legacy" trackmania modes, you should use SetApiVersion('2011-10-06'), that will make the callbaks like in maniaplanet 1.
But if you're using scripts modes, then SetApiVersion('2012-06-19') will use the new callbacks that are unfortunately less precise (like no endround/startround, ...) but work with any script.

I can make the callbacks change depdending on the current gamemode, but that doesn't seem a good idea as the xml-rpc client wouldn't know what to expect.

Slig wrote: Also, i don't think that previously we got Status [6,Running - Exit] then [2,Launching] between challenges :

Code: Select all

[08/23,23:54:09.33,90.360]: TrackMania.EndChallenge
[08/23,23:54:09.33,90.360]: TrackMania.PlayerInfoChanged(Array)
[08/23,23:54:25.02,106.015]: TrackMania.StatusChanged(6,Running - Exit)
[08/23,23:54:25.08,106.073]: TrackMania.StatusChanged(2,Launching)
[08/23,23:54:25.16,106.158]: TrackMania.ChallengeListModified
[08/23,23:54:26.06,107.057]: TrackMania.PlayerInfoChanged(Array)
[08/23,23:54:27.72,108.714]: TrackMania.StatusChanged(4,Running - Play)
[08/23,23:54:27.75,108.746]: TrackMania.BeginChallenge
Last, i also got a problem in Fast (using ManualFlowControlEnable) : I receive the first (of the erroneous 2) EndRace before the last EndRound ; but i could not reproduce it with a simple script to check callbacks only, so this one is probably a bad side effect on my side.
I don't think I changed anything here. are you sure it wasn't like this before?
seems correct to me.

User avatar
xbx
Nadeo
Nadeo
Posts: 1154
Joined: 14 Jun 2010, 17:35

Re: ManiaPlanet 2 Beta Server 2012-08-14 - beta1.2e

Post by xbx » 31 Aug 2012, 16:40

kremsy wrote:
xbx wrote: Please note that we're also testing a different setting in the bandwith control that will pretty much max out the bandwith you set in the configuration file.
Can you be a little bit more specific, what will be the best Speed setting in the Config?? Should it be a value like 1000000 or something real?
in server 2012-08-30,
You should use the actual bandwith, in kilo bits per second, you want to allow for the game.
(1000000 was a hack to workaround a bug in 2012-08-14)

but there are still , apparently, lag on connection problems unfortunately. we keep working on it..

Flighthigh
Posts: 420
Joined: 29 Jun 2010, 06:48

Re: ManiaPlanet 2 Beta Server 2012-08-14 - beta1.2e

Post by Flighthigh » 31 Aug 2012, 16:55

xbx wrote:in server 2012-08-30,

This Serverversion dont run under Linux Ubuntu 12.04 LTS

The log say:

Code: Select all

[2012/08/31 17:52:21] Initializing...
[2012/08/31 17:52:21] Configuration file : dedicated_cfg.txt
[2012/08/31 17:52:21] Loading system configuration...
[2012/08/31 17:52:21] ...system configuration loaded
[2012/08/31 17:52:21] Loading cache...
[2012/08/31 17:52:21] ...OK
[2012/08/31 17:52:21] Listening for xml-rpc commands on port 5009.
[2012/08/31 17:52:21] Loading dedicated server configuration...
[2012/08/31 17:52:21] ...Dedicated server configuration loaded
[2012/08/31 17:52:21] Connecting to master server...
[2012/08/31 17:52:22] ...OK
[2012/08/31 17:52:22] Identifying on master server...
[2012/08/31 17:52:23] ...OK
[2012/08/31 17:52:23] Please wait, loading...
This is it. It wont going on.

Ozon3
Posts: 29
Joined: 11 Jul 2012, 15:52

Re: ManiaPlanet 2 Beta Server 2012-08-14 - beta1.2e

Post by Ozon3 » 31 Aug 2012, 17:48

Hi, master Server is down ? :


[2012/08/31 18:39:52] Initializing...
[2012/08/31 18:39:52] Configuration file : dedicated_cfg.txt
[2012/08/31 18:39:52] Loading system configuration...
[2012/08/31 18:39:52] ...system configuration loaded
[2012/08/31 18:39:52] Loading cache...
[2012/08/31 18:39:52] ...OK
[2012/08/31 18:39:52] Listening for xml-rpc commands on port 5000.
[2012/08/31 18:39:52] Loading dedicated server configuration...
[2012/08/31 18:39:52] ...Dedicated server configuration loaded
[2012/08/31 18:39:52] Connecting to master server...
[2012/08/31 18:44:53] ...ERROR: Internal server error
[2012/08/31 18:44:54] Exiting...

Post Reply

Return to “Dedicated Server”

Who is online

Users browsing this forum: No registered users and 2 guests