Feedback and Reports for the master branch from github

UASECO is a fork of the XAseco2/1.03 controller for Trackmania and has been overhauled to support the Modescript Gamemodes of Trackmania².

Moderators: undef.de, NADEO

User avatar
hacki65
Posts: 80
Joined: 20 Mar 2012, 12:56

Re: Feedback and Reports for the master branch from github

Post by hacki65 » 20 Jul 2018, 15:44

[ ISSUE PLUGIN CHECKPOINTS ]

Hi undef,

the last changes in "plugin.checkpoints.php" produce a new issue. If i have no local on a map, the first run shows the diff between my times and the worstest local (1:21:832). That's the expected behaviour.

But the second run (at this moment i HAVE A LOCAL) shows not the difference to my local (that i drove a minute before). Instead its checks for the same local as before (1:21:832). See screenshot.

Another player of our clan juked a map where he don't have a local and tested this behaviour too with the same result.
And then, as he leave the server and came back immediatly, the correct time diffs would be displayed (same map was running).

BTW: the cps bug is still present. If in db both settings are -1 no time diff will displayed on a map with local record is stored for a player. The settings in the plugin.checkpoints.xml has no effect. On our server this file is untouched so the default setting will be used.

Could you check this behavoiur please. Greetz hacki65

Image

User avatar
hacki65
Posts: 80
Joined: 20 Mar 2012, 12:56

Re: Feedback and Reports for the master branch from github

Post by hacki65 » 22 Jul 2018, 16:37

[ PLUGIN CHECKPOINTS ]
Mysterium. Yesterday, one day later, the plugin displayed the time difference correctly on maps where i don't have a local. Don't know what the hell is that. Its confusion.

User avatar
hacki65
Posts: 80
Joined: 20 Mar 2012, 12:56

Re: Feedback and Reports for the master branch from github

Post by hacki65 » 23 Jul 2018, 16:45

Hi undef,

a little bug found in Roundscore Widget. The Playernames flowed out of the screen. Can you check and fix this please? See Screenshot:

Image

Thx hacki65

speedychris
Posts: 147
Joined: 29 Dec 2011, 20:47

Re: Feedback and Reports for the master branch from github

Post by speedychris » 03 Sep 2018, 11:34

Since the current Snapshot is 1 month old und runs overall good when will be 0.9.6 released?
One thing i noticed (don't know if already posted): if i juke a map in the score screen this juked map is not displayed, only the next regular (=wrong) Map.

User avatar
Tavernicole
Posts: 36
Joined: 17 Aug 2011, 16:08

Re: Feedback and Reports for the master branch from github

Post by Tavernicole » 21 Nov 2018, 19:09

Hi all,

I'm unable to make UAseco work with the latest server release (2018-11-15) and the updated TMStadium@nadeo.Title.Pack.gbx. The UAseco process stops working during initialization. The issue seems to be located in records-eyepiece as if I remove it from the plugins.xml, the UAseco server works fine.

The yyyy-mm-dd-hh-mm-ss-uaseco.log shows the following:

1) Many lines such as this one:
[PHP Notice] Undefined index: POS on line 1372 in file path\UAseco\plugins\plugin.modescript_handler.php

2) Tons on lines such as this one:
[UASECO Exception] Error returned: "Connection interrupted while reading header" [2] at GbxRemote::query() for method "methodName" with arguments:
Followed by the dump of a variable.

methodName is not always the same, I can find: GetForcedMusic, SendDisplayManialinkPage (6 times), TriggerModeScriptEventArray (2 times), SetForcedMusic, SetCallVoteRatios, SetCallVoteTimeOut, etc

3) One line like this one:
[UASECO Fatal Error] ExecuteCallbacks XmlRpc Error [2] - Connection interrupted while reading header on line 1892 in file Path\UAseco\uaseco.php

This line is followed by other exceptions (see 2) and the file ends abruptely.


I understand that there's a communication failure between UAseco and the Dedicated server, I precise that (1) the three processes are located on the same computer (dedicated server, webrequest and UAseco) and (2) that it's not a fresh install, I updated the dedicated server and the Stadium title pack that were running the previous versions and UAseco 0.9.5 without changing anything in the configurations.

What am I doing wrong? Would the log file be useful?

It's a test server, so if you want me to perform additional checks or modifications, you're welcome.

Best Regards,
ヅわ てavernicole
- Team Chameaux -

User avatar
undef.de
Posts: 1847
Joined: 06 Apr 2011, 21:57
Location: Germany
Contact:

Re: Feedback and Reports for the master branch from github

Post by undef.de » 21 Nov 2018, 21:44

Tavernicole wrote:
21 Nov 2018, 19:09
1) Many lines such as this one:
[PHP Notice] Undefined index: POS on line 1372 in file path\UAseco\plugins\plugin.modescript_handler.php
You have to be in sync with the changes: https://github.com/undeflabs/UASECO/blo ... nfig-files :thumbsup:
Tavernicole wrote:
21 Nov 2018, 19:09
2) Tons on lines such as this one:
[UASECO Exception] Error returned: "Connection interrupted while reading header" [2] at GbxRemote::query() for method "methodName" with arguments:
Followed by the dump of a variable.
The Method "GetForcedMusic" lets the dedicated server crash without any entry in the logfiles. If you want to use UASECO (doesn't matter which version), you have to disable the plugin.music_server.php.
Developer of UASECO, a controller with support of the Modescript Gamemodes for TM².
Visit the official website for more: UASECO.org


Developer of various plugins for XAseco/XAseco2 and MPAseco, visit my lab: www.undef.name

You like what I do? Then award a ManiaStar.

User avatar
Tavernicole
Posts: 36
Joined: 17 Aug 2011, 16:08

Re: Feedback and Reports for the master branch from github

Post by Tavernicole » 23 Nov 2018, 20:57

Removed the plugin "music_server", corrected the contents of the config files, everything works perfectly now.

Thanks undef!

:thumbsup: :1010
ヅわ てavernicole
- Team Chameaux -

User avatar
undef.de
Posts: 1847
Joined: 06 Apr 2011, 21:57
Location: Germany
Contact:

Re: Feedback and Reports for the master branch from github

Post by undef.de » 23 Nov 2018, 21:54

Tavernicole wrote:
23 Nov 2018, 20:57
Removed the plugin "music_server", corrected the contents of the config files, everything works perfectly now.
The 2018-11-22 release of the dedicated server fixed the "GetForcedMusic" bug.
Developer of UASECO, a controller with support of the Modescript Gamemodes for TM².
Visit the official website for more: UASECO.org


Developer of various plugins for XAseco/XAseco2 and MPAseco, visit my lab: www.undef.name

You like what I do? Then award a ManiaStar.

User avatar
frode
Posts: 19
Joined: 16 Aug 2011, 19:57

Re: Feedback and Reports for the master branch from github

Post by frode » 31 Dec 2018, 19:35

My friend had to reinstall Maniaplanet, but now he gets error message when joining a Uaseco-server.
Image

He also gets black squares all over the place.
Image

Has anyone any idea what is wrong?

:thx:

User avatar
Miss
Posts: 1538
Joined: 05 Jan 2016, 11:34
Location: The Netherlands
Contact:

Re: Feedback and Reports for the master branch from github

Post by Miss » 31 Dec 2018, 21:25

I *think* that's a ManiaPlanet 4.1 issue? I think I remember seeing some other issues posted by mtkd that are similar.
1070 GTX, i7 4790k, 16GB RAM, Windows 10
Forum moderator, opinions are my own. :thx:
Check out Image openplanet, the alternative Maniaplanet & Turbo scripting platform! (Openplanet subforum)
I also stream on Twitch and tweet on Twitter.

Post Reply

Return to “UASECO”

Who is online

Users browsing this forum: No registered users and 2 guests