Deadlock - Unable to calculate the shadows

Moderators: w1lla, NADEO

Post Reply
User avatar
Harest
Posts: 69
Joined: 26 Mar 2018, 04:21
Contact:

Deadlock - Unable to calculate the shadows

Post by Harest » 28 Nov 2018, 22:59

Hi,

This thread is more here to ask if a condition could be added to avoid this deadlock more than anything because the bug i'll describe is probably very rare and exceptional, but also related to an old feature (old mix-mapping, enabling the removal of clips to any block).

The bug : The game thinks the shadows are calculated in high (reality : it's false), while also stating they're not calculated. Screenshot :
Image
This leads to the fact you're unable to calculate the shadows at all. It's greyed out, and placing then removing a block to then click on a button to calculate the shadows will not calculate them (it closes the window, probably considering it's done so instead of calculating "again" (as the game is thinking) it does nothing).
No shadows = map not playable (literally, it can't be started).

The bug is reproducible but in a very specific setting, again on the map i was building and i need to keep it private a few more weeks so i can only give it in private if wanted by Nadeo staff. I don't exactly know how it happened to be possible at this point. I just can tell i was building the map before 4.1 and was using the feature (old mix-mapping with OpenPlanet) without any issue. I was able to save the map with shadows calculated after the 4.1 one time, and it's with this version of the map the issue started. So it may be in fact related to 4.1.

Steps to reproduce :
  1. Open the map
  2. Ctrl+click the block i want without any clips, delete it with del.
  3. Press F3 to show the OpenPlanet menu and enable the editor developer tools.
  4. Click on advanced tools and enable old mix-mapping.
  5. Place the block again to where you deleted the block before.
  6. If there's still a visible clip, Ctrl+Z and Ctrl+Y to remove that clip.
  7. (Optional) Click on advanced tools and disable old mix-mapping.
I tried to find a variable for the state "is the shadows calculated (in high)" in the Nod Explorer without success. I tried with the command line to calculate the shadows without success. I thankfully found a way to still be able to calculate the shadows by using the old mix-mapping in another fashion : Instead of removing the block i wanted without clips, i activated the old mix-mapping, attached a block next to it at the side where a clip remained then removed that block*. Though i added also a few blocks after and that's maybe this rather than the other way to do the old mix-mapping that enabled me to calculate the shadows. Because while adding a block and removing it didn't work, adding one and keeping it seems to work in this situation.

So, imo it'd be easier to fix this bug by adding a failsafe : if shadows calculated is false and shadows calculated in high is true, then put shadows calculated in high to false as well and enable shadows calculation. Even if it's not the best way to deal with this ofc.

*Well, apparently i thought i deleted it but it somehow came back. Running the map a bit i figured the block i had deleted was back there. So yeah, the workaround is to place a block you don't remove. In a normal situation, placing and removing a block allows you to recalculate the shadows. You can for instance place a road block mix-mapped under the map if you're done with your map and don't want to add any visible block anymore.
On a side note, another weird stuff i kept having on this map is a macroblock i put 3 times in the map, one of them kept disappearing but only half of it. The macroblock was a mix of 3 embedded items, one of the 3 would just vanish (the one being used 8 times in that macroblock) while one of the 2 others (each used only 1 time in the macroblock) would duplicate. I never found how it happened so it appeared to me to be "randomly". At some point in the last edits of the map so in 4.1 when i tried to place the macroblock again at its supposed place, it would instantly reproduce the issue i just said. I restarted the game and it was fine again.

Post Reply

Return to “Trackmania² Reports”

Who is online

Users browsing this forum: No registered users and 0 guests