Newly embeddable materials don't work when the map is opened in the Map Editor

Moderator: English Moderator

Post Reply
User avatar
Harest
Posts: 91
Joined: 26 Mar 2018, 04:21
Contact:

Newly embeddable materials don't work when the map is opened in the Map Editor

Post by Harest » 09 Nov 2019, 17:17

Hi,
niebo26 wrote:
11 Oct 2019, 14:10
...
- Custom Game Materials : these materials are game materials in which you can alter some parameters (like PhysicsID for example). Compared to normal custom materials, these ones are embeddable in maps ! ...
This works well when you play the map normally, and it's awesome o/. Thanks a lot for that, perfect timing for my next map :thx:.

However, i just want to report a simple bug and easily reproducible: When you try to open a map in the Map Editor which has embedding item(s) with custom material(s), these custom materials won't work and will display a red texture. Only if you don't have the custom mat locally ofc. If you're the creator of them, it'll be fine.

Have a nice one,
Harest.

User avatar
niebo26
Nadeo
Nadeo
Posts: 133
Joined: 19 Apr 2011, 19:00
Location: Grenoble, France

Re: Newly embeddable materials don't work when the map is opened in the Map Editor

Post by niebo26 » Today, 09:47

Hi Harest,

This is a normal result. Custom Materials are not embeddable and the red material is a fallback when the game has troubles to load a material in an item. That's why unfortunately if you want to use custom materials, you'll need to give the Mat files or make a titlepack so people can play your map.
All of this doesn't apply to Custom Game Materials because they use game textures and thus can be embedded without any issue ^^

Niebo
"Don't mesh around !" - ® Haagse, 2019

SUPER SONIC SPEED !

Look for niebo26 in TMU & in TM² :)

Post Reply

Return to “MP4.1 REPORTS / BUGS / INFORMATION”

Who is online

Users browsing this forum: No registered users and 0 guests