[MP4][Obstacle][MT] Restarting doesn't reset MT clip conditions

Moderators: w1lla, NADEO

Post Reply
Ville
Posts: 44
Joined: 15 Jun 2010, 11:37

[MP4][Obstacle][MT] Restarting doesn't reset MT clip conditions

Post by Ville » 02 Dec 2019, 19:28

When you restart a run (by pressing 'delete') in Obstacle or TimeAttack TP, the MediaTracker clips you've taken on the previous run(s) carry through the restart. In other modes, like Battle, the restart seems to reset the conditions, as intended. This makes RPG maps in Obstacle almost impossible to make, as after your first run on a quest map, you can simply restart your run and have all the mandatory MT clips (quest objectives) already taken. In worst case scenario it can make the map completely unplayable more than once unless you leave the map after all of your runs.

The developer of Obstacle (smoke) hasn't done changes regarding the MT. The issue also exists in the old TimeAttack mode.

I've made a video showing the bug in detail here: https://www.twitch.tv/videos/344221225


To do this glitch:

1. Make a map in Obstacle editor and create two MediaTracker clips - the first one with "NotAlreadyTriggered 1" with any text block, transition fade or other observable block - the second one leave empty

2. Play the map in Obstacle mode

3. Take the empty MT trigger

4. Take the conditional trigger next - it should not display anything

5. Restart by pressing 'delete'

6. Take the conditional trigger again. It should not display anything again, because conditions don't reset correctly in Obstacle
OS: Windows 10 Home 64bit
CPU: Intel Core i5-3570K 3.40GHz, ~4.4GHz
GPU: Nvidia GeForce GTX 1080
RAM: 8GB

Post Reply

Return to “Shootmania Reports”

Who is online

Users browsing this forum: No registered users and 1 guest