ManiaPlanet 2 Beta Server 2013-05-22

Moderator: NADEO

User avatar
xbx
Nadeo
Nadeo
Posts: 1059
Joined: 14 Jun 2010, 17:35

ManiaPlanet 2 Beta Server 2013-05-22

Post by xbx » 22 May 2013, 18:12

hello all!

Here is today's update:
http://files.maniaplanet.com/ManiaPlane ... -05-22.zip

(or, as small patch to apply on top of 2013-05-16:
http://files.maniaplanet.com/ManiaPlane ... _delta.zip )

This is a just an update to include the latests fixes and script Api changes from today's client update.

User avatar
Xymph
Posts: 1284
Joined: 15 Jun 2010, 20:35
Contact:

Re: ManiaPlanet 2 Beta Server 2013-05-22

Post by Xymph » 22 May 2013, 20:42

Thanks, but two other minor fixes are still on your to-do list, then? ;)
Developer of XASECO for TMF/TMN ESWC & XASECO2 for TM²: see XAseco.org
Find your way around the Mania community from the TMN ESWC hub, TMF hub, TM² hub, and SM hub

User avatar
fng_thatoneguy
Posts: 665
Joined: 05 Jan 2011, 18:06
Location: That One Place
Contact:

Re: ManiaPlanet 2 Beta Server 2013-05-22

Post by fng_thatoneguy » 23 May 2013, 07:47

I'm curious to know why the files started being called ManiaPlanetDedicated_2013-04-11 and the fix released the next day, but the past three releases have gone back to being prefixed with ManiaPlanetBetaServer instead of ManiaPlanetDedicated. Is there a reason for this?
Image

User avatar
killer606
Posts: 459
Joined: 19 Jul 2011, 09:15
Contact:

Re: ManiaPlanet 2 Beta Server 2013-05-22

Post by killer606 » 23 May 2013, 15:42

Maybe I'm just to silly to do, but after the update I cant start Royal. I have in the .sh (/title=SMStormRoyal@nadeolabs) and the logfile tells:

Code: Select all

[2013/05/23 16:38:18] Initializing...
[2013/05/23 16:38:18] Configuration file : dedicated_cfg.txt
[2013/05/23 16:38:18] Loading system configuration...
[2013/05/23 16:38:18] ...system configuration loaded
[2013/05/23 16:38:18] Loading cache...
[2013/05/23 16:38:18] ...OK
[2013/05/23 16:38:18] Listening for xml-rpc commands on port 5223.
[2013/05/23 16:38:18] Loading dedicated server configuration...
[2013/05/23 16:38:18] ...Dedicated server configuration loaded
[2013/05/23 16:38:18] Connecting to master server...
[2013/05/23 16:38:18] ...OK
[2013/05/23 16:38:19] Identifying on master server...
[2013/05/23 16:38:19] ...OK
[2013/05/23 16:38:20] Please wait, loading...
[2013/05/23 16:38:22][b] ...ERROR: Title unknown.[/b]
[2013/05/23 16:38:23] Exiting...
Is there a new title name? or just a bug?

User avatar
fng_thatoneguy
Posts: 665
Joined: 05 Jan 2011, 18:06
Location: That One Place
Contact:

Re: ManiaPlanet 2 Beta Server 2013-05-22

Post by fng_thatoneguy » 23 May 2013, 16:07

Very good question. I don't have the answer, unfortunately, but I have a potential workaround while you're waiting for an answer.

See the Nadeo game mode scripts thread and download the Royal script. You'll need to change the title to "SMStorm" and you will be on its ladder rather than the "SMStormRoyal@nadeolabs" ladder, but it will let you have your server in the meantime.

(I know it will work because our server uses a customized version of that script and I had no problem after the upgrade.)

Good luck! :thumbsup:
Image

User avatar
killer606
Posts: 459
Joined: 19 Jul 2011, 09:15
Contact:

Re: ManiaPlanet 2 Beta Server 2013-05-22

Post by killer606 » 23 May 2013, 16:24

Thanks for your help. But its no problem, I've upgraded at first the Royal 2 but the Royal 1 is still online in old version. So I can wait :D

User avatar
fng_thatoneguy
Posts: 665
Joined: 05 Jan 2011, 18:06
Location: That One Place
Contact:

Re: ManiaPlanet 2 Beta Server 2013-05-22

Post by fng_thatoneguy » 23 May 2013, 16:32

Awesome! I hope you get an answer soon.
Image

User avatar
_BLiNK_
Posts: 52
Joined: 20 Jun 2010, 18:58

Re: ManiaPlanet 2 Beta Server 2013-05-22

Post by _BLiNK_ » 23 May 2013, 22:00

Relay server doesn't work...

@+
My Computer
OS: Windows 7 Pro 64 bit.
CPU: INTEL I7 3770K.
RAM: 16GB CORSAIR VENGEANCE 2 X 8 GO 2400 MHZ C10.
GPU: ASUS GTX 680 2GO DCU II TOP.
Motherboard: ASUS MAXIMUS V FORMULA.
SSD : SAMSUNG 840 PRO 256 GO
Sound: Realtek (onboard).

User avatar
Gugli
Nadeo
Nadeo
Posts: 510
Joined: 14 Jun 2010, 17:35
Location: Mon PC est à Paris, mais mon coeur rode dans les forêts de Lozère

Re: ManiaPlanet 2 Beta Server 2013-05-22

Post by Gugli » 24 May 2013, 15:34

killer606 wrote:Is there a new title name? or just a bug?
That's weird : I have a server running right now with "/title=SMStormRoyal@nadeolabs" and everything works fine.

The size of "./UserData/Packs/Royal.Title.Pack.Gbx" should be 9 036 808.
Its MD5 checksum is 01FAB434E33087BEF902D5BD5858609E.

Is it the same for you ?
--
(>~_~)> ═╦═ ╔╦╗ <(~_~<)

User avatar
Gugli
Nadeo
Nadeo
Posts: 510
Joined: 14 Jun 2010, 17:35
Location: Mon PC est à Paris, mais mon coeur rode dans les forêts de Lozère

Re: ManiaPlanet 2 Beta Server 2013-05-22

Post by Gugli » 24 May 2013, 17:40

Xymph wrote:Thanks, but two other minor fixes are still on your to-do list, then? ;)
Since I was at it, I fixed those 2 things. Should be OK in the next update.

The space was tricky though : our versionning-system keep telling me "no difference found" because white-spaces are not taken usually into account xD.
--
(>~_~)> ═╦═ ╔╦╗ <(~_~<)

Post Reply

Return to “Dedicated Server”

Who is online

Users browsing this forum: No registered users and 0 guests