MT: Light switch only switches on but not off

Moderators: w1lla, NADEO

User avatar
TMarc
Posts: 15104
Joined: 05 Apr 2011, 19:10
Location: Europe
Contact:

MT: Light switch only switches on but not off

Post by TMarc » 06 Jul 2013, 20:45

Why is the vehicle light not automatically switched on in tunnels (even if there is enough light there)?

So I tried to use a MT trigger to switch on the light. This works fine.
However, in the MT editor, in the preview of the vehicle light (there is a small arrow) the light goes off in the middle of the tunnel, and on again at the exit when I place a new trigger block there :?
And during the validation or racing the track, the light does not go off after the exit of the tunnel,
regardless if I put a new trigger block there, or if I use a long trigger block along the tunnel, or if I use two clips with individual trigger blocks for vehicle light.

Does anybody knows how to switch off the light correctly? :?
maniaplanet forum global moderator

Link list with FAQ, Support, Wiki, Tutorials, Community activities, and much more.

System specs: Intel i7-970 12GB RAM, nVidia RTX 2060 6GB, Creative SB X-Fi, 2xSSD 1xHDD

User avatar
GanjaRider
Posts: 317
Joined: 17 Jun 2010, 10:23
Location: The Netherlands

Re: [Valley] MT: Light switch only switches on but not off

Post by GanjaRider » 07 Jul 2013, 11:12

I have the same problem. An empty tirgger doesn't stop the vehicle light. And setting the time on a few seconds and disabling 'keep playing' doesn't help. The lights stay on the entire track.

User avatar
steeffeen
Translator
Translator
Posts: 2472
Joined: 14 Oct 2012, 16:22
Location: Germany

Re: [Valley] MT: Light switch only switches on but not off

Post by steeffeen » 07 Jul 2013, 12:09

cars with lights on look cooler anyways :D
    Game Mode and Title Pack Creator, Developer, ShootMania-Player & more

    ManiaControl, FancyManiaLinks

    User avatar
    Skeleton
    Posts: 592
    Joined: 23 Jun 2010, 19:42

    Car lights

    Post by Skeleton » 09 Jul 2013, 21:26

    Hi all, been away a while and not sure where we're up to with versions and all that.
    I'm back and just bought Valley. First I must say very good job but I do have a problem.
    Before I go into my problem I first must say there must have been an update at some point and we now have a light cone when we have our settings set low, great update, now I can see where I am going in the dark but now onto my problem.
    As I am very big on using mediatracker (still no small triggers I see but I wont go there for now) I have found a problem with vehiclelights clip. If I use it to turn lights off in night mood they don't turn off and if I use it to turn lights on in day mood they come on but with no light cone so can't see where you're going :?

    User avatar
    TMarc
    Posts: 15104
    Joined: 05 Apr 2011, 19:10
    Location: Europe
    Contact:

    Re: [Valley] MT: Light switch only switches on but not off

    Post by TMarc » 09 Jul 2013, 22:05

    merged topics, as it was already partially reported.
    Thanks for the addition with the day mood :thumbsup:
    maniaplanet forum global moderator

    Link list with FAQ, Support, Wiki, Tutorials, Community activities, and much more.

    System specs: Intel i7-970 12GB RAM, nVidia RTX 2060 6GB, Creative SB X-Fi, 2xSSD 1xHDD

    User avatar
    Skeleton
    Posts: 592
    Joined: 23 Jun 2010, 19:42

    Re: [Valley] MT: Light switch only switches on but not off

    Post by Skeleton » 09 Jul 2013, 22:11

    TMarc wrote:merged topics, as it was already partially reported.
    Thanks for the addition with the day mood :thumbsup:
    Thanks mate :thumbsup:

    By the way I found this not to be just a bug in valley, it's the same in canyon.

    User avatar
    TMarc
    Posts: 15104
    Joined: 05 Apr 2011, 19:10
    Location: Europe
    Contact:

    Re: MT: Light switch only switches on but not off

    Post by TMarc » 10 Jul 2013, 19:17

    OK, I have renamed the topic title accordingly (any TrackMania game - ok except Stadium, if it gets light one day ;) ) :thumbsup:
    maniaplanet forum global moderator

    Link list with FAQ, Support, Wiki, Tutorials, Community activities, and much more.

    System specs: Intel i7-970 12GB RAM, nVidia RTX 2060 6GB, Creative SB X-Fi, 2xSSD 1xHDD

    User avatar
    Voyager006
    Posts: 93
    Joined: 16 Jun 2010, 13:39
    Contact:

    Re: MT: Light switch only switches on but not off

    Post by Voyager006 » 12 Aug 2013, 16:56

    Same here (bump)

    The funny thing is that when you preview the clipgroup, it seems to work all fine :P
    In-game voyager006
    Discord Voyager006#8530
    Mania Exchange Voyager006

    Windows 10 | i7-920 | GTX 1060 6GB | 1920x1080 @ 60Hz | 1TB HDD | 8GB DDR3 | DirectX 12

    User avatar
    TMarc
    Posts: 15104
    Joined: 05 Apr 2011, 19:10
    Location: Europe
    Contact:

    Re: MT: Light switch only switches on but not off

    Post by TMarc » 10 Sep 2013, 00:17

    yeah :|
    maniaplanet forum global moderator

    Link list with FAQ, Support, Wiki, Tutorials, Community activities, and much more.

    System specs: Intel i7-970 12GB RAM, nVidia RTX 2060 6GB, Creative SB X-Fi, 2xSSD 1xHDD

    Mikey
    Posts: 212
    Joined: 16 Jun 2010, 01:22
    Location: Down Under

    Re: MT: Light switch only switches on but not off

    Post by Mikey » 28 Sep 2013, 15:01

    Confirmed , Valley and Canyon, MT lights on do not time out or get turned off by another MT trigger

    Post Reply

    Return to “Trackmania² Reports”

    Who is online

    Users browsing this forum: No registered users and 1 guest